• Hello, Guest! Welcome back, and be sure to check out this post for more info about the recent service interruption and migration.

The Definitive Guide to Connecting your SE/30

Mk.558

Well-known member
Greetings comrades,

Originally the Guide was written here, but it has grown far beyond its original proportions and thus requires me to host it off site for both post limitations and the need for regular updates. You can find it at the link here:

http://www.applefool.com/se30/

Good day!

 
Last edited by a moderator:

Mk.558

Well-known member
Reserved for future additions: a moderator might be required to edit this past a certain defined time.

A quick note: I edited my Help icon in the menubar so that it looks like the one from System 7.0 and 7.1. It's still 7.5 though, so don't be fooled.

Future note to do: 1) work on System 7.0 or 7.1; 2) System 6 FTP establishment; 3) build floppy that can connect to a computer that also boots; 4) get an email setup working properly; 5) this shall be filled by itself automatically with things to do (like a bigger hard drive, spare hard drive, working floppy drive for the internal bay etc); and 6) an IRC client that actually works. (Someone walk me through something...)

Oh and Windows? Eh, maybe some other time. I'll probably use FTP, as SMB isn't supported by 7.5.5. I heard that some versions of Windows (like 200 Server) can connect to these macs. I don't have Windows XP setup on my Mac mini Intel because I don't have a 10.5 disk. I like 10.4.11 better anyways but I sometime I'll get around to putting XP on it and figuring it out.

 

amatecha

Member
Amazingly informative post. Thanks! I just picked up an SE/30 on the weekend and this will be an extremely valuable chunk of info for when I finally get my hands on an ethernet card!

 

Mk.558

Well-known member
To update this thread, I just installed System 7.0.1 on my SE/30. (If I had only known it took up 2.8MB I could have done it much, much earlier...) I just installed it on the RAM Disk and copied the stuff over to the HDD once it was done.

I was able to mount my 10.2.8 iBook to the desktop with just the stock, basic install of:

• System Software for the SE/30

• EtherTalk Software

• File Sharing Software

...and that's all. Given that it mounts with 10.2.8 it should also work with 10.3 Panther, and definitely with 9.2.2. With 10.4.0, the computer doesn't even show up in Chooser. So I started Fetch 2.1.2, but found out that it needs VAS ( :?: ) or MacTCP. So when I have more time around I'll throw on MacTCP 2.1 and fiddle with it to see if FTP is the only way to connect to 10.3 (possibly) or higher.

This also reminds me, I was graciously sent a 250MB HDD to swap out my 40MB (which also has deterioration of the spindle bearings) so I wanted to copy over the 7.5.5 stuff I had left on the 40MB. Turns out the SE/30 would get the "Connection has unexpectedly broken" in Chooser, and this was through a router.

So if you have troubles like that, and a restart doesn't fix your issues, consider a crossover cable. Now it just works dandy (and through the router the 10.4.0 computer couldn't find the SE/30).

 

coius

Well-known member
do me a favor. I think I got a website that it will work on well.

go to:

http://coius.info:8080/

That is about as simple as a webpage you can get. no CSS/weird scripting. it's hosted on a PowerBook 540c, and will display on older browsers fine afaik. I coded it without all these "extras" so I intended it to served from an old machine, and viewed with old machines.

Works very well on my LC II under Netscape, so if you try it, see what it comes up like. I am interested in seeing how it renders on your system.

 

Mk.558

Well-known member
You wanted to host it there also?

:-/ If you want you can do as you please with my words. Maybe we can rig up a proper gopher style website that is actually useful -- news, bbs, trading post, craigslist proxy, etc.

To add to this Guide, I figured out that you can connect to an 10.2.8 (or earlier, maybe Panther as well) with just Classic Networking, and the need for OpenTransport is really required for 10.4.x or higher. Knowing that, you can make a System 7 boot floppy (7.5 is a bit too big) that can be a restore disk if something bad happens. Considering that the OpenTransport 1.3 files take up about 1.5MB space to begin with, not to mention AppleShare Client 3.7.4, you can adjust your options a little bit.

I don't know what System 7.0.1 and OpenTransport work like, I know OpT is compatible with nearly all versions of OS 7, but I don't know if OpT 1.3 is limited to 7.5.5 minimum or not. You may need to FTP into a 10.4.x or higher system to file transfer.

 

Mk.558

Well-known member
Has anybody else made headways in FTP under MacTCP, email clients that work (with what provider?) and so forth?

I tried installing AppleShare 3.7.4 to 7.0.1, but it doesn't work. OpenTransport 1.3 apparently does install, but without AppleShare 3.7.4 it won't work.

In order to connect to a 10.5 or higher machine you must use FTP. AppleShare simply won't work unless you have OS 7.6 or higher.

 

Mk.558

Well-known member
Just tried connecting to my 10.4.11 Mac mini under System 6 and Fetch 2.1.2. No response.

System 7 does the same thing. System 7 cannot connect to this version of AppleShare, it says.

Bottom line: System 6 to 7 must use a 10.2.8 (10.3?) or earlier machine. FTP is still out in the open. For 7.5.5, the max you can connect to is 10.4.11 and only under OpenTransport (or FTP). (I'll try FTP soon to 10.5.8.) For 10.5 and above, you might need 7.6 minimum. For Windows, FTP might work, or you might be forced to use Shareway IP Personal, or DAVE. (I tried DAVE 4 at macintoshgarden.com, and it failed because it's for OS 8 and/or 9. You'll have to hunt down an older version.)

 

theos911

Well-known member
A few weeks ago I was was trying to get FTP between my SE/30(system 6 boot disk & mactcp) and windows box. I was using Quick N Easy FTP Server 3.2 Lite. I recall my SE/30 getting a dir list... like once. However, fetch kept crashing. I'd do more testing, but I don't have a HD for my SE/30, so it is a real pain trying to do it all from floppies. I know I had to set a manual address similar to the one I was attempting to connect to. Sorry, I can't remember anymore details.

 

Mk.558

Well-known member
I don't know if you even need MacTCP to connect using AppleShare.

You should put a Minimal Install of System 6.0.8 on a floppy, and put RAMDisk 2.01 on it. That will at least free you some space. That application has the neat ability to copy a folder (if there is only one, it'll be the System Folder) and then quickly switch to it as it quits, ejecting the floppy.

I just tried to FTP into 10.5.8 under 7.5.5 (and if it doesn't work under OpT, it definitely won't work under 7.0.1) and it says there are too many connections.

The solution might be to put a FTP server on the SE/30, and then use an FTP client on the other computer. Ideally this should work from System 6 (because System + Finder barely even fits on a floppy in SSW 7.0.1) with 9.2.2 all the way to 10.7. Ideally.

Anybody here skilled at ZTerm? I'll be looking into that next. Using ZTerm opens a telnet hole, so if you're connected to the Internet and someone is running port sniffers up and down the port #'s that may not be so hot. There is a patch that does allow SSH. More.

 

TylerEss

Well-known member
Nicely done!

Also, this doesn't appear to be well-known, but you can do TCP/IP filesharing on old macs like the SE/30 by copying the "ShareWay IP Personal Bkgnd" application from a MacOS 9 install. You need to launch it manually, but sticking an alias into the Startup Items folder is sufficient. I seem to recall also that you need to use ResEdit and change a preferences resource that tells it not to start up on systems older than MacOS 9.

For email, there are a lot of options but they're all kinda kludgey. I wrote a howto on some options a few years ago, which is now back online at http://www.fenestrated.net/~macman/68kMail/

Also, for exchanging files with all manner of modern computers, I highly recommend running an FTP server on the old Mac itself. NetPresenz is a great and free FTP, Web, and Gopher server that works under both Classic (MacTCP) and OpenTransport networking. This should avoid a lot of the "my newer FTP server crashed Fetch" type problems.

Cheers!

 

Mk.558

Well-known member
That's good information. Do you happen to have the memory to know where the required hex bits are and what to change?

The copy of Shareway IP Personal in System 9 is pretty much intact as it was bundled in the system, just like System 7 and MultiFinder.

That NetPresenz sounds like a solid application. After all, if someone is still hosting a Commodore 64 web server, how hard can it be on a machine more than 8 times the computing power?

 

Mk.558

Well-known member
Funny how I refer to my own article for reference sometimes...

In case you might need to look up your DNS under Mac OS X:

Open System Preferences. Click Network. Select the service (AirPort, Ethernet, Bluetooth, Firewire) and select Configure (this is under 10.4). Click the TCP/IP tab. If nothing shows up under "DNS Servers" (unless you configure a different DNS) then head to Terminal and type this:

Code:
$ cat /etc/resolv.conf
This is what mine reads out at the moment:

Code:
icecubeW0A:~ icecube$ cat /etc/resolv.conf
domain domain.act.dsltmp
nameserver 192.168.0.1
nameserver 205.171.3.25
icecubeW0A:~ icecube$ []
I will see about setting up an FTP server under System 6 sometime soon. I really should do that so I can supply a System 6 Network Restore Disk. There's a 7.5 Network Access Disk but it won't boot my SE/30 even with 7.5.5 installed*, so a System 6 disk should be easier to manage. I supposed I could work on a System 7 Network Access Disk, but System and Finder barely fit on to a 1.44MB floppy. What I could do is use "1430K FREE" to enlarge a floppy space size, then strip SSW 6 down to the bone. System 6 is really doable for this, as System 7 wouldn't really give you any advantage (unless you somehow managed to install and fit OpenTransport to communicate with 10.4) and even at that, System 6 is really clever for switching boot volumes (like a RAM Disk or floppy) without restarting.

* I figure each major version updates the bootloader, just like with Mac OS X to a degree: I installed 10.5 first, then Windows XP, then 10.4, which messed up the bootloader so Windows wouldn't boot.

 

Mk.558

Well-known member
Okay. Now.

This is Shareway IP Personal Bgnd built into* OS 9 opened in ResEdit. I searched through all the resource fork catagories and snapped pictures of the relevant ones to help jog some old memories (Tyleress?) so I can figure out how to get this to work. It would be hot to use Opt 1.1.2 and some version of AppleShare under SSW 7 to ...maybe it won't work. FTP is always available. Sort of.

006407f0.jpg.3b6089076609ffed2bd5c46f62268b18.jpg


This is probably the required resource to change.

502f03f9.jpg.22e861e87d5cb5fadf387da7793c2daa.jpg


Yes. OS 9.2.2 comes with OpenTransport 2.8. Just so you know.

62523b34.jpg.57f62524f2dfccfbe84bb75a136db36f.jpg


Should be interesting to fiddle with this. I can't read the alpha code there though. I'd think they'd code it in hexadecimal.

The nice thing about FTP is when AFP refuses to work (SSW 7.5.5 has been taking forever to startup recently: about 30 minutes to startup File Sharing) is this can usually work.

97b5c62a.jpg.adf9ead49a8465f672cd99b042c02b4b.jpg


ca7d82fa.jpg.91203dcc7651cfbd9cbc9e00ff95da02.jpg


*: Insallation is optional, I'm told: it's been awhile since I installed OS 9 on a Mac, and the last time I did it was with the iBook which installs (more like restores) 9.2.2 from within OS X.

EDIT: Here is NetPresenz link. It won't work under System 6, or so it says. I'll continue investigating this.

 

Mk.558

Well-known member
I edited the field for gPRF to $0000, and using 7.5.5 cannot see or connect to a 10.5 system. I tossed the application (more like a daemon, there is nothing to indicate it is active aside from the dimmed image of the application) in the Applications folder and tossed an alias in the Startup Items folder.

I think the most reliable way to connecting using anything over 10.4 and Windows will probably require a server software kit.

EDIT:

20c67851.png.db953388bde50506998dd0ffc7e09050.png
Warning: Shareway IP Personal Bgnd crashes when attempting to shut down or restart the system (7.5.5). A fix may nor may not come along. Restart holding down the Shift key to disable Startup Items launching, as the program is always open and is only closed by the System shutdown procedure.

 

Mk.558

Well-known member
Apple may be considering changing their legacy software download page, I had some hiccups just now try to connect to

http://www.info.apple.com/support/oldersoftwarelist.html

....and it said the page cannot be found. It's working again, but I found this alternate link:

http://support.apple.com/kb/TA48312

I will be backing up critical download images to maintain a source for files listed here. I found that this project couldn't be completed easily without the Legacy Software Restore Disk. I recommend to all of you that you download it (just in case it gets pulled or the link goes bad) especially since the rate of decay these days on legacy software is often quite high.

One of these days I'll get to update this page with more content, EG: graphical tutorial on connecting under Win 2003 Server using AFP, hosting an email server, FTP Server under System 6, and so forth. Problem is most of this pertient stuff 1) is forgotten, 2) so antiquated that none of it is compatible any more (EG: SSL/SMTP email), 3) locked up in brains which have moved on to other things, and 4) no longer available due to broken links and general decay of digital media.

As we move faster and push on even harder in our futuristic quest of the utopian "idea" of the future, we leave behind artifacts at a increasing rate, making even a 25 year old computer a relic destined to die.

EDIT: I forgot to mention, with Shareway IP Personal Bgnd running (modified), I could not see or connect to 10.5.8. I think the universal solution is an FTP server, most optimally under System 6 in the case of emergency restore media.

 

zuiko21

Well-known member
For those of you with spare time and bandwidth, here's a 11 min. video of my SE/30 browsing the internet:


Sorry for the moiré :I I'm getting a WiFi connection shared from my sister's MacBook Pro, but works fine from a Linux laptop too.

My SE/30 configuration is:

20 MiB RAM

540 MB HD

(expensive) Asante MacNIC II/E PDS Ethernet card

System 7.5.5 (for any Macintosh install)

OpenTransport 1.1

Netscape Navigator 3.01

The setup procedure was surprisingly easy: TCP/IP control panel set to DHCP and there she goes... you can see the MBP with a manually set IP, but DHCP works fine on that side too. No special drivers were needed for the Asante card.

Thanks for the ideas!

 
Top