• Hello, Guest! Welcome back, and be sure to check out this post for more info about the recent service interruption and migration.

Designing RaSCSI case for CM4 IO board and OLED questions

I am working on getting a RaSCSI setup for using the Raspberry PI Compute Module 4. I have the I/O board and 1GB ram CM4 Lite(no onboard EMMC). I wanted to use a 2GB or 4GB version but they are out of stock at work due to chip shortage(I am a repair tech at Microcenter). Anyway, the whole reason is I am trying to get it to run from a NVMe SSD, since the CM I/O board has a PCIe 1x slot. Yes it is only PCIe 2.0 and only 1x but should still out perform any SD card in both speed and longevity. I had to order the NVMe adapter from Amazon due to the fact that I only had a 4x adapter.

Pic of the case I am working below in Fusion360. It's is current in the "did I measure and cut the holes in the right place" phase.

Anyway the real question here is this, is there a way to +5 volts OLEDs working on RaSCSI hat? The reason I ask is have a couple of screens from a project for a fast floppy gotek in my Amiga.

Also any other suggestions or ideas are welcome

Thanks
RaSCSI Case.png
 

Trash80toHP_Mini

NIGHT STALKER
Nice project! Don't do 3D CAD/printing yet, but I will be following your progress closely.

Raspberry PI Compute Module 4 with or without I/O board is something of great interest to me. Since you've experience with the CM4 architecture, do you nave any notions about linking PCIe 1x slot to PCI slot of Mac or Amiga for various uses over that high speed connection?
 
I actually don't know much really, just saw that the NVMe storage worked with the I/O board and the firmware had been updated to allow booting from it. Also read that for read/write speed that PCIe 1x > USB3.0 > emmc > microSD. As for routing PCI over pci express that is way out my league.

It just kinda coincided with my purchase of the RaSCSI hat so put the two projects together.
 
Ok got the OLED attached via jumpers and it kinda works. Set height to 64 in the script and still gives mostly grabbled display any ideas from anyone here on what is going on?
 
Top