• Updated 2023-07-12: Hello, Guest! Welcome back, and be sure to check out this follow-up post about our outage a week or so ago.

Powerbook 150 Boot Disk and General Questions

Hi new member here, I have just recently aquired a powerbook 150, I have some questions about getting it going.
The first power adapter I bought from the States an ADP-17AB a ''low power'' supply from what I have read (maybe on this forum) specifically designed for the 150.
the difference being the input is 0.5A and the original adapter is 0.35A (how is it the low power one has a higher input amperage?) They both ouput 7.5V 2A.
I tried to power on the powerbook but nothing happened so I checked the supply. A strange thing happened when I was measuring the voltage of that supply, while the DC remained very low or zero, it was measuring an AC voltage output of about 30V. I hope for the few seconds I had it plugged into the powerbook it didn't damage anything.
I got another power supply, a UK one this time and measured it before trying on the powerbook, it measured 7.78V. so I plugged it in and the powerbook made a chime and the screen lit up, it tried to boot but from the hard drive, made a few clicking sounds and then gave the wonderful floppy disk with a question mark box.
So the display looks really good, when the contrast slider is all the way to the left there was a very faint horizontal line in the middle of the screen but it goes away at normal level.
I did have a chance to take out the tracking ball and clean the rollers while waiting for the new power supply.
I really don't want to open it up if I don't have to, so the first step is getting a boot/tools disk and trying to repair the drive. The next oldest apple computer I have is a G3 tower, is the easiest option to get a USB floppy drive and make the boot disk/tools disk from the G3?
If the hard drive is dead, it looks like they are quite rare to find, as the powerbook max hard disk size is 2 or 4GB? also would this work https://www.amazon.com/Syba-Compact-Adapter-Enclosure-SD-ADA45006/dp/B0036DDXUM/?th=1 . Any advice is much appreciated.


Well-known member
Congrats on getting a 150!

Thing is though that nowadays, laptops from this time are very high maintenance. There are a few faults on the 150 that really need to be addressed in order to keep yours running. I've detailed them here on my website: https://www.macdat.net/macintosh/powerbook/100_series/150_home.html
Most important thing on that page though is to remove the PRAM battery! Your unit will be killed by battery leakage if you leave it in there any day now.

On the original hard drive: It's probably dead. Can you post a video of the sounds it makes on startup?

The 150 used Quantum brand hard drives, and these have a rubber bumper in them that goes sticky and causes the heads to stick. It's possible to fix this by opening the drive up and carefully tape over or replace this bumper. I failed with my drive though.

People have had luck with CF or SD card adapters in these things, but they can be a bear to format properly with the 150's utilities from what I hear. You'll want to format and set up the drive on your G3 for the best chance of getting it working. I can't give a whole lot more advice on that though as I'm currently running a 1GB spinning drive in mine.


Well-known member
Also: disregard the comment about the ELNA Long-Life PSU caps on the website. If you have one of the Low-Power labeled ones, yours won't have them as I've recently learned.


Well-known member
It's always going to be worthwhile getting a HDI-30 cable to provide access to SCSI peripherals. Then you can attach a standard SCSI external drive, and boot from it! First Boot from Floppy, system 7.1.1; then use Apple HD SC Setup to format the external HD and then install the full . Or for example, get a SCSI Zip drive from Ebay: the 68K drivers are certainly available.

I say this, because when I started with my PowerBook 1400 last December(ish), it had a 750MB HD, and no floppy drive, but I found I had a HDI to SCSI adapter and from there I was able to use my Zip drive and then PowerCD to start to get usable firmware onto it. Then I bought an SD drive adapter.

So... next thing. If @3lectr1cPPC is correct then it might be possible to recover enough of the HD to read the drivers from it. You can plug it into an IDE to USB adapter and then read it on a Linux machine using DD:

dd count=2048 if=/dev/TheNameOfTheDriveWhenYouPlugItInProbablySda1OrSda of=PowerBook150Drive.img

Which would copy the first 1MB of the drive to a file called PowerBook150Drive.img.

Finally, this thread might be useful:



Well-known member
IDE drives that old usually won't read on a USB adapter unfortunately.
If the bumper fix did work though, it wouldn't be a partial recovery, the drive would just work and boot.
Would a non apple branded hard drive work in the powerbook, for example an IBM drive, not just would It be recognizable and able to be formated with the tools disk but would it physically fit in the laptop? I have seen a 10GB IBM drive for sale, however I am thinking it would need to be partioned into 2GB segments from the G3 using a 3.5 - 2.5 IDE adapter, one of these https://www.amazon.co.uk/Desktop-Co...4202253&sprefix=3.5+to+2.5+ide,aps,182&sr=8-4, otherwise it might be easier to try the CF card adapter, does anyone have experience using one of these in a powerbook, it seems an actual low capacity hard disk is nearly impossible to find.


Well-known member
The drive I used was out of a 1400, so it was apple branded.
The 150 itself will recognize other drives, but the format utility won't work on them. It wouldn't even work with my apple-branded 1GB drive, which I formatted in a later PowerBook.

CF card adapters have been made to work in these, and SD adapters may also work.

The 10GB drive is too big, it may work if partitioned, but I wouldn't risk it.
I was able to make a tools disk from the G3, to test if the floppy drive on the powerbook is working. It is, it boots from the tools disk however it can't detect a hard drive either with the drive setup or disk first aid so it looks like the disk is dead.

I need some advice on opening the 150, I removed the screws, however it didn't want to come apart. It looks like there is some sort of clip next to the battery compartment, and it wasn't coming loose at that end.


Well-known member
There is another screw at the back by the ports, make sure you’ve removed that.

The battery has to be removed to get it open.

Then lift the whole top up from the back, disconnect the big cable near the ports on the inside, and hinge it up until the two clips at the front come free.
Thanks, I got it open, I didn't see that one.

It seems the battery has leaked, I will desolder it later.

I cant seem to get the old drive out, as there is a screw under the ribbon cable, the ribbon cable seems stuck, how do I get it disconnected?
I pulled the plastic ribbon a little but it seems stuck, I don't want to damage it.


  • battery.JPG
    1.6 MB · Views: 25
  • hard drive.JPG
    hard drive.JPG
    1.7 MB · Views: 20
  • cable.JPG
    1.7 MB · Views: 17


Well-known member
One of those screws above the drive should be holding it in. And yeah, get that PRAM battery OUT!
All things considered, that’s a very minor leak.
Now I'm having an issue where the rear screw housing is not lining up, and the bottom
two rear screws are just turning and not grabbing anything.
The metal battery bracket also came loose, I taped it down.
On the inside there was also this strange cylindrical piece of sticky foam
that seemed misaligned so I straightened it, maybe this or the expanded battery is whats causing it not to align right?
This is why I did't want to open it.


  • battery housing.JPG
    battery housing.JPG
    1.2 MB · Views: 16
  • casing.JPG
    1.9 MB · Views: 15


Well-known member
Something may be misaligned, it can happen. Take it apart and check everything over, it should fit back together. Make sure the interconnect cable is properly connected. It was a necessary thing to do though, that battery would have destroyed it.

Edit: wait, is the PRAM battery still installed? Clip it out!
OK I will, I was thinking it would need desoldering, I'll just clip it.
As for the hard drive, do you mean to remove the screws on the hard drive itself, I thought these were keeping the drive together.
There is the one screw next to the ribbon cable, the one under the ribbon cable that I can't ge to and the one next to the ribbon cable connection, that one seems to be blocking the ribbon connection from being removed?


Well-known member
I half desoldered, half clipped mine off.

The bracket the HDD is attached to has a screw above the drive, and another one by the cable. Then it should lift out.
I clipped off the battery, I'm still stuck getting the hard drive out, it has the top screw, the one by the cable and another one underneath the cable, I can't get to it without damaging the cable, and I can't seem to detach the cable without removing that screw...

Also here it that piece of foam that was at an angle when I first oppened the powerbook


  • screw.JPG
    1.1 MB · Views: 9
  • foam.JPG
    1.7 MB · Views: 9


Well-known member
You should be able to carefully push the cable out of the way, or unplug it. I was able to get mine out, just be careful not to tear anything.
I disconnected the ribbon cable from the motherboard and then gently lifted it to get to that screw.
I was then able to remove the drive, in order to disconnect the cable I had to remove the drive from its caddy first.

I then opened the hard drive, it seems the rubber bumpers were stuck but I was unable to get to them. I removed the two screws on the
top metal plate but couldn't remove the middle one it was stuck. The drive was getting a dust particle on it so I put it back together.

I taped down where the battery case had come loose, removed the stick of foam and it all went back together.

Now I await a new hard drive, unless anyone has Ideas about how to fix the old one.

I made the System disks and booted from disk one just for a preview.


  • tape.JPG
    1.8 MB · Views: 9
  • hard drive (2).JPG
    hard drive (2).JPG
    1.4 MB · Views: 10
  • startup.JPG
    3.9 MB · Views: 15