• Hello, Guest! Welcome back, and be sure to check out this post for more info about the recent service interruption and migration.

FleaBay Find: Duo 230 with DuoDock and a CL SE/30

gobabushka

Well-known member
Well my first Mac project in a while is two fold.

I got a great deal on a Duo 230 with the dock. Both work well, except the dock top clips are broken and the slot door is missing. After a trip to Florida for various reasons, it's all up here with me in NC and I can finally get started. 

While I was down there I also picked up my SE/30 that I got on Craigslist last year. Never fired it up, just bought it and put it in storage because I was in a major hurry. I also put off taking it apart because I didn't have a long T-15 anymore. A year later...find out someone had already removed those screws...lol

Got it apart, no battery boom boom, and it just needs a good cleaning and a recap. Should be good as new then!

Also everything could use a tad of retr0bright...especially the eBay lbd and mouse...

IMG_20181005_110829.jpg

IMG_20181005_111429.jpg

 

CC_333

Well-known member
I actually have a Duo and dock similar to that (can't recall the model #'s). I'm not sure it works though (a vague memory tells me that the prior owner (BMoW, actually) said it didn't).

Not sure I want to keep it or not. Guess it depends on whether it's fixable.

c

 

TimHD

Well-known member
Anyone tried to get a DuoDock working lately? I got one that was supposed to be working, but doesn't. Did a basic strip down, everything looks ok, not entirely sure where to start - was going to research what common issues are for the Duo Docks.

Separately, my Duo 230 boots for 20-30 seconds then just stops. Sometimes it goes for longer, sometimes shorter. Not sure what is causing that, but see it seems to be common and might be IC/transistor related though the differing cut out seems to suggest heat related (as need to leave it off for 5 mins before I can coax it to boot again).

Any thoughts from those who've had a play with Duos and their Docks.

 

Trash80toHP_Mini

NIGHT STALKER
There's a single component in the original DuoDock's PSU that's a very common failure point. Don't recall offhand, but it is or was a well documented fix. Mine failed back in the day, fixed it and it's still working.

 

TimHD

Well-known member
There's a single component in the original DuoDock's PSU that's a very common failure point. Don't recall offhand, but it is or was a well documented fix. Mine failed back in the day, fixed it and it's still working.
Do you recall what tests you did to fix the error (eg multimeter check on traces etc or are we talking transistor/chip level replacement that got it going)?

 

TimHD

Well-known member
Link seems not to work, but I managed to unpick it and I think this is what you were referencing as first hit (among others on a similar thread). https://aronnelson.com/aron/duoTick.html This, like others, identifies C28 as the culprit. Will give it a go.

NB: The PowerBook Duo 230 is going well again. Did a strip and reassemble after I noted some comments re importance of one of the screws needing to be in solid to help grounding or something. Working like a champ now. If only the Duo Dock was that easy to get going! Ta

 
Top