• Updated 2023-07-12: Hello, Guest! Welcome back, and be sure to check out this follow-up post about our outage a week or so ago.

Asante Mac Con issues


Hi fellow retro mac enthusiasts 

Do you know if it is common (??) for a Asante MacCon to break/cease to function?

I bought such a card from Italy quite some time ago, but have never been able to get it to work properly (on 6.0.8, 7.0.1, 7.1 and now 7.5.3 inside an SE/30).

I think i have tried everything actually. Putting a 10base-t hub in between it and my router (a Hirshmann mini-wg 6tp, a Netgear EN 104tp and a Raspberry PI model 2b (wich eth0 set to 10mbp/s half duplex acting as a wifi-hotspot from the ethernet side). It doesn't connect. I have tested MacIp 2.0.1, Opentransport 1.1.2 (i think it was) and the Asante diagnostics. It passes the memory test but fails on the next test.

I even bought an external scsi/rj45 unit and that one works fine, but i would love to see the internal Nic work as well.

The PDS connectors looks fine, i do get a link-led light when connecting the network cable.

When i check the properties in MacIp /opentransport, i can't see the hardware address of the MacCon-card (but when running the Asante util, it does see a MAC-address).

Could it be some bad solder joint? Something else?



Last edited by a moderator:


Well-known member
Isn't there a spillage of some sort on the main card? If conductive, that mess could cause a malfunction.



Well-known member
There is some kind of dusting on the cream colored connector, I would check/clean that.  I thought there was something in the first main card photo, but its not evident in the following main board photo, so it might be a reflection.



Some troubleshooting basics not mentioned as yet:

Is the fuse good?

Have you buzzed the cable for continuity/shorts?

Checked connector orientation? Some of mine are unkeyed on the NIC end, dumb@$$ move on the part of a very smart company!



Hi, to the responders above - i'm terribly sorry for my long delay in responding but i thank you for your replies earlier :) . During this time, i got hold of another Asante NIC that actually worked. But out of curiousity i tried to determine if it was the PDS card itself causing the issues or the daughter card and so i did some swaps. Old daughter card + new PDS -> worked fine. New daughter card + old PDS -> same issue, did not work, and so i realized that the issue is most probably the PDS itself.

By coincidence, i saw on another forum (applefritter) another gentleman telling about the same issue and in his case, it was apparently the clock-chip that was the cause of it (he heated it up a bit and that seems to have solved it in that case). I will try to locate this chip on my own board and try the same thing. Will ping back here when i have tried it out.


Well-known member
@my03 thanks a lot for reporting back! I happen to work on getting an old MacCon to work right now and I have trouble with a connector card it seems. It works fine with the AUI (and an external AUI->RJ45 converter), but doesn't negotiate with my modern router with the onboard connector.

Could you confirm that your "old daughter card" with the T7220A works with your modern networking switch/router? Or do you need to put a 10base-t hub in-between?

Old daughter card + new PDS -> worked fine. New daughter card + old PDS -> same issue
Just to make sure - so it's the daughter card with the T7220A chip that works for you?

Thanks for help!


Hi moldy,

yes, i can definitely confirm that the old daughter card works with the new PDS/main card, as does the new daughter card :)

Oh, and super interesting that you mentioned having a 10-base-t in between - when i wrestled with this issue on the "old" card, i kept reading that it needed this thing in between (10-base-t) and that more modern routers probably would not work and so i got this old device on Ebay (with AUI and 10base2/thin coax + rj45) but it still did not work. When i eventually got the new Asante, it worked straight away to my Netgear 1GB router without issues.

I did what the poster over at applefritter did (that solved his issues) and ordered a replacement crystal (
a THX model 9B-20.000MEEJ-B). When i get it, i will replace it and keep my fingers crossed :)