• Hello, Guest! Welcome back, and be sure to check out this post for more info about the recent service interruption and migration.

PowerBook 3400c Repair Stories

galgot

Well-known member
Probably unlikely... anyone have a 3400c logic board out that they'd be willing to take a picture of?  Specifically the underside right below the power adapter port and next to the ADB port.
Ok, So I pulled out my non-working 3400s stack :

Stack.jpg

Prepare for an all album of 240Mhz boards ,the part you've asked on the board ,

First two picts is one that would boot only to the chime, although it looks relatively clean.

From the third pict it's one very corroded , but the machine would boot to a grey screen only.

Top:

240-5.jpg

240-6.jpg

240-2.jpg

240-1.jpg

Under:

240-3.jpg

240-4.jpg

And this is a repair I've done on a trackpad button, just a piece of aluminum :

Repair-1.jpg

Repair-2.jpg

This is the added consolidation piece added to the hinges on the Kanga, that I was mentioning earlier. Shouldn't be too difficult to do in aluminum too :

Kangahinges.jpg

 
Last edited by a moderator:

MikeatOSX

Well-known member
Hi,

I got the Kanga as non working: black screen, no start chime, but HD spinning a while (using known good power adapter).

And: when I put in a PC formated empty disk, it's ejected after a while as normal.

A known good PMCIA-CF adapter card doesn't start it.

As I have a working 3400, I changed display, speaker panel and keyboard for a test: nothing but silent noise from the speakers.

PMU reset: same noise.

I also used the PRAM battery from the 3400, but meanwhile it could have been empty.

So I changed these parts back and the 3400 still works (thanks to Apple!). :)

What I saw: the little PMCIA board inside (for ejecting) lied on the logic board, pins broken.

Next I tested the Kanga's HD with an IDE-USB adapter on my current Mac:

the HD spinned very slow and only short and in this case I always use a two-way USB cable, for getting more power to the HD.

And boing! The HD bombed my Mac! :(

It's definitely defective.

So I supposed, the harddisk also may have damaged the PMU board.

Now I got a NOS PMU board for the Kanga in UK. I'm living in Austria, the Kanga is from New York. :)

Today evening I plan to use the new PMU board and I'll know more, I hope.

So I'm praying, that the logic board is still alive!

 

MikeatOSX

Well-known member
Yes I did it:

I swapped the PMU board, but that didn't help. :( Wasted money! :( :(

I tested with a known good PowerBook harddisk with system (and a CF-IDE adapter afterwards), disconnected PRAM battery, fan, keyboard and Trackpad.

I forget to mention, that I always have a clear good startup chime.

So the chime comes, when I connect the AC adapter and I can hear the harddisk spinning for 2 seconds, silence for 3 seconds and so on many times, but after a while the PowerBook shuts down and I have to start it again.

What next to test? Logic board looks good, but maybe that little broken PMCIA board did anything cruel to the logic board?

Or should I wait for the next Kanga?

Hmm...

 

raoulduke

Well-known member
Galgot - thank you very much!  I have to start working on my /200 board again; getting the solder off has proven pretty challenging.  I'm assuming none of those boards specifically have ADB problems, btw?  Nice job on the trackpad repair, also.

MikeatOSX, if you leave it on long enough with the fan disconnected it'll probably overheat and shut itself down.  If it's definitely not that, what exactly happens if you just leave it on with the flashing disk?  The broken PCMCIA board probably didn't do anything to the board, although if the 4-pronged connector is still connected to the board you might remove it; I guess there's a very small chance of a short, but I don't think it matters.  Are you just tossing HDs in or are you trying to install to them through the Kanga?  What happens when you boot from an install CD/disk tools floppy and just leave it on?  Does it still shut itself down?  It's also possible I'm misunderstanding your issues - the above was a somewhat diffuse description.

 
Last edited by a moderator:

galgot

Well-known member
I don' t think ADB is completely broken on these. The first one , non-corroded nice looking, was from a 3400c with a broken screen that i managed to boot with another screen before the board itself failed. Mouse was fine.

Second one , very corroded, i never managed to boot it completely. It chimes, goes to the grey screen, and sometime it can start to boot on pc card, then fails. When it does, a plugged mouse would move the cursor very erraticaly.

 

raoulduke

Well-known member
Interesting.  Random thought.  I think with the second problem I know what you mean - sometimes my broken board (when it worked) would boot to gray screen and sometimes to HD (past gray screen) seemingly at random.  I eventually noticed that the HD would boot it every time if I connected something to the SCSI port in the back.  I can't remember if I actually put a CD drive/HD in the enclosure I'd connect or if it's just the act of connecting something to the port.  If you ever have time I'd be very curious if you find something similar.

 

MikeatOSX

Well-known member
Are you just tossing HDs in or are you trying to install to them through the Kanga? What happens when you boot from an install CD/disk tools floppy and just leave it on? Does it still shut itself down?
HD and CF-Card were installed on a PB3400c - no way to install it on the Kanga, which is showing a black screen only.The fan was disconnected for a short time only for testing purposes.

The Kanga is reading a Mac boot disc several times and then stops, same as with the HD, with CF-IDE adapter I can hear or see anything of course - this adapter has no led.

PMCIA CF Adapter Boot-CF also don't do anything. So I cleaned contacts with special computer contact spray, waited the necessary time and put all things together.

The only new thing is the sleeping led, which appears sometimes, when I do a PMU reset.

And the starting chime always appears as if the Kanga were ok.

Yeah and the bottom gets warm! :D

Sorry, English is not my native language. ;)

 

raoulduke

Well-known member
Nor worries on the English.

* If you're going to leave the replacement screen in whatever - it's just useful for debugging to see some screen.  VGA out?

* (Ok on fan; I didn't think that was the reason it would shut down, just wanted to make sure; mine never shut down with fan disconnected - for like hours)

* Don't worry about the sleep LED (for now).

* The boot disk (floppy/CD? both?) makes the computer stop responding (freezes/crashes?)?  Do you have a) a different floppy module, b ) a different CD module, c) an external SCSI enclosure/CD/HD?

-  It's actually possible what I said to Galgot might work a little for you - try booting anything when you have a SCSI device/enclosure/cable (maybe) plugged into the port in the back.  **

If it cannot boot from any floppies or CDs then you need to start going through normal debugging - http://tim.id.au/laptops/apple/powerbook/powerbook_3400c.g3.pdf- starting where it says "Troubleshooting".  I apologize I could not find a German (German?) manual quickly.  Basically RAM reseating, various cable issues - but based on what you've said I don't think that's the problem with any of this.

** The best analogy, albeit imperfect, for my observation is that it's kind of like 'jumpstarting.'  Or, to steal from Amiga, Kickstarting.

 
Last edited by a moderator:

MikeatOSX

Well-known member
Yes I have absolutely everything to test. :)  I‘m a Mac user since 1992 and didn't give away anything.

And yes, I have all service sources for all Macs, but the Kanga / 3400 service source didn‘t help me.

I‘ve already tested with a PB 3400 display for several hours, no success.

Hmm.  :-/

 

raoulduke

Well-known member
Wait.  The 3400c display does not work with the Kanga?  I thought that it did.  If it doesn't then there are some more basic problems.  I assume you have taken the logic board out (not just looked at it)?

 

MikeatOSX

Well-known member
No I didn't take it out as I don't have anything to swap.

I cleaned a battery leaking PB 5300 logic board some weeks ago - which is working now, but I can't see anything wrong with this Kanga lb (on the upper side). It looks like new.

 

raoulduke

Well-known member
I don't want to suggest you do anything that will harm the Kanga - particularly because I think it'll be difficult to find a new logic board - but at this point I would take the board out, put it back in with nothing but the PMU and try to start it.  If/when that doesn't work I would (personally) start to clean the board.  I don't know what you used for the 5300 cleanup but I (at Unity's suggestion) have started usually with Rubbing Alcohol (Isopropyl) and Vinegar, and then something called Scrubbing Bubbles (http://www.amazon.com/Scrubbing-Bubbles-Fresh-Scent-Aerosol/dp/B00HY51IIM/) and then distilled water and then thorough drying.  I forget what caused my 3400c to start powering on the display but I think it was a journey to the center of the dishwasher.  However, these are also considered  extreme options.

 

MikeatOSX

Well-known member
Oops, dishwasher is not really my choice. :)

Or baking a logic board, as some guys do...

But yes, I'll take out the lb but not today. :)

 

galgot

Well-known member
You could try reassembling the all thing , and leave it unpowered but plugged to power brick for a night.

My Kanga was not booting one time, I think it was after changing the HD, no chime, nothing. Just the green light on top of the screen.

Left it a night plugged to power, next morning it booted. Go figure...

Maybe the PMU needs to powered for a while to be completely resetted .

What you could try too, see if it's booting on openfirmware (alt-cmd-o-f), then if so type "reset-all" and see if it boot normally.

Edit: will try that trick of plugging a SCSI device to boot tomorow...

 
Last edited by a moderator:

MikeatOSX

Well-known member
BTW: did anyone test a PB 5300ce display (800x600 active matrix) with a Kanga or PB 3400c?

For test purpose only.

 

raoulduke

Well-known member
The connectors won't fit.  So no.  There are probably also a slew of other incompatibilities.

But also if both VGA and a working 3400c screen don't work (I'm not sure actually about the 3400c screen compatibility but I would bet they are compatible), then it's probably not a screen/display issue.

 
Last edited by a moderator:

galgot

Well-known member
Progress : Just tried that SCSI trick, now the corroded 240Mhz board boots on a Zip. But unfortunately no ADB nor trackpad control, nothing. 

So I get on the desktop and can do nothing ;/ Note the internal drive doesn't show up on the desktop too...

Tried the same thing with the non-corroded but non-working 240Mhz board. No joy. I still get the chime, but nothing else, just black screen.

 
Top