• Hello, Guest! Welcome back, and be sure to check out this post for more info about the recent service interruption and migration.

Mode32 with Radius Color Pivot mouse freezes

tact

Well-known member
While working on my se30 that I recapped years ago, I recently picked up a Radius color pivot 030 card! on ebay. It works great but I found an odd issue... When I installed mode32 i think 7.5 latest version, the mouse freezes when it starts up, it still clicks and the keyboard still works, but it won't move. I switched the main screen to the se30's screen and the mouse works fine until it moves over to the second color monitor and freezes. Originally I thought it was because I only had 8mb ram and picked up 4x16mb simms anyway and upgraded to 68mb, only after that I found that the mouse only froze when using the radius color pivot screen and probably doesn't have anything to do with the ram lol.

Does anyone out there have a Radius color pivot card using Mode32 ever have this or any similar  problems? or can anyone maybe help? =)

Thanks.

 

BadGoldEagle

Well-known member
Megabyte has a SE/30 Color Pivot and so do I. 

His works while mine does not.

But he told me that his Color Pivot wouldn't work when Mode32 was on. So this restricts the RAM to 8mb max...

What kind of software have you installed ? 

I have uploaded these drivers from Radius. 

 

tact

Well-known member
Thanks for the reply Now I know its not just me lol.

Sooooo I have a color monitor and 60 extra megabytes of ram neither of which I can use together nor can I used mode32 to play any programs or games that require it... I'm glad I wasted the money buying all of that Lol

So here's the next question, Does anyone think it would work with a 32bit clean Rom installed? like a iifx iisi or a programmable rom simm?

I'm not wasting another 100$ on this if that still wouldn't work lol maybe someone can send me a rom to test this.

It not only restricts to only 8mb of ram but some software like Doom for instance, REQUIRES 32 bit to run even if you only have 8mb of ram. I managed to play it with the keyboard despite the mouse not moving lol. but then I can't do anything else or use all my ram.

I'm using os7.5.5 now and I Did download and install that radius pivot driver thanks for uploading it =) but I don't even think it does anything, isn't the driver built into the rom, which mine says v1.0 on it I haven seen v2.0 and v2.5 roms on boards out there maybe they fix this problem, What version do you guys have? =)

I'm working on recapping everything the analog board and power supply now.

I even scored a Diimo 030 50mhz.fpu!!! that was missing  a capacitor, Fixed! (Ill post more about this all elsewhere when I'm done)

So I would reeeaaallly Like to get this thing working....

 

tact

Well-known member
Yaknow I'll probably go and get that Mac Rominator programmable rom simm anyway, I'm very determined to get this thing completed and fully working =)

Anyone use that?

 

BadGoldEagle

Well-known member
There's no reason why this won't work. You can get the modded SE/30 mod from BMOW, which is 32bit clean and supports the HD20 Hard Drive (not scsi, the floppy port one which is not supported on standard SE/30s).

BTW, what monitor are you using for this? Apple branded CRT, LCD perhaps? I know the Pivot is very picky. I own the IIsi variant as well. It works in the /30 because the PDS slots are basically the same and one LCD works with the IIsi card while I can't get it to work with the SE/30 specific one...

 

tact

Well-known member
I'm using an apple 15" multiscan crt from back then, or plug into my current viewsonic lcd seems to be the same either way. or the viewsonic projector playing oregon trail on the big screen lol. 

what is this "modded SE/30 mod from BMOW"?

 

tact

Well-known member
I guess I have to try it , We'll see if 32bit clean will fix this problem. =)

Thanks

 

tact

Well-known member
I ordered that rominator and read it says ".. Some SE/30 hardware has trouble with the pre-programmed ROM image – see instructions for details.." lol I guess we will see what happens... ya with my luck hahaha

 

BadGoldEagle

Well-known member
I think this has been fixed. If not then you'll have to reprogram that one yourself with a IIfx or IIsi ROM. I keep forgetting which one is better for the SE/30.

 

tact

Well-known member
Well I got my rom-inator today really fast, But it did not work in my se30. I tried just about every configuration of ram I could and no difference I just get the typical garbage screen with no boot sound or anything. So I still have no idea if 32bit clean would even fix the problem with the mouse freezing on the radius color pivot screen . lol

Not sure what to do now....

 

tact

Well-known member
ok ok sorry for so many replys to my own topic lol, I pushed down on the rom-inator with a finger while turning it on and it gave me a boot screen , it seems to be a tiny bit thinner than the stock romm might not make full contact, I'll figure it out lol

 

tact

Well-known member
put a couple thin shims in there to hold it in place worked great, Now it will boot to the rom-inator! =D but.. Now i can't get it to boot to anything else, hard drive or boot disc. it stuck at Welcome to macintosh. I did remove the mode32 extension from the hard drive before hand, it wont even boot to a floppy disk utility. hmmmm. And when booting to the Rom-inator disk, it doesn't mount the hard drive. hmm

 

tact

Well-known member
Guh! SO many posts! So much progress XD I'll keep you All updated as I go crazy hahaha!

Switched to 32bit in the rom disk boot, now it shows my hard disk, it may have just been off the desktop screen  some of my icons are...

But it still won't let me boot to any other disk... Is this normal? Will the rominator only boot to the rom disk?

 
Last edited by a moderator:

tact

Well-known member
So i finally finished recapping everything and Did get the rom-inator to boot to 7.5.5 in 32bit mode... however... this did not fix the problem.. the mouse is still frozen on the radius color pivot screen... and now that its in 32bit clean mode I can't even hold esc during reboot to disable mode32 to fix it "sigh

so now I'm even more stuck.

So I have a fully recapped (w/sony psu) early model SE30 in perfect condition , with a Diimo 030 50mhz! (also recapped) , a radius color pivot card!, 68MB of ram!, a 2GB hard drive!, with an apple 12x! CDrom... And the dam mouse is frozen!!!! Hah So I can't quite use all of this together... Just yet, maybe if i can't get it working correctly maybe I can get a different color video card someday or maybe someone wants to make a trade for a different one that works in 32 bit =P

If anyone has any more suggestions or help I would Love it I'm sure you would all love to see this se30 be completed
 

I'll work together another post to fully illustrate my se30 adventure so far, just so tired right now guh

 

joethezombie

Well-known member
I don't have a Diimo, but I can try it with a Micron Xceed card.  I'm traveling right now, but maybe can put mine together next week.

 

rsolberg

Well-known member
Is the cursor freeze up consistent if the mouse is plugged into a different ADB port or if no keyboard is connected? How about a different mouse or trackball? I'm not suggesting the peripherals are at fault, just curious if the behavior changes.

 

tact

Well-known member
It doesn't make a difference of adb ports or keyboards and I don't have another device to try. The mouse still clicks, and the keyboard still works. And it only freezes once it loads the Macintosh OS screen, It also works when the  b&w Screen is the main screen the mouse moves around just fine but freezes when the cursor moves over to the radius color screen. Weird.

 

Paralel

Well-known member
Have you run a debugger hooked into the OS with verbose output to try and catch what is happening that is triggering this?

 
Top