• Hello, Guest! Welcome back, and be sure to check out this post for more info about the recent service interruption and migration.

Macintosh Portable resurrection (attempt) and diagnosys

ironborn65

Well-known member
In the schematics, PH0 PH1 PH2, and PH3 go straight to the external DB19 floppy connector
so I started checking for continuity and it was just fine BUT
... I noticed that in the schematics the pins of the SWIM are labelled 35, 32, 36, 31 (as in the schematics of the Mac Classic) while mine are 29, 26, 30, 25 (6 less). I start counting anti clockvise from the rounded corner as per the picture

How is it possible? Can the SWIMS be so different one from another?
I checked several times the correct orientation, but it cannot be in any case because the 35, 32, 36, and 31 would end up in two sides of the ISWIM.
I dunno, I'm lost now ... :(
Is there a pinout of the SWIM? I did not find any

1651878413395.png
 

SuperSVGA

Well-known member
... I noticed that in the schematics the pins of the SWIM are labelled 35, 32, 36, 31 (as in the schematics of the Mac Classic) while mine are 29, 26, 30, 25 (6 less). I start counting anti clockvise from the rounded corner as per the picture
You're off by 6. Pin 1 typically starts at the center pin on PLCC chips.
 

ironborn65

Well-known member
it was a good exercise, I successfully tested for continuity all the pins of the SWIM, PH, data, address, and control ..they all reached destination, so my soldering skills are good enough :)
So, I'm sticking to the point where: 1) without the SWIM the Mac chime, it stops the boot process, and 2) with any of the SWIM I have garbage on the screen, no boot and no chime.
Now I'm left with the only option of finding another SWIM. :(
I'd like to know how the SWIM is tested during the boot process, a cool thing would be to fool the boot sequence by a simple wiring to let it proceed even if the SWIM is not present.
Can you guys share your thoughts?
thanks for supporting me
 

ironborn65

Well-known member
does anyone know which are functions 4 DIP switches setting on the MB?
In the technical manual I read "disabling the on-board ROMs via DIP switches."
It could be - hopefully - related.
Can u pls tell me which are your setting in a working Portable?
I can not tell from the pics I find over the internet, too blurred and apparently they are not all the same
 

SuperSVGA

Well-known member
I think the normal state is to have 1, 3, and 4 closed (on) and switch 2 open (off).

Switch 1 connects ROM_WS to +5V and Switch 2 connects it to ground. I imagine having both closed simultaneously will short the +5V to ground.
I believe this is for configuring ROM timing, perhaps for slower ROMs or something.

Switch 3 connects the built in ROMs to the CS line. With this switch open, the internal ROMs won't be selected.

Switch 4 connects the reset line for the power manager. I can only assume this was so you could bypass the power manager by hooking one up at J21?
 

Berenod

Active member
I read in your first post about the scsi2sd led not blinking.
I've never used a scsi2sd (only blueSCSI) so I am not sure where they get their power from.
If they work of the power of the DB25 scsi ports found on the Mac's, then note that, just like the Mac plus, the portable does not put any power out on the DB25 port
You need to supply power to the scsi2sd some other way.
With the BlueSCSI I simply use a USB 5v supply on the provided micro-usb socket on the BlueSCSI.

On my SE on the other hand, the BlueSCSI simply works without any externally provided power ..
 

ironborn65

Well-known member
@Berenod I don't believe it's my case because the '?' icon does not show up, the boot sequence stops because the SWIM is not responding, the ROM is not yet attempting the boot from a device.
If it will ever pass that point u r probably right, external +5V power will be required
 
Last edited:

ironborn65

Well-known member
YESSSSS it works, finally. :):):):)
The emotion of the happy chime and the "Welcome to Macintosh" is invaluable!
Another Mac salvaged!
Thanks mates for following me in my tourney.

One of the two SWIM was bad and the other had to be pressed more firmly than what I did initially.

If I connect the internal Conner HD I had with the Portable it does not boot, not event the chime, so I'd like to setup a permanent SCSI2SD

- it boots with the SCSI2SD plugged in the external DB25 port with +5V from the berg connector. A fix I found for using the power rail says "Simple 4.7ohm resistor, and a regular 4001 diode from the 5V rail to the termination pin of the DB25 connector." : Is it advisable??
- I'd like to have the SCSI2SD inside. Is there a 32pin to 50pin converter?

thank you all
here is the picture of the recovered Portable!, yeah I know system 7.5.5 is too much (it's one I had in the SD), it's better to step down to 7.1 or less

1652393655659.png
1652394022100.png
 

desertrout

Well-known member
Oh that's great news! Congrats! That must have been a satisfying (and also a little face-palming) conclusion lol - we've all been there. :) She'll fly on 6.0.8
 
Top