• Hello, Guest! Welcome back, and be sure to check out this post for more info about the recent service interruption and migration.

De-serialize Lisa System and Lisa Office Diskettes


Well-known member
Since I spent so much time figuring out how to de-serialize Lisa diskettes, I figured I'd post the "how to" in order to perhaps help the community. There are a lot of bits and pieces on-line, but nothing really comprehensive. So here we go

Of course, an easy way to go is to download the diskette images (usually deserialized) and copy them on blank disks. But this is cumbersome, as you need to transfer the files from a modern computer to the Mac, with all kind of hardware and file format mismatch. Now if you have original Lisa System or Lisa Office (aka Lisa 7/7) diskettes, this would seems simple: just copy them onto the Lisa Profile or Widget. Well, chances are that these floppies have been copied once before on a different Lisa. And when you do this, Lisa writes your Lisa serial number on 4 bytes of memory in the diskette itself. If you then try to copy the diskettes again, Lisa compares its serial number to the one on the diskette, and if the two numbers don't match, it won't copy the files.

When the diskettes are new, these 4 bytes of memory are null (all zeros). So in order to make the diskette usable, you need to either copy your Lisa serial number on the diskette, or null out (fill with zeros) that particular location. The former option is more difficult, since you need a way to find out your Lisa serial number. It's possible, but cumbersome. The easiest solution by far is to null out the bytes.

Before you do anything, make sure you make a copy of your Lisa diskette. The best is to actually deserialize that copy, and not the original.

So what you need to do is to use Fedit, a byte-level file/volume editor. After you start the fedit program on your favorite vintage Mac, you should insert the Lisa diskette in question (System 1, or any LisaWrite, LisaList etc....). Your Mac will not recognize the diskette, but if fedit is running, it will ask you if you want to mount it. Go ahead and mount; then go to File>>Open Volume, and click on"drive" until "internal drive" shows up. Internal drive is your Lisa diskette. fedit will then display the first sector of the diskette. What you then need to do is to navigate to the sector number where the serial number is located, using the right arrow (or scroll bar) in the bottom. The first pic below shows sector 31 (in hexadecimal, red box) where this SN is located. For the Lisa 7/7 diskettes, the beginning of this sector always starts with .{Tx}obj (red box), where x is a number associated with the particular program. Here for instance, T5 is for LisaList. The bytes to null out are always the 8 hexadecimal digits in columns 2 and 3, on the 5th row of this sector (red box). Simply enable hexadecimal editing (cmd H), place the cursor over the first of the 8 numbers to null out, then type eight zeros in this location. Once this is done, you need to save the sector to the disk (cmd W), and you're done. I could not find a way to get the floppy to eject in fedit, but after closing it, I found that diskcopy 4.2 would do it, so this is what I do.

For Lisa System 1, the location of the SN to null out is a bit different (sector 1C, 13th row, bytes 38CC to 38CF - see last pic)

The table below summarizes the sector and byte location for each Lisa 7/7 program (both 2.0 and 3.0 version), as well as Lisa System 1. I hope this helps


LisaList (v3.0) Diskette after nulling out


Lisa System 1 (v3.0) Diskette before nulling out



Well-known member
I thought it was just the application disks that needed deserialization, and that the OS disks did not, but it's been a while and I could be wrong...


Well-known member
I thought it was just the application disks that needed deserialization, and that the OS disks did not, but it's been a while and I could be wrong...

This is correct, I think one of the original docs said to deserialize the LOS install disks, but I feel this is most likely incorrect as it works on previously used disks, only (some of) the tools are protected.

It might even be that when the LOS floppy is inserted the OS is merely updating a timestamp in the MDDF and not the Lisa's serial number, but haven't actually tested this.

I've also experimented with an empty magic serial number which worked - if the serial # from the VSROM is all zeroes except the places where the ff sync bytes are, you'll still get warned about the tool being serialized, however since the serial number resulting from this is all zeros it effectively doesn't prevent further installs from the same tool disk. see this thread: https://lisalist2.com/index.php/topic,65.msg294.html#msg294

But yeah, as mentioned previously, all of this is moot since once I found where the protection bit was, I was able to permanently turn it off.

The clue is that some "tools" are not serialized so was able to look at the fields in the extent block for that tool (think of it as an inode) and see the difference between those and the ones that were protected. For example, the Preferences and Calculator tools are unprotected. I don't recall which off the top of my head but at least one tool isn't protected and the others are in LOS 3.1 apps.

See this thread for more details: https://lisalist2.com/index.php/topic,98.0.html


Well-known member
Thanks @sunder ! Great info. And yes, I had noticed that some tools were not serialized, but did not record which ones.

I need to research this quite a bit more. I was pretty sure I couldn't load LOS when I first tried, and that's when I learned about this serializing thing. I remember going through the whole process (5 diskettes), but when Lisa asked to put System 1 diskette back on, this is when the error message happened. But perhaps this was something else.