• Updated 2023-07-12: Hello, Guest! Welcome back, and be sure to check out this follow-up post about our outage a week or so ago.

BlueSCSI problem, is it HW or user error?


Hello, I recently acquired a Mac SE and Mac Classic and purchased a BlueSCSI v2 DB25 to use with them. I carefully followed the instructions to assemble it and setup the FW and SD card. However, I have the same problem on both machines when attempting to use it, nothing shows up on the desktop. When I try using a bootable image to bypass the HDD, it either boots straight to HDD or gives the ? folder icon. I'm hoping someone more experienced with the BlueSCSI and/or vintage Macs will be able to help me determine if the issue is a software/config, hardware, or user (me) fault. I've tried pretty much everything I can think of. The log files look fine, the BlueSCSI detects the hda files and says they are setup successfully. I tried a few different SD cards, and (re)formatting as exfat and fat32. I've tried several different hda images, found on the BlueSCSI wiki, Macintosh Garden, Archive etc. Tried different settings in the bluescsi.ini file, and different SCSI IDs. Tried with USB cable plugged in, in case it wasn't getting enough power. Also tried disconnecting the internal HDD.

Using floppy disks I was able to transfer SCSIProbe app to the Mac, and it shows that something is detected on the correct SCSI ID, however the description fields are empty and it just shows a dot followed by "no data". Clicking "Rescan" and "Mount" makes no difference. I'm definitely not a noob with computers, but am new to 68k Macs so it's definitely possible I've just made a simple silly mistake, like maybe there's a keyboard shortcut or some setting I overlooked. The Mac Classic appears to work perfectly (so far) after I cleaned up the battery and capacitor leakage, and did a full recap of logic and analog boards. However, it's possible there's still a bad trace or faulty SCSI chip on the Classic causing a problem. But the Mac SE is in near mint condition, so I think it's unlikely that it is a hardware issue with the computer itself, or at least unlikely that both computers would have the exact same fault but otherwise work perfectly.

Would greatly appreciate any advice or tips! Hopefully I can get it working and it's not a manufacturing defect in the PCB, but at this point I'm stuck scratching my head.


Well-known member
My experience has been that for images that show up in the log as ok, tools like SCSI probe see the hard disk and display something like "BlueSCSI device..." and the image "HD" size, even if the image isn't bootable... Random thought, could you be using a SCSI ID for your image(s) that is in use by a physical device? i.e. SCSI ID 0 is normally the internal HD so you would not want to use an image name like HD00_512.hda or you'd have an ID conflict.

I second running through the entire troubleshooting doc:


Thanks for the suggestions! I have gone through the troubleshooting documentation, but will take another look just in case. Not sure how picky the naming convention is, does it care about spaces, -, _, . etc? It says the LUN # is optional, so would this name be acceptable (assume yes since it's how the file came).
"HD6 BlueSCSI Toolbox 1.0.1.hda"
I have tried renaming to use SCSI ID 1-6, so I don't think it's a conflict. I'll attach the log file below.

Also, I will check out those links for the Discord, github, and Tinkerdifferent, thanks.


  • log.txt
    3.9 KB · Views: 1
  • IMG_20240319_140047_034.jpg
    2.4 MB · Views: 11