• Updated 2023-07-12: Hello, Guest! Welcome back, and be sure to check out this follow-up post about our outage a week or so ago.

A/UX Initialization Error "Standalone program space is too small"


Well-known member
I installed the SCSI2SD image of A/UX 3.1.1 discussed in the sticky on my SE/30. I can get it to boot fine with the stock ROM installed, but only 8MB of RAM is detected. If I replace the ROM with a MacSIMM 32-bit clean (IIsi with memcheck disabled patch) ROM, the system reverts to a flashing question mark. If I boot it from a 7.5.3 disk tools disk and use Apply HD SC Setup to reinstall the SCSI driver on device 0, it boots into the mac environment fine. All standard fair for that SCSI2SD image it seems.

The wall I'm hitting is that once it's booted into the mac environment it tries to run the A/UX Startup program and give this error (pardon the different HD icon, this was from an earlier attempt when I used the Silverlining driver rather than Apple HD SC to get the system booting):


Note that the 18304712 figure appears to be the amount of free RAM the system has, which should be more than enough to do anything in A/UX:


If I click "continue" it gives another message that seems similar, though this one has a different value for the program space value:


Finally, hitting continue results in all the commands to actually start the system failing:


I tried running commands manually in the startup environment and the only ones that worked were the help options.

I've tried different memory control panel settings (32-bit addressing on/off, VM on/off) and different RAM (including less than 8MB and up to 80MB) with the same results.

I feel like I'm so close yet so far. Has anyone encountered a similar issue? Is this due to the fact that I'm using a IIsi ROM image in an SE/30 and there's some weird A/UX pickiness that's rearing it's head?

Last edited by a moderator:


Well-known member
I have been through two or three A/UX installs on a stock SE/30 and have never seen this behaviour.

Last edited by a moderator:


Well-known member
The patches for A/UX are specific to certain ROM builds. If you install your own ROM, A/UX may fail to boot because the ROM checksum is different to the requirement of the patches.

Last edited by a moderator:


Well-known member
Thanks everyone. I don't know why I thought I needed the 32-bit clean ROM for A/UX. Swapped the original ROM back in and we're in business: