• Updated 2023-07-12: Hello, Guest! Welcome back, and be sure to check out this follow-up post about our outage a week or so ago.

6400/200 - No Video, No Green LED, Nothing Happening


Well-known member
A while back I had gotten my 6400/200 VEE setup with a PATA SSD (8GB) and it worked fine, it had been left unplugged for a few weeks, and now It won't turn on fully. The facts:

  • Nothing after the startup sound, no video, no green led on the front
  • Tried replacing the battery, used both the square type and the AAA type, all new, and no change
  • Tried to zap the pram, but it would not trigger the reboot with the keys held down
  • Took out all the PCI Cards and Comm Slot Ethernet Card
  • Removed AV Card and TV Tuner
  • Cleaned RAM pins, and Cache pins too. 
  • Took out the SSD and tried to force it off CD-ROM
It seems like the machine has had a "stroke", nothing gets it past to fully turn on. Anyone experience this?




Well-known member
After the startup sound, I believe the computer starts to check the ram. So that means something in its startup check is wrong, I think. Don't just listen to me though, I am just guessing. Try taking out the ram sticks, and maybe try with one or something? I dont know how much you have.



Well-known member
Have you tried waiting more than a minute after the chime before shutting it off or rebooting? On a cold boot, these machines will take a very long time to perform the RAM test if large amounts of RAM are installed. My 6360 almost always makes me think it's broken, then up comes the happy Mac and it boots. It seems like forever, but I expect it's about 40 seconds.

If you still don't have luck, try removing both sticks of RAM and see if it boots. (there's 8MB soldered on the logic board) If even that doesn't work, I'd try disconnecting the hard drive. It won't boot like that, but if you get a blinking question mark, it likely means your drive is dead.

Oops, I just re-read your post and noticed you've already tried disconnecting your SSD. If the waiting longer and removing ram suggestions don't work, try disconnecting the CD-ROM drive. I've had a failing optical drive cause a lock-up before the display initialises before.

I can't remember if the LED normally lights immediately when the machine is powered on... I think it should be. If that's the case, the power supply unit might be unstable, causing the system to halt.

Last edited by a moderator:


omidimo, did you ever figure out the issue with your 6400?
I've got a 6400/180 that i'm working on. It was a former home to a mouse, and I literally had to clean everything inside. No corrosion, but I get the bong on power up, no video, no LED on the front module, and is unresponsive to zapping PRAM. Removed all extra RAM, Cache, drives etc. The symptoms match what yours was doing, so I was curious if you ever found a cause.


Well-known member
I have one that does this occasionally/intermittently. Seems to be an issue with 6400s. Two things make me believe it’s the power supply, although I haven’t got around to proving it:

The onboard video output is dim and has lots of visual noise during hard disk activity, of the type that is typical of old power supplies suffering from voltage drops during disk activity, etc.

Also, I can reproduce it 100% of the time by adding known good hardware (PCI cards, second hard drive, etc) to the system.

I have a handful of other projects on the bench now, and this one is way down my priority list but that is the first thing I plan to look at when I dig in to it.


Interesting, have you tried measuring the voltages off of the power supply while it’s acting up?
I did check voltages after it was powered on and the 5v, 3.3v and 12v rails seemed okay. Unless there was a dip that caused it to crash.

Ive been trying to dig up any info on in depth troubleshooting, including schematics but haven’t been successful.


Well-known member
I've had this happen with my 6500 as well, nothing I did would revive it other than swapping motherboard. I've done that twice, and it fixes it for awhile, my 6500 is currently dead again with this issue as I've not had time to deal with it yet again.


Well-known member
The thermal paste might have completely dried up... or the heatsink has shifted a bit ... or both.

Several of may 604e-cards for PCI-Macs were not reliable and got extremely hot after a while.
'Re-greasing' them fixed the instability but they still get very hot... although it's summer here in Germany at the moment.



For me it’s definitely not a thermal issue on the CPU. During cleaning I did remove hestsink, clean ir and apply new thermal compound.


I have been doing digging and the issue I think stems from the CUDA chip. According to the 6500 schematic, it controls the power LED on the front of the computer. Being that it’s not coming on, I’m guessing that the issue surrounds the CUDA chip.
I have a power pc g3 with the same CUDA chip, and that system does work. It takes about a second or so for the power led to come on.

I’m going to hook up the working and non working system to a logic analyzer to make observations on a working vs non working system.


Well-known member
Cuda is a 68HC05E1 microcontroller. If it's not working, likely there's an issue with the 32.768 Hz oscillator that feeds it. (It can act up if the battery's dead too).


Well-known member
I wonder if the caps are to blame. I replaced a handful of the ones in the power supply and some of those were starting to leak a bit. Also recapped the motherboard. These machines are getting closer to 28-30 years old now...


I did test the oscilator and did see a good signal from it. I also did go through most of the caps and tested them, the only ones which were questionable were the 100uf caps. Since I had them on hand, I went and replaced them all as well and no change.

I have a Power Mac G3 here which does work and has the same CUDA chip. I might hook both up to a logic analyzer to see if I can make some comparisons between the two and characterize how it should work.