Jump to content

Floppy not working in SE/30 - but working in other machine?


Recommended Posts

I have two SE/30s and recently tried the floppy drive in one and found it throwing up the "This disk is unreadable" error, and then fails to initalise any disks I have.

 

I took the drive out, re-greased the metal and cleaned the heads with IPA, but no luck. I then took the floppy from my other SE/30 and swapped it in. Still no luck, so I tried the "broken" drive in the other SE/30 and it works fine! They are both Sony 2MB drives (looks like one is Rev2 and the other Rev3).

 

I have some Classic's as well. Any one know if their drives will work in an SE? I tried the SE drive on a Power Mac and the eject function went a bit crazy :)

 

Anything obvious I can try to get this working? The machine hasn't been recapped yet, but has been cleaned. It works fine except for faint audio.

Edited by jimbojones
Link to post
Share on other sites

I do not know, if it matters, but the SE/30 had somtimes a 800KB drive when it was upgraded from a SE. The floppy cable had a yellow cable at one side. I have one of those upgraded versions. The 1.44 MB floppy cable had a red cable. Perhaps you have the wrong cable in the SE/30? Please correct me, if the cable color has no influence on the function.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...