Jump to content

SE/30 SCSI or drive failure?


Recommended Posts

So I booted up my SE/30 I've left alone for a bit. I put in a younger (ca. 1995) hard drive I had laying around last time I messed with it, which I used LaCie Silverlining v5.7 to initialize and install a disk driver for. Everything was working fine as of then, excepting quiet audio and display distortions whenever the hard drive or floppy drive was in use. (it hasn't been recapped) This time, I booted it up, I found that I left System 7.1 installed last time I used it, but the software I wanted to mess around with (THINK Lightspeed C 3) expects System 6. I figured that's why the debugger wasn't working, and since I really wanted to use this specific version of the software, I decided to wipe the System folder and reinstall from my 6.0.8 disk images. After the install, I reboot and after Welcome to Macintosh I get a bomb with "Illegal instruction" or something. So I try to install again. Unfortunately, this install failed, with error #-36, which just decodes to IO error as far as I can tell. I try again, same error. I try to install the Minimum system software for SE/30. This works, and boots fine for the few minutes I test it, but I really want Multifinder for my programming, so I go back, install the full system software for SE/30, which seemingly succeeds, and this time when it boots it constantly redraws the Welcome to Macintosh window border, hanging there. I turn it off and call it a night.

 

I'm mostly looking for a matter of probabilities here, what's likely to be the problem? Is my drive failing? It's not making any different noises from usual, that I can tell, but it also didn't mount consistently when booting from my System 6 floppy. Every boot always shows the Silverlining driver window, though. Every time I got an error during boot I restarted a couple times in case it was a one off, but each problem I described above was consistent. This all came after a couple hours of running the computer, so by my understanding that makes capacitor issues less likely since they had a chance to warm up. Still, perhaps there's fluid near the SCSI circuitry, and that's causing a problem? I didn't see any before I turned the computer on a couple days ago, no bulging caps either (I stored it disassembled for some reason, so I looked over the motherboard before I put it back together.) Could a chip in the SCSI chain be failing?

 

As I see it, I have three things to try: attempting to clean the hard drive (maybe I'll run Silverlining again to see if there's bad sectors), cleaning and recapping the motherboard, or just ditching the hard drive and ordering a SCSI2SD. Any thoughts?

Link to post
Share on other sites

Silverlining included a First Aid program that actually worked for me, unlike the one on my System 6 disk. (Is that locked to Apple hard drives again?) Verify and repair and it was good. I ran Silverlining’s short tests to see if anything else would go wrong and they didn’t. So, yay Silverlining! 
 

I’ll update again if anything goes wrong in the near future, I’m about to start a project on this Mac that’ll keep me running it for a while. 

Link to post
Share on other sites
  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...