Jump to content

Can't launch iTunes after 10.5.8 Update?


Recommended Posts

Hey, I need a point in the right direction - appreciate any help. I'm in software loop-hell.

 

Just updated my iBook G4s from 10.4.11 to 10.5.8.

 

Now I can't get iTunes to open on any of them.

 

The application data says I have QuickTime Player 7.2.1

 

When I go to open iTunes, it won't lanuch and says I need QT 7.5.5 or greater.

 

I can't find a 7.5.5 QT to download, just 7.6. But when I try to load 7.6, the load program says it is OLDER than what I have.

 

I need a version of iTunes that runs the radio stations at least - iTunes 10.6.3 is what it says I have in application data.

 

Should I just delete iTunes and then reinstall iTunes 8.6 or 9?

 

Frustrating...never had this problem running 10.4.11...

Link to post
Share on other sites
  • 68kMLA Supporter

I've run into this before. The update to Leopard messed up your newer version of QuickTime that was installed in Tiger. The version number being reported to iTunes is different than the QuickTime Player application version because the older framework has overwritten the newer one. My guess is that the Player version is 7.6.1 or higher, but the framework is 7.2.1, hence the confusion. I ran the installer for 7.7 and did a permissions repair to be safe and things were fixed.

 

See: https://discussions.apple.com/thread/4031846?start=0&tstart=0

Link to post
Share on other sites
  • 68kMLA Supporter

Apple seems to have removed Quicktime 7.7 for Leopard from their download server. The only versions accessible are for Snow Leopard. You'll likely need 7.6.9 or 7.7.0 as chances are you had the latest Tiger version (7.6.4) installed before the Leopard upgrade. http://mac.filehorse.com/download-quicktime-player/ There's a link to 7.7.0 from a third party. I found it by cross referencing now deleted Apple KB articles on Archive.org, then searching for the file name. 7.6.9 for Leopard is available on the "previous versions" drop down menu on the File Horse page. If you prefer to find the file elsewhere, Apple's filename was QuickTime770_Leopard.dmg

Link to post
Share on other sites

Thanks, everyone! I played with it more this morning and finally found success with iTunes 10.6.3 running with QuickTime 7.6.4. I had tried downgrading to iTunes 9.1.1 but that did not work, as iTunes could not read the previous library file.

 

I could not find 7.7 very easily but 7.6.4 does seem to work ok.

 

What an odd thing that Apple set up with unbundling QT and iTunes from the basic 10.5 update path. Weird. Well, now I can replicate this solution across my three G4s.

 

Thanks for the help!

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...