Jump to content

Search the Community

Showing results for tags 'quadra'.

More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


  • Important Information
    • The 68kMLA Forum Rules
  • Community Connections
    • General 68kMLA News & Stuff
    • Conquests
    • Trading Post
  • Projects & Hosted Forums
    • RetroChallenge
    • 68kMLA Wiki
  • 68k Model Forums
    • Compact Mac
    • Mac II, Quadra & Centris
    • 68k LC & Performa
    • 68k PowerBook
  • PowerPC Model Forums
    • NuBus Power Mac, LC & Performa
    • PCI Power Mac & Performa
    • G3/G4/G5 Power Mac, iMac & eMac
    • PPC PowerBook & iBook
  • Everything Elseā€¦
    • Apple I, ][, /// & Lisa
    • Newton
    • Software
    • Hacks & Development
    • Peripherals

Find results in...

Find results that contain...

Date Created

  • Start


Last Updated

  • Start


Filter by number of...


  • Start





Website URL












Found 24 results

  1. hello everybody, I am in this very strange situation: my Quadra 700 came with an hard disk which failed after a few weeks. I wanted to try an 80 pin hd (cheaper, easier to find) with this made-in-china adapter: https://it.aliexpress.com/item/4001112495209.html and I got my hands on a 17GB Seagate Cheetah ST318406LC (the label says it's LVD/SE). Connecting it and turning the Mac on got me chimes of death and sad mac errors 00000F / 0000003 or 000000A, with any possible combination of scsi id (now the HD is on ID 4). I could boot the Quadra with an external (v5.5 boxed) scsi2sd and low-level format the disk to HFS with FWB Tool Kit, then install MacOS 8.1 - the disk is there, I can see it, it reads and writes perfectly, if I use system picker to pick the 8.1 HD system folder and then reboot, it will boot into 8.1 with no problems, but... if I unplug the scsi2sd and just turn the Mac on, I get the no-disk icon. How is this possible? what setting or action am I missing? Any hint or advise is warmly welcome! Thanks in advance!
  2. Juliet Elysa

    Sad Mac on Performa 635CD

    Hey y'all! Hope everyone's been doing alright! Life has been insane for me the last couple of years (especially this one...), so my Macs have kinda taken a back burner until tonight. My oldest daughter officially inherited my beloved Performa, and when she went to play some games a couple of hours ago it finally happened. A wild Sad Mac appeared, with the code 0000000E 0000FD00. Where should I start with troubleshooting this? Dr. Google has been very little help... Miranda inherited my Sad Mac phobia, and tonight she turned on the Performa in her almost completely dark bedroom right after waking up from a bad nightmare. Probably the worst way to experience your first wild Sad Mac!
  3. I recently bought a Macintosh Quadra 700 off of eBay (https://www.ebay.com/itm/Vintage-Apple-Macintosh-Quadra-700-M5920-Desktop-Computer-w-Harddrive-Mac-iMac/273781054522?ssPageName=STRK%3AMEBIDX%3AIT&_trksid=p2060353.m2749.l2649) and it has some corrosion on the logic board from a leaky battery. When I was cleaning the corrosion off, several components fell off of the board. The parts that came off were R71, C61, R76, R77, Y6, and C65. D5, D6, and U91 are still on the board, but their pins don't look too great. U92 has nearly all of its pins broken off and it is hanging on by two or three pins. I tested the continuity of all of the traces that I could follow in the damaged area and everything seemed to be connected. When I try to turn the computer on, the power LED lights up and the speaker clicks once (but does not chime). Do you think that the symptoms are caused by the missing parts or are the power-on issues more likely the fault of bad traces that I didn't catch? If any of the missing parts are necessary for operation, please tell me the correct component value so that I can replace them. I hope that U92 is not needed for the machine to power on because it seems to be a custom chip that is probably impossible to find. Attached are some pictures of the damaged area so that you can see what I am referring to. I hope I can save this one because I have always wanted a working Quadra 700!
  4. IIfx

    Quadra 950 - Power Tower

    After many years of delays on my part, I finally managed to get this specific Quadra 950. Many thanks to @Trash80toHP_Mini for taking a large detour on the way home to North Carolina through the countryside of Northern Virginia to hand it off to me. The Quadra fired right up without a single issue after just a little bit of light cleaning. Specifications: 16mb RAM, with all SIMM slots filled 500mb HDD No Nubus cards at the moment My plan for this machine is simple. Stuff it full of Nubus cards and RAM. This Q950 will be the successor to my Q800, which currently has gone through two logic boards after an awful overclocking experiment using a MacClip. The goal is to have a power tower equivalent in awesomeness to my IIfx. That means this Q950 will house at least 1 StageII Radius Rocket, in order to elevate it's grandeur. With a 305w power supply, why not? I bought a SCSI2SD v5.1 board to serve as the main storage for the machine. Perhaps down the road I can locate an OrangePC card to go in it too. For now, my main goals will be buying RAM for it to get to at least 128mb and setting up the SCSI2SD. I will post more in this thread as progress is made.
  5. Hi, Me again - I was the guy having issues with my 950's ADB port/video artifacts and SCSI2SD booting/Sad Mac: Quadra 950 board #1 The issues could be described as: (just in case y'all have any more ideas) ADB is on crack. Text carat blinks super-fast, repeats almost instantly and equally as fast. Mouse requires 4-5 super-fast clicks to register as one double- video artifacts with NuBus video card; on-board seems to be OK replacement Apple Ethernet NuBus card (SONIC model w/ 68000 CPU) is recognized in Slot A but locks the system up when I try to select it in AppleTalk cpanel SCSI2SD with last good SD card image (taken Feb 2018 before issues) results in 0000000F major, 00000021 minor. Gray screen with ? mark as expected if I boot without SD inserted, but panics after I insert so maybe a bad disk driver (Lido, FWB, etc - I can't remember which one)? I booted from a physical HDD I used to have on my 700 before replacing it with a SCSI2SD. file copies, Snooper logic board tests, etc are super slow with ADB keyswitch set to ON. I left it overnight for a repeating test (including basic RAM 101010) and this morning the RAM test was only 10% or so done. Should have taken a couple of minutes. I took out everything but 128 MB RAM bought earlier this year from MemoryX. Quadra 950 board #2 Purchased on eBay two weeks ago - owner stated it was a working pull from a 950 with a damaged side panel in 2002, sealed in a bag ever since. Doesn't chime, even with no RAM installed, it should at least boot chime and death chime? No video, SCSI drive light blinks as I would expect would happen, part of the usual POST process I swapped out 68040s with my other 950. No obvious trace damage. Yesterday was the first opportunity to work with it. The "upper right" corner is cracked (i.e., the corner on the end by slot $E) but I checked and don't see any traces that would have been broken on either site. (just green space You may have seen this board on eBay, which I got specifically to replace the #1 above board. Now I have two I can't do much with. What the hell do I do? (PS, I'm inserting the obligatory "looking for a Pisces PDS card and internal caddy CD bezel" but would just be thrilled if I could get it working again - I promised it the PPC PDS card from my 700 if it cooperates with me) Thanks!
  6. This has not been a good month for me. First my poor cat Linus is hit and killed by a car last week, and now the Q950 I picked up from our dear Nuvision has died! This Quadra 950, a workhorse at Nuvision Graphics for who knows how many years, is now giving no signs of life, and I don't know why. It all started when I first received the machine from Nuvision a few months ago. The front of the machine had a label on it which read "BOOTS (NEEDS WORK)", so I knew things would be interesting. When I first set it up, it was not booting due to the format of the HDD, also indicated by that label on the front. Attempting to boot into both 7.6 and 8.0 install CDs, I kept getting bus errors; indicated by both a bomb message and SadMac 000F 0001. I popped in a SCSI2SD and after a few attempts to boot, it eventually started working. I had no clue why. It's been a few months since I booted it, and I've moved to a new house, and when I dragged the machine out of the closet a few days ago it worked fine. Then I ordered an Asante MCNB Rev.A NuBus card for the machine, and inserted it yesterday. I got a boot chime, but no video, and eventually death chimes. I removed the ethernet card hoping it would boot, but it wouldn't. After a few power cycles, it began to boot off the SCSI2SD, but when the Mac OS splash screen appeared, I got that "bus error" bomb quite a few times, and a single "illegal instruction" bomb thrown in there as well. Thinking there must be a bad SCSI cable or that the SCSI2SD may have died, I removed them and attempted to boot off the DB25 SCSI port using a CD drive, but kept getting bus errors. After a few more boot attempts, it was just a boot chime followed by a death chime after the RAM test finished, and a couple power cycles later absolutely no signs of life. At around that time I was starting to realize that I would have to gut the machine to troubleshoot. I wound up removing everything: floppy drive, PPC 601 card, a PowerPump overclock kit, and 128MB of RAM, all to no avail. I don't know if the Asante card killed the board, or if the history of bus errors indicates some other issue. I might get an oscilloscope so I can probe the 040 and NuBus hardware to see what's working and what's not.
  7. So, my Q700 that was only in my hands for about a month is suddenly having hardware/ADB issues as well as the 950 I've written about here. Background is above. Pardon the crosspost but I wouldn't normally hang out in the Peripherals section so maybe others wouldn't either... and this graduated from a problem isolated to the video card to impacting the entire machine! Here it is in its glory/gore. Thank you in advance for following along! Above PC 24x jacked up my Q700. Machine at the time had a upgraded/soldered 33 MHz crystal, PPC 601 PDS card, PowerPump NuBus card and companion SIMM that was supposed to increase the clock from 33 to around 40 MHz but I never could get it to work. The Quadra came to me without an 040 CPU so I bought a MC68040RC40A (note the 40 MHz so it should handle the overclock just fine) and installed it, even though the 601 runs most of the time. I have a 3-port ADB/HD15 KVM switch that works (seemingly) perfectly. Plugged in the Radius card to revisit the issue I noted in the above post and it basically the mouse went out shortly thereafter (after a couple of reboots, there wasn't a particular moment of failure). Clicks work but no x,y movement. The pointer is grounded in the upper-left corner, regardless of boot disk (SCSI2SD or original HD), OS version (7.6.1, 8.1, 8.5) or H/W configuration. Booted from Legacy Recovery CD (7.5 IIRC?) and FloppyEmu (various versions). I've cleared PRAM countless times I have 64 MB matching 30-pin RAM (+4 MB onboard), that I've taken out I have 2 MB VRAM that I've taken out I plugged in a known working PrecisionColor 8xj NuBus from another machine I left in/took out the PPC 601 card I pulled the 68040 and forced it to let it run on PPC 601 only I took out all NuBus cards and ROM SIMM I *think* I tried to run a stock Quadra 900/700 ROM onto a ROM SIMM I burned but I'm not sure if I did it right (just got the programmer last week) I bypassed the ADB KVM by connecting wedge mouse and AEK II to both Quadra ADB ports I disconnected AEK II and connected multiple mice directly to both ADB ports I verified AEK II and mice work in other machines I removed and replaced the (tested good) PRAM battery I've used ADB Renewal and Mouse Jolt utilities that are supposed to reset the ADB/bus and don't require a mouse to do so I've had success with TechTool PRAM zapping as it claims to be more thorough (beyond the initial ~192 bytes they claim is wiped with a regular Cmd-Opt-P-R?) but can't navigate TechTool without a f-ing mouse I get an 0000000F/00000021 occasionally when I try to boot from SCSI2SD, usually if I don't pull the PRAM battery AND power for ~30 sec. I have a Snooper NuBus card that I'm not even sure is working. It lights +5V, +12V and -12v light up but no ADB or Activity - the orange clock LED blinks rapidly ... but it does the same thing in my working Iici too. The main symptom is STILL: the mouse clicks but doesn't move. (which is great if the Apple menu were a "FIX ME AND GET FILTHY RICH IN THE PROCESS" button). I'll buy a Q700 board if someone has a working one for sale but that's a last resort. But I also want to get this solved and put my front bedroom/lab back together soon. Is this a lost cause? And thank you again for hanging in there with me!
  8. I have a 950 that has been the most stable machine in my arsenal, just sitting there, serving up files from within A/UX. I also maxed out the RAM to 256 MB and threw a NuBus Ethernet card and SuperMac Thunder/24 card in (since I can't get my hands on the usual 950 "hen's teeth"). Well, I had an issue after swapping video cards (to troubleshoot an equally-frustrating issue with my 700 - see other thread in Peripherals) and, while I managed to get it back up, I have the weirdest side effect: when the key switch is left in the default (0-degree or up-and-down) position, I have wavy interference or artifacts on the display and it gets worse at higher resolutions. But when I turn the switch to SECURE (which disables the keyboard and mouse), everything is normal! I took the beast apart last night and unplugging the key lock from the logic board has no effect, but I didn't expect it to after other threads pointed out the position is "remembered" once set, even if disconnected. In taking out the power supply, I took a quick look and didn't see any obvious electrical damage but that's way out of my wheelhouse. I know tantalum capacitors can burn out but I haven't an idea what to check next. This appears to be the only side effect but I'm not 100% sure yet. Thanks!
  9. I recently picked up a Quadra 700, and unfortunately the battery had leaked a little bit onto the logic board. Can anyone take a look and see how bad it appears? I've never dealt with this kind of stuff before, but it doesn't appear too bad? I got it off ebay, and the auction said it powered up (they had a picture of it with the green LED lit), but I haven't dared to even plug in the power. it looks like it lost a couple of SMD bits for sure, and clearly the battery connections are a complete wash. The battery case was completely disconnected (rattling around the case when I got it home) and the metal contacts were completely gone. I saved the plastic battery holder just in case, as the plastic didn't seem to be too worse for wear. The SIMM closest to the battery has some corrosion spattering, but it doesn't appear to have completely eaten away through anything..though my hopes aren't high on bringing that one back to life I suppose. Sadly, what saved everything else was the the machine must have been upside down, because the entire underside of the floppy drive is rusted through. It was so bad I couldn't even manage to unscrew it from the drive bay because the corrosion has filled the screw head to the point that I couldn't get a driver in there. On the plus side, there was a PPC upgrade card and a radius videocard, seemingly untouched by the battery juice. I've attached a few key pictures, and here's an album with some more stuff https://imgur.com/a/DBBsy Thanks!
  10. Asking because there is a Q900 floppy bezel on the same site (Milagro Computer) but it looks more like a Q800/840A floppy... there's no mistaking the 900/950 floppy bezel (nice right angles) The CD bezel, not so sure. It doesn't look the same as the other different ones I've seen (some with round eject buttons, others with the standard rectangular button) but could it still fit? Quadra 900/950 CD Bezel 815-2738 Would love the flexibility of swapping out bottom drives from time to time (I have a "framing" bezel that was meant to hold in full-height drives but it just doesn't look as good.
  11. Hey all, I've nearly maxed out the RAM (64 MB or $40 at a time) on the Q950 I acquired a few months ago and had a spare key made just in case I broke the only one off in the lock. I added a SCSI2SD with A/UX 3.1.1, 7.6, 8.1, Apps and Backup partitions. I've added a SuperMac Spectrum/24 Nubus card (with the DSP daughtercard but also a v1.0 ROM I believe) and the Apple SONIC Ethernet Nubus card (AAUI) with the dedicated 68000 to improve file server performance. I have an AppleCD 300e external SCSI (1x) that lines up beautifully with the front bezels. I came across a Newer Technology Variable Speed Overdrive (2 of them, actually) with the SIMMs and clips but I stupidly assumed this model (for Q700/900) would work on my 950 with the 25 MHz crystal, before I understood how oscillators work. So these VSOs are useless to me (unless I keep one for a future Q700 buy) So a few scattered questions since I'm currently at a standstill on upgrades. Does anyone have a BMOW/DougG3 ROM for the Q950? I saw a .rom for the 900 but it was just to disable RAM check - which would be fine on its own but I wanted to boot from the ROM disk. I'll buy the programmer, I'm just surprised it hasn't been tried out AND shouted from the rooftops by now. Anyone have a PPC 601 they want to sell? Or anything else I would want to pimp this beast out? I know Pisces/AWS95 PDS cards, JackHammers, Radius Rockets, etc are extremely rare and impossible to stumble upon. Would love to get my hands on drive bezels (like everyone else) so I can put in a DDS-2 drive... Other than that, I swear I'm enjoying it Thanks!
  12. It seems that none of my Centris and Quadra era machines are stable anymore unless they've been recapped. In the last few years I've recapped several motherboards, but even they started showing issues, so now I'll be recapping or replacing power supplies, too. After recapping my 1U Amiga 1200 (which is now running 100% perfectly without panics or core dumps for more than a month), I was inspired so I decided to do a Quadra 605. Since I have more motherboards than cases (the plastic is SO brittle!), and since I don't have the capacitors I need for the power supplies, I decided to build the recapped motherboard in to a 1U case and use a standard power supply that fits the case: The Quadra 605 motherboard has had the resistor swap to overclock it to 33 MHz. The CPU is a full m68040 with the heat sink attached using Arctic Silver thermal adhesive epoxy and I added two AAA batteries in place of the 1/2AA. And, of course, it has a 128 meg SIMM and a pair of 512K VRAM SIMMs. For storage I installed an SCM PCD-50B SCSI multi-card reader. It's limited to async negotiation only, but since Mac SCSI isn't all that fast anyway, it still makes for a very snappy system. It presents each card slot as a separate LUN which Mac OS apparently ignores but NetBSD is happy to use. It's pictured with just one 64 gig CompactFlash in the PCMCIA slot with an adapter (which must be in that slot because the PCMCIA slot is LUN 0, and the Mac won't boot off of a LUN other than 0), but I also added another 64 gig MicroSD in an SD adapter in the SD slot for a total of 128 gigs. If I need more later, I may add yet another 64 gig MicroSD in a Memory Stick PRO Duo adapter, which in turn installs in an adapter to make it fit in the standard Memory Stick slot. I've tested it and it works. Plus, the CompactFlash is in the PCMCIA slot, so I can add another CompactFlash, too. The SCM PCD-50B are neat adapters The power is attached through a simple SATA power cable which provides just 12 volts and 5 volts. I can't imagine that much would make use of -5 volts, but the speaker output doesn't work and I'm guessing the serial port may not. I'm waiting for some 7905 regulators to be delivered so I can add -5 volts soon. After running it for several weeks compiling non-stop, I think it's safe to say that it is completely and perfectly happy. Next up is the Quadra 610 with 264 megs of memory and a 50 MHz NewerTech Quadra Overdrive...
  13. Hello, I figured I would start a topic for my custom case/ATX conversion of my Quadra 650! I got the logic board from just.in.time for $5 dollars, in untested condition. I actually found the matching connector for the power connector on Mouser! I ordered that, and I used clip leads for a first test, set up for hard power. I connected a speaker, and applied power. The board chimed, and it booted to the question mark. Yay! The board was good. Then, I connected an external scsi hard drive, which was read and it booted. Now, I'm going to assemble the proper cable so I don't have to use clip leads. I'll post some pictures of it after it is assembled, and then I will work on the soft power circuit. After I convert it to ATX, I will design a case and cut it on my laser cutter.
  14. Hi all, My Quadra 840 AV which I recently acquired from the roadside, has no video output, chime, or hard drive. There was a note attached to it that said it needed a new PRAM battery, so I replaced that. Still no chime, most likely because of the missing HDD. I remembered I had a 50 pin SCSI hard drive from a Classic II that wasn't working, so I tried using that to terminate the SCSI cable. It would start up, seek the HDD, wait 20 seconds, seek again, and would continue in that fashion until I turned it off. Yet again, no chime. I don't have the caddy for the CD ROM drive,so I have no way of booting with that, but I think the floppy drive works, though I'm not sure how to boot from that. I'm pretty much at a loss here, I don't know what to try next, so that's why I thought I'd ask here. Thanks, -Alec
  15. First post. Woot! I thought I might share some knowledge and get some feedback on my process, but first the backstory. I have a Performa 640CD I acquired from a longtime client around 12 years ago. She donated it to me because the power supply failed from a lightning strike. I happened to have acquired a Performa 630CD around that same time, so I moved the 640CD logic board over to the 630CD chassis to test it. Lo and behold: the 640CD powered up. Life happened and I promptly forgot about the machine. I got back on a preservation/restoration kick the last couple of years and finally got back to the 640CD. Still no power supply, but I wanted to at the very least get started on preservation. I yanked the power supply from the 630CD and moved it to the 640CD so I could get the system working "au naturel". My primary goal was to convert the hard drive to CompactFlash. Good idea too, because on the first powerup, the original drive suffered a bone chilling head crash. Now to the point of the post. I couldn't find a single process anywhere after two days of 'net searching that details everything necessary to completely restore one of these machines from nothing if you don't happen to have the original software media. I pulled together several different resources and my other ancient cobwebbed Mac/PC knowledge to create a single set of instructions for restoring the software on one of these machines. I'd like folks input on my process: maybe there's some steps I can eliminate? A better set of software tools or installer disks I can use? At the very least, I wanted to share this process here so others who might someday need it could get use out of it. The process is several pages long so I'll link it externally. If that's frowned upon, I can post the entire process here. http://inanis.net/museum/quadraperformalc-630-software-restoration-process/
  16. Hi... I found a pdf of the "Macintosh Computer Service Guide Vol III" July 1994 here: http://vintageapple.org/macbooks/pdf/Macintosh_Computers_Service_Guide_Volume_III_July_1994.pdf The scan is outstanding. It has testing options that apply to many Macs. It covers the Color Classic, LC 520, and up to the Power book 200 series. This manual is over 300 pages. jack
  17. Hi, I'm still a newbie with old Macintoshes so bear with me. I'm getting a Centris 650 in the mail in a few days and it comes with two Nubus cards installed. The first is an unknown video card and the second is (I think) a Digidesign Audiomedia card. My questions are: 1) Do Nubus audio and video cards speed up system performance? If so, how much and how can you tell? 2) I'm not doing any audio recording but I will be playing games and multimedia cd-roms. Does the Audiomedia card improve sound for games, or did all 68k-era compatible games just output 8 bit sound natively since most 68K Macs weren't capable of doing 16 bit sound? 3) This Centris 650 has ethernet built-in via an AAUI-15 connector. Is there any system performance or internet speed difference in getting a dedicated Nubus ethernet card, or is this on-board ethernet sufficient?
  18. I started an archiving project using a Mac Quadra 610 here: https://68kmla.org/forums/index.php?/topic/25007-starting-archiving-project-using-quadra-610/ However, the 50 MHz NewerTech Quadra Overdrive proved to be not all that stable. The rest of the machine is 100% stable running at 25 MHz without the Quadra Overdrive, and I'd like to fix that. Does anyone know of a source or sources of the last mask .57 micron L88M Freescale / Motorola chips, aside from the $50 ones on eBay?
  19. Hi, m68k users! I've been using bbraun's djMEMC fix in the NetBSD kernel to support 260 megs in a Quadra 610. However, sometime between last summer and now I've noticed that when I'm booted in to Mac OS 8.1, the Quadra is showing 132 megs whereas it was definitely showing 68 megs in the past. This isn't after warm-restarting from NetBSD or anything like that (I think bbraun mentions or implies that the ROM memory routines run on all boots, so changing-then-rebooting to get more memory isn't an option). Has anyone else seen 132 megs on a Quadra or Centris 610 without modifications?
  20. MinerAl

    Q840AV B

    From the album: MinerAl machines.

    Quadra 840 AV. HDD wouldn't boot, but mouse comes on screen and eventually the flashing

    © MinerAl

  21. MinerAl

    Q840AV A

    From the album: MinerAl machines.

    Quadra 840 AV with 500MB HDD, 8MB RAM System 7.5 Dirty case

    © MinerAl

  22. MinerAl

    Q950 B

    From the album: MinerAl machines.

    Quadra 950 with a 1GB drive and OS 7.6(?), 8MB RAM

    © MinerAl

  23. MinerAl

    Q950 A

    From the album: MinerAl machines.

    Quadra 950 with a 9GB noisy server SCSI drive in it. The five partitions are named Michael, Marlon, Tito, Jackie, and Jermaine. System 7.5.x, 16MB RAM

    © MinerAl

  24. I recently acquired a working, but neglected Quadra 840AV. It came with 3 hard drives installed, an original CD-ROM drive, and with a 64 MB of RAM. It clearly needed a total recap of a motherboard and a good cleanup, which I did. Then I tested the machine, and I found out that a CD-ROM drive wasn't detected, even that it was connected properly. I figured out that it must be the drive that failed. Then I cracked open the Sony CDU561-25 drive, and to my surprise, I found capacitors that have leaked and corroded the PCB. The damage was quite bad, but fixable. There was a group that leaked, and they were three 16V 47uF and two 16V 10uF silver electrolytic SMDs. On the left side of the PCB, there were four 6.3V 100uF that looked okay, but when I changed them, they were certainly on their way to fail (fishy smell). So when I replaced them all with tantalums, the CD-ROM drive now works flawlessly, and I know that they won't leak ever again. Also, I was impressed with the build quality of this particular drive, it is massive and it has a voice coil laser mechanism, which just screams high quality all around. So, next time your CD-ROM drive fails, check the caps inside the unit. Also, if you have a Sony CDU561-25 or similar, it will be the smart idea to change the caps just to be sure, even if they are not leaking. Sometimes the CD-ROM unit will cost alone more than a complete computer, so it is worth it.