Jump to content
grog

Cabletron Ethernet SE/30 driver installation

Recommended Posts

I am currently in possession of an SE/30 with a Cabletron Ethernet card (AUI + ST media) running System 7.5. I've downloaded the cabletron.sit driver file from the Vintage Mac Museum repository. While I have been able to get the installer copied over to the system I cannot get the driver itself installed. Whether I install from a floppy disk (obviously not the original) or off the hard disk, it insists on needing the "Ethertalk Installer" disk. I've named the diskette "Ethertalk Installer", but that was just a shot in the dark that didn't work. The Cabletron Ethertalk Installer folder extracted from the cabletron.sit file appears to contain everything I would need, but perhaps there is another disk that I'm not accounting for...? (I even have tried other vendors' Ethertalk Installer images, but this doesn't work, either... no real surprise.)

 
As far as I can tell, the hardware works (link and activity lights are functional on the AUI port) but the driver isn't there. Not sure if there's anything else I can/should try at this point. I haven't attempted an OS upgrade/downgrade/reinstall, as any install via floppies will take time to set up, plus I'd actually need to acquire a couple dozen floppies themselves for System 7.x. I am willing to put in the effort to go to 7.5.3 if it'll streamline the driver install process.
 
This was an eBay purchase that I'll need to return in the next two weeks if I cannot get Ethernet working. I believe the SE/30 of my past ran MacTCP with an Asanté card, but I don't have prior experience with a Cabletron card. 
 
Any advice would be helpful. I'd really like to hold onto this machine if possible and make it a permanent part of my vintage hardware collection, but I'm rather insistent that everything is able to talk IPv4 on my LAN. 
 
Thanks,
G

Share this post


Link to post
Share on other sites

Hi Grog,

 

I ran into this same problem a while ago. Here's how I solved it, I think (seems to work in Basilisk anyway...):

  • Extract cabletron.sit
  • This should result in a folder called "Cabletron Ethertalk Installer"
  • Rename this folder to "Ethertalk Installer"
  • Now you can use the Installer inside of it.

If the folder has any other name, it asks for the disk just like you're reporting. You can also create a disk image of the renamed folder using Disk Copy 6.3.3. That also seems to work in my testing.

Share this post


Link to post
Share on other sites

Thanks so much for your reply, dougg3. Some success... after re-copying the cabletron.sit file and renaming the extracted folder as suggested, the Installer did complete. Very grateful; this has been days worth of frustrations. (Fortunately I have an iLamp G4 running 10.5 Leopard which has been instrumental in reading/writing forked HFS diskettes.)

 

Tthere is still something amiss, however, either with the card or the OS itself.

 

Card/driver:

  • I assume the switch on the card toggles between the AUI and ST media. If not, does it need to be in one position or the other?
  • The Management control panel icon has an X on it during boot. If I run the control panel after boot, the MMAC Add: field is 00-00-00-00-00-00.
  • The DNI-Media control panel states "No adapter found." If I select the rightmost radio button, I have the option to select between 10BaseT Port, Coax/AUI Port, or Auto Select. However, that's about all it does.

 

OS:

  • If I attempt to start the Network control panel, I get the error "AppleTalk is disabled. Please use the Chooser to enable it and open the Network Control Panel again."
  • When I go into the chooser and attempt to set Apple Talk to Active, I get (a) an error to the effect of "Please make sure that you are connected to an AppleTalk network."; and (b) after selecting OK, it simply says, "AppleTalk cannot be opened."
  • Wondering if System 7.5 IP networking wasn't ready for prime time and if an install of 7.5.3 would streamline my goal.

Theories:

  • This SE/30 only has 5 MB RAM and this may not provide the necessary overhead needed to run the driver and network stack.
  • The OS is corrupted, either prior to installation or due to my trials and errors with driver installation.
  • The card has a hardware issue and its LEDs are just indicating the electrical circuits/signals are good between the AUI interface and the external MAU+switch.

I guess if I knew what a working installation+card looked like within System 7.5 I could narrow down what to troubleshoot. I figure if base functionality were there I would at least see a valid MAC address. It was odd that the system came with IEEE488 software installed—initially, I thought the card wasn't Ethernet, but I opened up the SE/30 to find the Cabletron part number. It would seem the IEEE488 card was swapped out for the Cabletron NIC without anyone ever having configured the latter.

 

Finally, assuming I ever get MacTCP enabled and functioning, should I be able to ping the SE/30's IP address? Technically speaking, ICMP and UDP are different transports from TCP; I guess I wouldn't be surprised if a 25 year old TCP/IP stack implementation were exclusively that, be intended for outgoing connections only, and NOT be designed to respond to pings.

Share this post


Link to post
Share on other sites

Glad you got the installer to run! I wish I could help more, but my Cabletron card is actually a NuBus card in my IIci. Unfortunately I don't know any details about the SE/30 card or how to use it. Hopefully someone with an SE/30 might be able to chime in. I can tell you that my IIci's card has a switch -- the housing of the switch is blue, and the switch itself is white. It's in the down position (toward the RJ-45 jack) and I've been using the RJ-45 jack rather than the AUI port.

 

I'm pretty sure 7.5 should be fine for networking. I use my card in 7.1 with no problems at all. I'm able to ping my IIci from my Windows 10 computer, as long as MacTCP is set up properly. I have noticed that pinging doesn't work until I do something that causes MacTCP to load on the Mac, like running the "MacTCP Ping" program that I use to test pings initiated *from* the IIci. Simply opening the MacTCP control panel isn't enough to get the networking stack to load.

Share this post


Link to post
Share on other sites

I downloaded and ran Mac TCP Ping; as I feared, there's no echo_reply. Having gotten through the Cabletron driver installation, I'm fairly sure at this point that AppleTalk got corrupted some how. While I do think a fresh install of 7.5.3 is in order, is there a relatively quick way to repair the AppleTalk installation? Looking at the floppy images, it appears software is packed into "Installation Tome" files. At worst, if I create the install floppies, can I install over an existing 7.5 installation without reformatting?

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×