Jump to content
Iesca

M0110A Repair

Recommended Posts

A problem regarding my M0110A Mac Plus Keyboard...

In anticipation of some new keyswitches I had ordered, I had taken out the broken keyswitches, which of course required some desoldering. After doing so, I managed to make one physically functional keyswitch out of the bits from the three I had removed, and I reinstalled it. Afterwards however, the keyboard stopped responding at all when hooked up to the Mac.

I thought that maybe it was because a couple keyswitches were still missing from the board, so when the new ones arrived I installed them, as well as did a thorough cleaning of the board itself. (A couple of the pads broke slightly in the process of preparing them for new switches, but the important bits are still connected to the traces; as best as I can recollect, the problem started before I had done this).

Any ideas what may be the issue? Larry Pina suggests that, in the case of a complete failure, static may have killed the controller chip... (And just to allay any fear, I have only used a genuine keyboard connector,
not a phone cable!)

really don't want to have to buy another keyboard at $60+ a pop. Any advice is appreciated!

Edited by Iesca

Share this post


Link to post
Share on other sites

I haven't, I don't actually have a meter to check with. But the whole keyboard is dead, not just the ones I installed. :(

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×