Jump to content
AlexTheCat123

Macintosh Quadra 700 Battery Leakage

Recommended Posts

I recently bought a Macintosh Quadra 700 off of eBay (https://www.ebay.com/itm/Vintage-Apple-Macintosh-Quadra-700-M5920-Desktop-Computer-w-Harddrive-Mac-iMac/273781054522?ssPageName=STRK%3AMEBIDX%3AIT&_trksid=p2060353.m2749.l2649) and it has some corrosion on the logic board from a leaky battery. When I was cleaning the corrosion off, several components fell off of the board. The parts that came off were R71, C61, R76, R77, Y6, and C65. D5, D6, and U91 are still on the board, but their pins don't look too great. U92 has nearly all of its pins broken off and it is hanging on by two or three pins. I tested the continuity of all of the traces that I could follow in the damaged area and everything seemed to be connected. When I try to turn the computer on, the power LED lights up and the speaker clicks once (but does not chime). Do you think that the symptoms are caused by the missing parts or are the power-on issues more likely the fault of bad traces that I didn't catch? If any of the missing parts are necessary for operation, please tell me the correct component value so that I can replace them. I hope that U92 is not needed for the machine to power on because it seems to be a custom chip that is probably impossible to find. Attached are some pictures of the damaged area so that you can see what I am referring to.

 

I hope I can save this one because I have always wanted a working Quadra 700!

IMG_9390.thumb.jpg.f722272079b81ddee2938fbfff66b55f.jpgIMG_9394.thumb.jpg.d5b1d8a6cd9b0e39c4f57fdc1077a3ec.jpgIMG_9392.thumb.jpg.664d2c2ed99d8159b75478a100183549.jpgIMG_9398.thumb.jpg.cae31253691704da042224e74125ee47.jpg

Share this post


Link to post
Share on other sites

Speaker clicking but not chiming could be a ROM issue.  If the CPU can read the death chime from the ROM, it should play it.  I don't have a schematic for the Q700, but there's a good chance that chip is important (since most chips are).  At the very least, I'd start with replacing the components you can replace, along with repairing any broken traces, and see if you can get a death chime at least.

 

That chip is probably found on other Macs of the era as well, if you can get a parts board from one of them.

Share this post


Link to post
Share on other sites

There was a post here that had high resolution images of the entire board, but the embedded image links were all broken.  Here's a link to the actual images:

https://photobucket.com/gallery/user/bradwart/media/cGF0aDovMDMwNjQ5RDYtODFDNC00MTVELUI2M0ItQzZDMzREOEZCMUJCX3pwc3lxbzdkbWRpLmpwZw==/?ref=

 

You might be able to get an idea of what is missing from those.  Other than that, I don't have a Quadra 700 so I can't get any values for you; someone else on this forum would have to do that.

 

Also, if you're really determined, you might be able to scrape away at the edges of that chip to expose metal contacts for you to solder wires to.

Edited by tattar8

Share this post


Link to post
Share on other sites

Ive got one as well - exact same problem as yours, re-soldered the resisters what fallen off.

Fired her up - I all I can is hear chime of death. I noticed 3x RAM chips isn't really soldered onto the board/corroded and one or two chips is dead/fried in my suspicion. At this stage I am saving up for heat gun so I can remove the RAM Chips and replace with new ones.
Cheers

AP

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×