Jump to content
Sign in to follow this  
ScutBoy

Mac Portable SiClone RAM board

Recommended Posts

I have in my hands a SiClone "RAM-to-Go" card for the Mac Portable.

 

When put in the machine, the machine chimes, and the screen starts (light herringbone) pattern, but I never get the cursor, nor the Happy Mac. I've let it sit for about 10 minutes, in case it's taking a _really_ long time to do the RAM check, but nothing ever happens.

 

I have a Kingston 1 MB card, and that works fine in the same slot - chime, slight screen pattern, then cursor, then Happy Mac, etc.

 

On the other side of the card from the picture, there is an EPROM that doesn't have a sticker over the window. I suppose it's possible that it's been erased, or I suppose the card might be bad in some other way.

 

It's a 4MB card, so would be a nice add to the machine. I've not been able to find any doc on this guy, only an archived InfoWorld article that talks about the card being released - at $2499.00 for the 4MB version!

 

https://books.google.com/books?id=pjAEAAAAMBAJ&pg=PT31&lpg=PT31&dq=siClone+mac+portable&source=bl&ots=eeXxpaJ_jq&sig=ACfU3U07hBRdEvaBBp2rlaXyF5sPj9IkLg&hl=en&sa=X&ved=2ahUKEwjblPugr8ThAhWNm-AKHWlsCwwQ6AEwAnoECAgQAQ#v=onepage&q=siClone mac portable&f=false

 

Any info or hints on how to diagnose this guy appreciated!

SiClone.jpg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×