Jump to content
  • Posts

    • Found another SE, which I have made a thread about here:    
    • Yeah, hopefully it can go to someone who can rescue the special chips. The 68882 that took the brunt of it is relatively easily replaced. If that Mac SE/30 schematic project gets off the ground, someone could whip up a new PCB to give those chips, and many more from bombed boards, a new home.
    • I found this nice earlier model SE on eBay for a great price. I was really hoping it would have the squirrel cage fan/blower, but it’s about a year newer that I thought it was, so it does not. I plan to swap the analog board out at some point for an older one that does. I’ve heard they move a lot of air, and I just think they are really interesting. And I’m not really bothered by some fan noise.   Here’s some pics of the unit:
        Very little yellowing. Looks great. It does have the older 1986 revision motherboard, so that’s pretty cool. And yes, I did remove the battery. 
        This machine had the original Miniscribe 20MB drive (red LED), which had a VERY stiff stepper motor. I put a drop of oil on it, which helped a little, but the issue is that only gets the outer bearing, not the inner one.   So, what did I have to do? COMPLETELY REMOVE the stepper motor to gain access to the other bearing! 
        Here’s some pics of the drive including the stepper motor removed from it:  
      So I got the stepper motor moving pretty freely after oiling the inner bearing, and then reinstalled it. Of course I had the open the drive also to keep the heads in the right position.   Put it completely back together, tried to format it with HDSC Setup and the Micronet utility, and neither would format it. Obviously the cylinders got misaligned while messing with the stepper.
        So I connected it to my SE/30, which I have FWB Hard Disk Toolkit on, and that allows for a low-level format. I tried that, and it failed a little ways through, but it must have realigned it, because Micronet was able to successfully initialize it after that! The drive is now back in the SE and boots to System 6.0.8 just fine now. I will be putting System 7 on it tonight though.   So the hours I spent on this Miniscribe payed off! Really is nice to see this drive live again. Most would have probably trashed it for a SCSI2SD, and I do like those, but I think the mechanical drives (especially these stepper-drives ones) should be saved when possible.   I have also bought another drive I plan to use in this machine, which hasn’t arrived yet. Surely some nice high-capacity drive, right? Nope, it’s the infamous Rodime RO652, that was used in the very earliest SEs. Rodimes are notoriously unreliable, but I’m going to try and revive this one once I get it. The Stepper may need the same treatment. These are my favorite as far as the “sound” goes. A Rodime doesn’t sound like anything else. It’s also pretty cool that these were the very first 3.5” hard drives.   Anyways, that my SE! My THIRD SE...
    • Traces all surprisingly look OK, but the SMT chips were so rusted they just pushed off with light rubbing. Replacing those is beyond my skill. Will clean it up and maybe someone else could rescue it or salvage chips. 
    • Pretty sure this sound isn’t good. It’s a 128k with a monster Mac 2mb upgrade board with scsi. it powers on to a checkerboard pattern and this sound. I’m not powering it on anymore, just to get a quick video. 
           Any and all help would be greatly appreciated - if anyone has a monster Mac 2mb upgrade and could share pictures and experiences that would be great. tom IMG_2541.MOV