Jump to content


Photo

Original Airport WPA compatible APs?


  • Please log in to reply
10 replies to this topic

#1 TarableCode

TarableCode
  • 6502

Posted 21 March 2017 - 12:53 AM

Is there a list of known working chipsets or somesuch?

I've had no luck getting the Airport card in my clamshell to connect to a home router and a TP-Link travel router, both say the password is incorrect.

 

That being said it appears the Airport firmware is up to date as well as my OSX 10.4.11 installation.

WEP Works fine but... lol.

 

Whenever my Raspberry Pi Zero W comes I'll see if it'll connect to that but I'm not getting my hopes up.



#2 Macdrone

Macdrone
  • 68020
  • LocationKelso, Wa

Posted 21 March 2017 - 01:40 AM

my clamshells airport wont work with anything but old apple base stations.  Even with no security my airport extremes wont let it connect.  Its why I keep an old grey saucer airport around to save on the hassle, considering it actually has the card fro that eras macs in it compatibility is a non issue.


Lots O' Macs, but now thinning the lots.


#3 TarableCode

TarableCode
  • 6502

Posted 21 March 2017 - 03:32 AM

Yeah, I've heard some people say it works and other people say it doesn't, and some even say it works but only on certain routers.

I'm hoping it'll associate with the Raspberry Pi, the general idea is that I can just attach it to the powerbank I have and leave it in my purse for true wireless goodness whenever and wherever.

 

Failing that HoRNDIS works on Tiger so there's always that route, it's just a shame to waste that airport card.



#4 Gorgonops

Gorgonops
  • 68030

Posted 21 March 2017 - 04:05 AM

To work with WPA as implemented on the original Airport cards (under OS X, obviously, the classic OS had no WPA support at all) the access point needs to support the transitional TKIP link-layer security mechanism:

https://en.m.wikiped...egrity_Protocol

TKIP was designed to work with the flawed RC4 encryption hardware in WEP-targeted cards and was always intended to be a stopgap solution, so many/most routers today either don't support it at all or make you intentionally enable it. All I can suggest is digging around in the settings for your router and see if there is a checkbox you can click to enable TKIP/"WPA1" compatability.

#5 johnklos

johnklos
  • 68000
  • LocationEarth

Posted 21 March 2017 - 03:16 PM

Some USB-wireless devices with Ralink chipsets can be used on OS X 10.4 (Tiger) and support WPA2. In general they're more of a pain because you have to run the software and re-associate after each reboot (most of the time), and there's more overhead, plus you're probably limited to 8 Mbps because it's USB 1, but it's an option I've used with my tray loading iMac.

 

Interestingly, WPA can be implemented entirely in software so long as the driver for the wireless card allows it, so an intrepid programmer could take WPA support from NetBSD and bring it in to OS X. More information about wpa_supplicant:

 

https://wiki.netbsd....wpa_supplicant/

 

I've actually connected to modern networks using WPA2 over an Orinoco WaveLAN Bronze which doesn't even support WEP directly.



#6 TarableCode

TarableCode
  • 6502

Posted 21 March 2017 - 06:38 PM

I've been fiddling with this a bit and it appears hostapd or the wlan driver or whatever is not communicating properly.

 

I get the normal debug output showing a device connecting and such but then hostapd says:

WPA: sending 1/4 msg of 4-Way Handshake

WPA: EAPOL-Key timeout

..

..

WPA: PTKSTART: Retry limit 4 reached

 

And then it stops trying to associate and the iBook will come up with the invalid password message.

I'm still looking into these logs but so far I'm not having much luck.

 

Interestingly enough I have used a Ralink USB adapter in the past and it did work but it was slower and needing to use it's own

UI was kind of a pain which is why I've been fiddling with Airport.



#7 Gorgonops

Gorgonops
  • 68030

Posted 21 March 2017 - 07:10 PM

Here is a support page for a random TP-Link router on the topic of configuring WPA-PSK:

http://www.tp-link.com/us/faq-256.html

Does your router have the option to change "Encryption" from AES to TKIP, and have you tried that?

#8 TarableCode

TarableCode
  • 6502

Posted 21 March 2017 - 07:14 PM

I've got it working O_O

Set eapol_version to 1 in your hostapd conf.


Edited by TarableCode, 21 March 2017 - 07:14 PM.


#9 Gorgonops

Gorgonops
  • 68030

Posted 21 March 2017 - 07:29 PM

Set eapol_version to 1 in your hostapd conf.

Assuming you're talking about in the Raspberry Pi? Setting that essentially forces WPA1 and the default cipher for WPA1 is TKIP. So, yeah, that should do it for you.



#10 TarableCode

TarableCode
  • 6502

Posted 21 March 2017 - 07:32 PM

I actually installed LEDE on my travel router and it seems to be working fine now, at least association wise until I fumble through all the configuration.

I'm hoping this works for other people as well since I've read numerous posts where they eventually gave up.



#11 bibilit

bibilit
  • 68000
  • LocationParis area -FRANCE-

Posted 23 March 2017 - 10:45 AM

https://68kmla.org/f...-wireless-card/

 

 

 

 To achieve this result, you should upgrade to Airport 4.2 under Panther (10.3 and above) I will advise which cards are working that way. 

Edited by bibilit, 23 March 2017 - 10:46 AM.

Macintosh Classic and II ,CC, SE, SE/30,IIsi 25mhz(RasterOps video),Q 700,LC, LC III,LC475, PBook Wallstreet/Bronze/5300cs/1400c/100/Tibook Imac G3 slot-in, Bondi and G4 / PMac G4 sawtooth, QS, MDD, Yikes!, Cube, Imac Core 2 Duo, Ibook G3 (white/clam) G4 + Newton 120, eMate 300,Quicktake 150,  PowerCD





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users