Jump to content
Sign in to follow this  
fyndr

Getting LC III to Recognize External HD

Recommended Posts

As a result of the feedback I got from the topic at https://68kmla.org/forums/index.php?/topic/26059-lc-iii-external-hard-drive/I was able to obtain an external hard drive which connects to my LC III via the DB-25 port. The setup looks something like this:

 

Mac <-> DB-25 to CN50 cable <-> CN50 pass-through terminator <-> External HD

 

I originally received a Spin external HD, but the unit would not power on. When I connected it using the setup listed above, the Mac would play the chimes of death and not start up. I recently came into a ClubMac external HD, which I confirmed is able to be powered on without any issues. However, when I connect it to my Mac it starts up correctly but does not recognize that anything is attached to that port. I tried running Apple HD SC Setup to initialize the external HD, but it only recognizes the internal SCSI drive.

 

Is there some other software that needs to be used in conjunction with the external HD in order to access it? Alternatively, could there be something wrong with the above SCSI chain or with the external HD itself that could explain it?

Share this post


Link to post
Share on other sites

Not sure you should have a pass through terminator.  Usually termination needs to be after the last device used.  That was usually why it was referred to as a scsi chain.

 

Have not had time to read the other post but of course if it has not been cleaned and recapped motherboard I would not try and diagnose anything.

 

If you are good in that like my first suggestion termination at the end is where it should be.  Never saw very pass through terminator, my guess is that would be why.

 

There has always been SCSI magic, so take it with a grain of salt, after over 20 years the drives being iffy only makes it worse.

Share this post


Link to post
Share on other sites

An update, I got a regular end terminator, so now my SCSI chain looks like this:

 

Mac <-> DB-25 to CN50 cable <-> External HD <-> CN-50 terminator

 

However, now when I try turning the Mac on, it gives the chimes of death. When I used the pass-through terminator it would at least start up, although the drive was not recognized. I tried different combinations of terminator placement (top or bottom CN-50 connector on the back of the external HD) with no luck.

 

I noticed there's a number ticker on the back of the external HD, presumably the SCSI ID. It is set to "6" currently. Does that make any difference in terms of the computer recognizing the device?

Share this post


Link to post
Share on other sites

The chimes of death issue was unrelated to the external hard drive and was resolved after having the LC III recapped. Using the end-point terminator instead of the pass-through terminator worked and I was able to view the external HD on the desktop without any problems.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×