Jump to content

Search the Community

Showing results for tags 'powerbook 500'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Important Information
    • The 68kMLA Forum Rules
  • Community Connections
    • General 68kMLA News & Stuff
    • Conquests
    • Trading Post
  • Projects & Hosted Forums
    • RetroChallenge
    • 68kMLA Wiki
  • 68k Model Forums
    • Compact Mac
    • Mac II, Quadra & Centris
    • 68k LC & Performa
    • 68k PowerBook
  • PowerPC Model Forums
    • NuBus Power Mac, LC & Performa
    • PCI Power Mac & Performa
    • G3/G4/G5 Power Mac, iMac & eMac
    • PPC PowerBook & iBook
  • Everything Elseā€¦
    • Apple I, ][, /// & Lisa
    • Newton
    • Software
    • Hacks & Development
    • Peripherals

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


FACEBOOK


GOOGLEPLUS


TWITTER


YOUTUBE


Location


Interests


OCCUPATION

Found 2 results

  1. Hello all, I had turned on my Powerbook 540c yesterday and it worked fine (although I forgot to turn on the external CD Drive so it wouldn't boot initially, derp). After using it for a bit, I shut it down as normal, but later in the day (and today) it didn't turn on; it remains completely silent. Am I correct in guessing that the power brick finally bit it, or could it be something else? I have heard of recapping the Blackbird's power supply, though it requires cracking open the enclosure... Thank you!
  2. I recently acquired an Apple Desktop Mouse II to use with my Powerbook 540c. While the tracking speed with the built-in track pad is fine, the tracking speed with the mouse, even at the highest setting, is painfully slow. I've opened up and cleaned out the mouse innards as best I can and wiped down the mouse ball with rubbing alcohol with little effect. Any advice?
×