Jump to content

Search the Community

Showing results for tags 'dead imac g4'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Important Information
    • The 68kMLA Forum Rules
  • Community Connections
    • General 68kMLA News & Stuff
    • Conquests
    • Trading Post
  • Projects & Hosted Forums
    • RetroChallenge
    • 68kMLA Wiki
  • 68k Model Forums
    • Compact Mac
    • Mac II, Quadra & Centris
    • 68k LC & Performa
    • 68k PowerBook
  • PowerPC Model Forums
    • NuBus Power Mac, LC & Performa
    • PCI Power Mac & Performa
    • G3/G4/G5 Power Mac, iMac & eMac
    • PPC PowerBook & iBook
  • Everything Elseā€¦
    • Apple I, ][, /// & Lisa
    • Newton
    • Software
    • Hacks & Development
    • Peripherals

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


FACEBOOK


GOOGLEPLUS


TWITTER


YOUTUBE


Location


Interests


OCCUPATION

Found 1 result

  1. Hi everyone, I have an Imac g4 17" 256MB 80GB Geforce 4MX This imac was last powered on 6 months ago according to the seller, it now makes no response to pressing power button at all. Here is what I tried: Replaced PRAM battery, reset PRAM by pressing the button, Hold power for 10 sec and plug back in, plug in and power at same time, resat the ram modules, tested diagnostic solder points and got 3.6V for battery, 12.20V for 12V, got 0.01V for 12VLSP and 5V. PSU was tested with multi-meter using the service manual guide and passed the test. I noticed some white and dry stuff around C241 on the logic board (next to 16 pin power connector) that needed to be rubbed off with alcohol, I replaced that cap. What should I do now? I've tried looking for logic boards but ones from the US seem to charge $100 for shipping alone on ebay.
×