Jump to content

jgk

6502
  • Content Count

    14
  • Joined

  • Last visited

Profile Information

  • Gender
    Male
  • Location
    San Jose, CA
  1. If I remember right, I originally needed it for the metal frame that held the LCD panel in the laptop lid of an old Dell, so, I bought the version that worked with metal. Since then, though, I've used it on many different surfaces, including plastic. Worked great, every time.
  2. This is the one I used: https://www.jbweld.com/collections/all/products/j-b-weld-twin-tube
  3. I've used this stuff (https://www.jbweld.com/collections/all) in the past, for similar issues on a laptop lid, and it's worked great. You could also rough up the surface around the break, on the bezel, and flood some of the epoxy around the post, to add a bit of extra strength to the bond.
  4. jgk

    Broken races on analog board Macintosh plus

    That looks somewhat nasty. I'd just buy a replacement analog board on Ebay. There are deals to be had there, every so often. BTW, with this level of damage on your analog board, I can only wonder what condition the logic board, and the monitor neck and yoke are in?...
  5. jgk

    800k drives...finicky!

    Looks quite normal to me. The internal drives on all the older Macs I've ever used behaved just like yours does. They always had that "strained" sound, even back in the 80's.
  6. jgk

    800k drives...finicky!

    Dug up some of the pics that I took when I did mine (over 13 years ago!). Have you completely disassembled and cleaned the entire eject assembly (pictured)? As I recall, the grease there on mine was pretty gunked up. If that's all moving freely, and you can manually actuate the assembly to easily pop a disk, then I would think it points to your eject motor, or the signal driving it.
  7. jgk

    800k drives...finicky!

    Last time I did this (which admittedly was quite a few years ago), I used a clear silicone based grease, primarily because I felt lithium was going to be too heavy. And at that, I used it very sparingly. As for the inject mechanism, mine was failing to inject, as a spring had snapped. Once replaced, it was functioning good as new. I'd check yours to be sure they've not stretched over the years.
  8. Hi all, I've got a few resistors to replace on a 512K board, but a quick look on DigiKey shows that even for a given resistance, wattage, and tolerance, there are still quite a few different types. Initially, I was just going to use carbon film, 1/4W, 5% tolerance, from a combo-pack I already have, but when comparing the leads on the original vs replacement, the original is a bit beefier. Anyone have any details on what they typically use as a replacement type? (e.g., 1/2W? metal film vs carbon film vs ???) Specifically, I'm talking about the resistors around the audio circuit, in the range from R12 to R23. (Had to remove all to clean up the board, but I'm not replacing all. Just a few that got a bit gunked up.)
  9. jgk

    Fixing Mac Plus sound/speaker

    Correction to my above post: I was (erroneously) looking at the original Mac schematics, not the Mac Plus. Looks like it's R22 on the Plus.
  10. jgk

    Fixing Mac Plus sound/speaker

    If you're getting solid, expected volume audio out the audio jack, then the circuit that's amplifying the audio is likely fine, and it's just your speaker. The schematic I have shows R1 (27Ohm) between the audio jack, and the pin going to the analog board that's connected to the speaker, so I'd check that too. Oh, and the audio jack itself has an embedded switch that disables the path to the speaker when something is plugged into the jack. Might want to check that too.
  11. jgk

    No sound from speaker on Mac 512K

    OK, it gets interesting. I had previously noticed a bit of corrosion (silver migration, perhaps?) between R18 and CR3. I had cleaned it up pretty well, and replaced R18, just in case. Started thinking about that part again, and resoldered the diode this time. Low and behold, I get a nice, loud "beep!" from the main speaker during boot-up. It eventually reverts back to the much attenuated audio, but I'll replace the diode and hopefully that will permanently resolve the problem. Fingers crossed...
  12. jgk

    FREE Boxed Mac 128K!

    Very nice. The floppies can be a pain to tear down and clean up. Takes a bit of patience. But, I did the one on my Mac 512K a few years ago. Works like new now, so it's definitely worth the effort.
  13. jgk

    No sound from speaker on Mac 512K

    Inspected it previously and it looked fine. Just reflowed it now, to be safe. Same results.
  14. Hi all, I've got a Mac 512K which is having sound issues with the speaker. Tried hooking up a speaker to the external audio jack, and while I do get audio, it's somewhat attenuated, and I have to crank up the volume on the speakers to hear it. Unplugging from the jack, I'm able to hear sound from the speaker, but it's very faint. (Unfortunately, I don't have a disk to generate a continuous test sound, so I'm just booting Dark Castle, and letting it play the intermittent audio from the splash screen.) One other odd thing: Seems like I'm getting some sort of feedback from the disk on the audio signal, as changes in the drive motor speed, or head movement are generating short beeps out the audio. Tried a MacPlus logic board with the existing power board, and that works fine, at least telling me the female side of J7 and the cable to the power board (and thus the speaker) are fine. Also, I was able to probe PA0:2 (pins 2 thru 4) of the VIA and see them all asserted. Thus, the paths in the 4016 for the three volume-adjust resistors are all active, effectively setting the volume to its highest. (Verified this by tweaking the volume settings in Dark Castle, and saw the changes reflected in the VIA pins.) Thought it might be the external audio jack, as I believe it has some mechanism to cut out the internal speaker when an external is hooked up. I do, however, get continuity when checking between R7 and R1, with no external speaker. So, seems like that's not an issue. Any thoughts? Without another Mac 512K logic board to probe how things should be for a working board, I'm somewhat stuck.
×