• Updated 2023-07-12: Hello, Guest! Welcome back, and be sure to check out this follow-up post about our outage a week or so ago.

TAM only boots if Command Key is hit and does not start using the keyboard power button?


Hi all,

I am the original owner of a TAM that I bought when the price fell to 1995 USD and I used regularly it until 2004. Since I have had some bad experience with exploding capacitor and battery on a Mac SE/30 (discovered it a few days ago) I needed to check the TAM. I remember it always could be started using the Apple Ergo Keyboard.

After I setting up the Bose Box and connected the power cord to it, I plugged the keyboard in and immediately while doing this, the TAM came back to live. After all those years, okay everything fine, not so. The system runs a Crescendo Accelerator at 400 MHz and has 128 GB of RAM, an USB PCI card and an Ethernet Communications card. I did also clone the 2GB (still own it) HD to a 10 GB HD.

But the TAM did not boot, it showed the Welcome to Mac OS 9.1 loading screen indefinitively. No boot. In a form I read okay kill the PRAM so I used the key combination and oh, the TAM did boot and I saw all my files from 2004, all okay, I did shut it down again and tried to restart it using the keyboard. Nothing. I unplugged the cable and the TAM started up and hung again at the Welcom to Mac OS 9.1 screen. And my 10 GB HD seems to have lost it, and showed the question mark sign.

I was able to boot the TAM from a HDD copy and could also connect the not working 10 GB disk using an USB case, files are all there. I cloned all the files from the backup disk to a newer 80 GB Seagate Momentus 5400.3, all worked well, but after shutting down the TAM, same story, I cannot power on the machine using the keyboard.

I found out that unplugging the keyboard cable power the TAM and after a few more tries I also found out, the TAM only boots if I hit the options key. So unplugging the keyboard and plugging it in and hitting the command key boots the TAM, but this is not an ideal situation.

Any thoughts what can cause this? I understand that the Computer Clock Battery should be bad but can a bad battery cause all this? I also noticed after the first time I could boot the TAM, the date was set to 27.08.1956 (no clue what this date was) but I could set the clock and after the additional attempts to start the TAM using my weird method, the date was still current but the time changed.

I do not have a source for a replacement computer clock battery, the original Rayovac 4.5 V velcro attached battery (did not leak) is still plugged in. Would replacing the battery solve all the weird boot issues with my TAM?

I would like to have it restored to working conditions without any weird tricks, as it was back in 2004 (I did power it on a few years ago and back then, there were no such issues, no leaked capacitors, as far as I can tell).
Last edited:


Well-known member
You don’t need a working PRAM battery for a TAM to boot, and I’m confused about powering on with the command/option key you’re sure it’s not the keyboard power on key top right?

Some tips
- press the CUDA switch on the motherboard with everything off for a few seconds, then reset PRAM
- Clean the umbilical connector and check it is clamped down fully
- The 4.5V batteries are no longer available, I use 3 X LR44 batteries in parallel others have used 3V CR2032 batteries in a custom holder with no issues
- Try another ADB keyboard, and don’t unplug it when in you can fry fuses on the motherboard doing this
- The TAM is super picky about upgraded HDs, I found if later model 2.5” IDE HD and slowest RPM drives worked best (5400RPM over 7200RPM)
- reapply the thermal paste on the CPU heatsink of the 603e CPU which would have dried out


Power on and boot problems

Yes unfortunately, it is for real, once I can power it by using these mentioned tricks, the disk shows the happy Mac sign, then it shows the Welcome to Mac OS 9.1 screen but does not boot until I hit the command key, no errors shown, it simply will not boot until I hit this key on the keyboard.

Powering on from the keyboard does not work, but if the TAM powers on (either by unplugging the keyboard or plugging in the power cord), it will not boot until I hit the command key on the keyboard. It will turn on the screen and hard drive, no problem, but will not boot fully.

Keyboard not powering on the TAM

I do not have a spare one but the one that came in the original box. But if this is a battery issue, swapping the keyboards I assume would not change the situation.

I re-read the manual (after all those years, excellent job of Apple, this is a really good manual) and I found a power button at the back, did not remember. Pressing the button does not start the TAM but if the TAM hangs I at least can power it off using this button.

I also noticed once everything is operational, the keyboard power button works just fine, one press and it will show the Restart/Power Off dialog, so the keyboard should be technicall speaking okay.

The fact that neither the power button at the back nor the power button on the keyboard powers on the TAM is what is puzzling me, can the dead PRAM battery prevent this from working?

Hard drives used

I only have 5400 ones:

- Seagate Momentus 5400.3 80 GB (currently used)
- Toshiba MK106GAP 10 GB (used for many years (cloned it from the IBM 5 GB drive), may got corrupted because of power off trial and error steps, did not boot and with that one installed I see the Questionmark symbol)
- IBM DPLA-25120 5 GB (I used this one to clone everything to the Seagate Momentus 5400.3 80 GB drive)
- Original Apple 2 GB Drive Model IBM DRCA-22160 that came with the TAM before I cloned it to the IBM 5 GB one

I used the Toshiba 10 GB PATA drive in the TAM for years with no boot issues but the booting is the same with this 10 GB drive and also with a 5 GB one I swapped just to copy the files from the 10 GB drive to the 80 GB PATA drive. The drive boot behaviour did not change, the TAM only boots if I (after I could power it on) hit the Command key. It would just show the Welcome to Mac OS 9.1 screen if I do not hit the command key.

All related to dead battery?

Since I discovered, the TAM does not even boot while pressing the power button at the back, is this an indication that the dead 4.5V battery prevents this from happening? By the way, the TAM also boots if unplug and plug in the power cord (so no need to do a hack with the keyboard, but it is still weird that plugging in the keyboard would also power on the TAM, since it can damage the motherboard, I will not do this anymore).

So soldering together 3 x LR44 would work, would the same be do-able with 3 x CR2032? I do not have a custom holder for 3 x CR2032 but I do have the batteries.

I can find those 840 4.5 V batteries on ebay, but I wonder if they would be in any good condition so going with LR44 and 3 x CR2032 would be better, but how to pack 3 x 2032 I do not know, can they also be soldered together?

What I have checked so far:

- I tried to do this CUDA switch recommendation now (no change in the boot behaviour) and I think the PRAM was reset also using Option+Command+P+R (but the screen did not come on, good thing that the power button worked to power it off)

- Umbilical Connector, no issues (it is clean). Clamped down (as usualy)

- not sure how I can remove the heatsink from the 603e. I have thermal paste at home but never removed a heatsink from the TAM.
Last edited:


Well-known member
Since it is booting partially, next time you turn it on, hold down the shift key and wait until you see the "Extensions Off (or Extensions Disabled)" message. See if it boots all the way. If it does, then you probably have an extension or a control panel that's causing a conflict, freezing the computer at that time. It might help, in that case, to download a copy of the Conflict Catcher utility off the Macintosh Garden, and install that. It lets you run conflict tests to find which file is causing the computer to crash or freeze up. So, it will start up with everything disabled, then add in files until the computer crashes. Once it does, and you've verified that the computer crashed, the utility will remove that last set of files it added, then add one in each time it reboots. Once the culprit is found, it can either be disabled, or you can cause it to load before the file it's conflicting with.

As an example, on 680x0 Macs, if you're running the Mac Identifier extension (or control panel for the 2.0 version) and have the CFM-68K Runtime Enabler file active, the computer will crash at boot with an illegal instruction error. The only way to get both files to coexist is to move the Mac Identifier extension so it loads before the CFM-68K enabler file. Either do it by adding a couple spaces before the "M" in the filename, or with the aforementioned utility, drag its name above the CFM-68K enabler's name in the active startup file set shown.


Well-known member
Remove the battery but keep it in a drawer. Even the 4.5v batteries leak and cause damage eventually, but when making a replacement it helps to have the old one about to use the wire and connector.


Keyboard swap

No not yet, the original one was never inboxed and I do not jave a spare one for the ADB bus. I do have a USB Mac keyboard but that is not feasible for this test, although since I cannot power on the TAM using the power button found on the rear nor using the,power button on my keyboard, I think that no other keyboard would power it on. It is very difficult to source a spare battery for this TAM, maybe this solves the power on issues.

I remember that very old Macs would not power on at all if this PRAM Battery is empty.

Battery replacement

I have been thinking of opening the Rayonvac Original battery case and fit it with what was suggested, 3 x LR44 or 3 x CR2032 but I do not have any clue if they can simply be soldered together or need to be mounted in a little separate housing.

Regarding extension:

This TAM booted always without hitting any extra keys, with that same set of enabled extensions as it is now. Imalso tried with Mac OS 9. only extensions, same issue, I need to hit the command key for it to continue to boot. Plus after I hit the command key, they show up during the boot process (no crossed ones either).

It may be a wild catch but I have a strong feeling that this super dead PRAM battery lets the Mac forget that it could boot and I then do the bootstrap procedure for him by hitting (not kicking) this command key 😊. Nevertheless it is super annoying that at the moment it does not work to my full satisfaction. Once booted, no issues. I hope I can restore the system to it‘s previous operational state, somehow.
Last edited:


Well-known member
CR2032s are 3 volts, you don’t want to use 3 of them. One and a half are enough! In fact you can use just one and it will work just fine.


I managed to find a 4.5v battery pack, containing 3 soldered together AAA batteries and an attached 2 pin cable. Will have to wait until it arrives. I also ordered the 3 x AAA box, but it takes more space therefore I will try the battery pack first.



I have received the 4.5V battery pack now. It has a tiny 2 pin connector that I could remove by bending the plastic that holds the small metal connector pins by using a pocket knife small blade. Not broken, only bent. The small connector pins I made then a bit bigger using a needle so that I could slide them over the pins inside of the TAM.

After a few trials and still nothing happened, I removed the battery pack and re-attached these connectors to the two pins on the motherboard more firmly.

What can I say, it works, again. The keyboard now powers the TAM and the TAM now boots, again, without hitting the command key. Strange I know, eben the power button behind the TAM now works, again, to power the TAM.

No other keyboards needed to try, no issues with the drive, it is all connected to the dead TAM battery. If the 4.5V battery is completely dead, the TAM simply won’t boot from the power button nor the keyboard.

Plus, because my TAM has 128 MB of RAM, I assume that the long time it takes to show the Welcome to Mac OS 9.1 splash screen is just normal 😊.


Well-known member
Plus, because my TAM has 128 MB of RAM, I assume that the long time it takes to show the Welcome to Mac OS 9.1 splash screen is just normal 😊.
If you open the memory control panel while holding down the (I think?) option key it shows an extra option that allows you to disable the memory test. This will speed up booting :)


The RAM test can be disabled by using the hidden switch in the memory control panel.

It is accessible also with the Mac OS up and running using holding down the key combination Option+Command while opening the memory control panel. It did not make a difference in my case (was off already).

Rebooting is in general much faster (Happy Mac only visible for a few seconds and then the Welcome to Mac OS splash screen apoears) so I assume the longer power on initial boot time is working as designed.

Great to see the TAM again back in action 😊.


Well-known member
That is so weird, the TAM is essentially a 6500 board, which I am playing with even nos and I never seen some like this…. Maybe the battery was not simply dead but also shorted out?


Well-known member
I don't know if machines from this era still have a separate Cuda chip or what, but I wonder if there's damage to the logic board somewhere around the Cuda. Like the trickle voltage from the power supply isn't making its way into it. That would explain why it only works when the battery's good because the Cuda has to be powered in order for the machine to boot...