• Hello, Guest! Welcome back, and be sure to check out this post for more info about the recent service interruption and migration.

SuperMac Thunder 24 GX Add On Drivers

Johnnya101

Well-known member
Anyone have info on getting a GX add on board for the SuperMac Thunder 24 (Not II!) to work? The only drivers I can find are for the Thunder II GX board. My issue is the Photoshop GX control panel crashes with the Thunder II drivers, so was thinking it is wrong?
 

slomacuser

Well-known member
You should install only IPA filters (Image Accel, Motion Blur) and IPM control panel

Do not use Filters for Other Apps in Photoshop as they are slower than built in Photoshop.

From the README

Recommended System version is 7.1 or greater.
GX Controls should only be installed on system with a Thunder II GX board.
 

Johnnya101

Well-known member
The IPA filters will work with the GX add on? Would that also mean the same drivers are used for the IPA add on card?
 

Johnnya101

Well-known member
Tried installing the IPA stuff. Photoshop gives an error saying the required resources are missing.
 

slomacuser

Well-known member
Picture of a board would help. Also what ver of PS are you using and what sys software. Also what drivers are used for Thunder card?
 

Johnnya101

Well-known member
PhotoShop 3.0.4, System 7.5.3 on a IIfx with recapped PSU.

The control panel freezes the system. The drivers for the IPA are IPA motion blur 2.5.6, Image accel 3.0, IPA more blur 2.0.2, IPA gaussian blur 2.0.2, IPA sharpen edge 2.0.2, IPA sharpen more 2.0.2, IPA unsharp mask 2.0.2, Photopress 2.5.4, and Image Processing 1.2.

I have SuperVideo 2.7.5 and SuperVideo 3.1 for the card itself.C948C6D4-4FFC-427E-8621-AD9BB10AC11D.jpeg
Photo of the GX add on.
 

slomacuser

Well-known member
If control panel does not recognise the card than it is a hardware problem. Could be the GX is not compatible with older cards
 

Johnnya101

Well-known member
The control panel doesn't even launch, it crashes the system. Wouldn't the control panel at least open? I can try installing the IPA add on to see if it will work
 

Johnnya101

Well-known member
Just tried with a stripped 7.1.1P. Doesn't instantly crash, desktop freezes and mouse icon glitches out. Then have to force restart. I'll try the IPA board next.
 

Johnnya101

Well-known member
Swapped over the IPA board. Control panel now leads to eternal flashing bombs. Maybe I have a corrupt driver folder? Found it on the garden.
 

slomacuser

Well-known member
Try with earlier drivers like IP Mgr 1.0.4 or 1.1 and Image accel 2.0.2 and SuperVideo 2.7.5 or earlier. What ROM has the Thunder card?
The IP Mgr 1.2 and Image Accel 2.5.6 were updated for PowerMacintosh computers and updated ROM 3.0 on cards. As you have a IIfx, you should use the software at the IIfx time ... Photoshop 2.0.1 to 2.5 and System 7.01 to 7.1 also
 

slomacuser

Well-known member
what nubus cards do you also have installed? what does the icon of IP Mgr look like at startup? is it crossed? If you put the thunde card out of computer the control panel should open without problems if not the drivers are corrupted
 

Johnnya101

Well-known member
what nubus cards do you also have installed? what does the icon of IP Mgr look like at startup? is it crossed? If you put the thunde card out of computer the control panel should open without problems if not the drivers are corrupted
Got it going! Looks to be working on a IIfx running 7.5.3, PhotoShop 3.0.4. Little later than its time, but seems to be working? Got a fresh reuploaded driver folder download, unstuffed, installed the EARLIEST control panel and filters, and it now works. Each Storm DSP plug in opens (think those are the ones?) and the IP manager now opens and sees the card.

Any blinking light feature like the Radius one to know when it is working?

Also, since I know you have a little experience with these cards, how exactly is the Raster Ops one supposed to work? The about plug in menu works for it, but when you go to use a filter, it freezes PhotoShop. Should I try reinstalling?

Have the following cards installed:
1. SuperMac Thunder 24 with IPA board
2. Radius Precision Color Pro XK
3. Asante Ethernet
4. Radius PhotoEngine(?)
5. RasterOps Photo Pro

I have tried different spots with the RasterOps card. The power supply seems to be very strong, it has been recapped and holds up perfectly with all 5 cards. TattleTech does NOT detect the RasterOps card, but I think in another thread that was normal? Oh, and the error when it crashes is type 1.
 

Nathan_A

Well-known member
Interesting, your card is different than mine. I have the "Image Processing Accelerator". It was "New in Box", and I just pulled it out today to put it on my SuperMac Thunder/24. There are two much larger footprint DSP chips on mine and a 64 MHz clock crystal.

PXL_20220605_200432965.jpg PXL_20220605_200419356.MP.jpg

I guess the "GX" daughtercard is a bit newer and a little bit faster. The DSPs are the same, but the "GX" ones are clearly a shrunk package. Your "GX" card also has that big SuperMac chip on it, which is interesting.
 
Top