• Hello, Guest! Welcome back, and be sure to check out this post for more info about the recent service interruption and migration.

SE/30 - Simasimac and a boot fail — I can't find the cause(s?)

jameswood

Member
Hi there, this is my first thread and I’m looking for help already! My SE/30 is… not so well. As this is my first thread, I thought I might as well be relatively thorough, and also introduce myself a bit. I'll put the relevant photos of the machine and scope captures at the end.

My Background
  • Australian, in Australia, officially a freelance graphic-designer-slash-creative-type by day
  • Electronics/3d printing/vintage computer, etc enthusiast by night and also too much by-day when I should be “generating revenue” or whatever??
  • Have repaired and restored several vintage Macs after becoming thoroughly addicted a few months ago:
    • Classic (x2)
    • Classic II (x2)
    • Colour Classic
    • LCII
    • IIsi
    • IIci
    • G4 Gigabit
    • Performa 5260 (in progress — too crumbly to really fall in love with, don’t want my heart broken when it collapses, but my 4yo daughter loves it and KidPix)
  • Haven’t yet retrobrited anything, but I have recently acquired the bleach cream and the UV source, and have a nasty stained mouse ready to go… just need the time, space, motivation and courage, but they’re not available on Amazon ¯\_(ツ)_/¯

SE/30 Background
  • Purchased my SE/30 as non-working from sad_mac on ebay (Shipping an SE/30 to Australia from the US cost a lot, but the total cost was still significantly less than buying one locally. WHAT.)
  • Logic board looks to be in good condition overall.
  • Cap removal, desoldering and some cleaning had been done before I received it
  • I have installed new Kemet tantalums and Vishay radial electrolytics
  • I have not touched the analog/power sections because on close inspection and measurement they don’t appear to need it yet (no leaks; happy volts)
  • I have re-cleaned the logic board in an ultrasonic cleaner with Electro detergent as recommended by Branchus (thank you!), then rinsed it in clean tap water, then soaked briefly in clean isopropyl alcohol before drying with compressed air and then baking at 105°C for about 5-10 minutes.
  • Included Apple 512k ROM. I’ve been told it tested good before shipping (could have gone bad since but I think unlikely)
  • Did not include RAM. RAM I’m using works in my IIci and my IIsi. I’ve tried 70ns in both 1MB and 4MB, always multiples of four at a time. Not mixing sizes. When ram is missing/incomplete/definitely incompatible, I get an immediate crash sound.
  • Nothing is socketed except for the video ROM.

SE/30 Symptoms
  • Semasimac screen: characteristic vertical lines with a different “texture” towards the centre third of the screen
  • No boot chime or other “physical” activity (does not attempt to boot)
  • Sound works: crash sound plays when pressing interrupt button (is this in the ROM??)
  • Crash sound on power up if no ram (or wrong ram) is installed
  • CPU clock signal not super-clean (C16M). Crystal signal to UE10 looks OK.
  • Activity on all data and most address lines: no activity on A0 and A1, unless interrupt pressed - normal for ROM? (Rom A0+1 pins NC on SE/30 schematic..?)
  • Even-numbered data lines have identical activity to one another (not checked all; D0,2,4,6 are identical to each other, as are D16,18,20,22)
  • Odd-numbered data lines also have identical activity (not checked all; D1,3,5,7 are identical)
    • To do: check this behaviour after pressing interrupt
  • Identical data activity confirmed using “math” on oscilloscope. Subtracting one from another gives a flatline.
  • UE8 and adjacent chips appear to be working
    • To do: confirm expected output from known input Note to self: Video section doesn’t interact with all data lines, only D24-D31
  • UG6, UG7 and UI8 and UH7 get quite hot when running outside of case with no fan.

Tried and checked so far
  • Re-cleaning in ultrasonic again - found some more goo under a chip, all seems clear now
  • Continuity checked and good on all data and address lines per matrix from redrawn SE/30 schematics
  • No shorts between adjacent or odd/even data lines
  • Video ROM appears to have activity on data and address lines but I can’t be sure because I’m measuring it in-circuit
  • Removing the video ROM didn’t change the symptoms (so above point likely irrelevant?)
  • CPU appears to walk the bus with no rom installed (checked with logic analyser. Not certain if signal voltage levels are good — will check with scope to see actual signals)
    • To do: remove all simms and check bus-walking voltages
  • Power supply voltages good
    • To do: confirm voltage rails with computer attempting to boot. Ripple on 5V? Measured OK on DMM but re-check with scope.
  • Analog board seems good
  • Lovely purple ROM on the way from Aberco on ebay for clean 32bit, but will also be useful to rule out bad rom.
  • Traces in the video multiplexing (?? I mean around UA8 to UG8 - is that what it’s called?) area have continuity and look ok. They do need solder mask. I put some on (prematurely) at first, and have since removed it for further testing and checking.
  • I was probing around UB11 (Sony sound chip) with the scope at one point, and managed to get a boot chime when I hit the reset button at the same time. This is the only time I’ve heard this machine make a boot chime. No hdd so no boot, but it did chime at least. I have focussed a lot on this area since and cannot recreate this. I thought it might be a problem with the reset line (bad switch, bad resistor, bad Sony chip??) but the reset line tested OK and the reset button resets the machine (tested by pushing reset after I cause a crash sound with interrupt button).

Current Theories
  • It could be two separate issues, or one: simasimac could be independent of boot failure
  • Bad PAL(s) — possibly UH7 generating bad clock on C32M
  • I'm realising now that I do not entirely understand how all the various clock signals work together
    • To do: understand the clock path better, if the waveform below is bad
  • Could UI6 be generating a bad C16G (is that where C16G comes from?)
  • The messy C16M clock signal could be causing the semasimac issue because the C16M line connects to all video PALs
  • The semasimac issue could be causing the C16M clock signal messiness
  • Bad CPU — duplicating data lines?

Questions
  • Are my above theories on the right track?
  • Is clock waveform OK or is it a giant clue?
  • Does UE10 generate C16M?
  • At the GLUE, C16G is connected to C16M. What do the G and M represent? (Could this be a typo at the GLUE?)
  • C16G appears to connect only the GLUE and UI6. UI6 is also connected to C16M. Why does UI6 need both?
  • UI6 appears to be clocked by C32M. Does UI6 generate C16G by dividing C32M?
  • Is the duplicated odd-and-even data line activity expected behaviour in the very-early boot process?
  • Is it normal for UG6, UG7 and UI6 and UH7 to get quite hot when running outside of case with no fan?
  • Is there a way to test an SE/30 ROM without access to another SE/30? (This SE/30 rom can’t boot a IIci or a IIsi, but I (now) believe this is expected)
  • Are there any suggestions on what to investigate next?
This has me stumped but I’m trying hard to solve it. I have tried to be as thorough as I can in this post; apologies for the length! I've learnt a lot and checked a lot in a short space of time, so apologies in advance if I've mixed up a bunch of concepts!

Thank you all in advance for any help, advice, pointers etc. End of too-much-text but here are some pictures:


CPU walks the address bus with no ROM (nothing on A0+1 (expected?)):
DS1Z_QuickPrint2.png

ROM for reference
tempImagetCJtEo.jpg


D0-D3. Evens identical; odds identical. Middle line is oscilloscope performing D0-D2.
DS1Z_QuickPrint4.png

D0, D2, D4, D6 (several cycles are superimposed here) Identical signals on multiple data lines.
DS1Z_QuickPrint5.png

Clock waveform (31MHz, C32M)
NewFile5.png

(Clock waveform from my LCII for comparison, at lower frequency)
NewFile4.png

Reset line (blue trace) doing its thing. (I can't remember if the logic analyser was on D or A pins in this capture)
DS1Z_QuickPrint1.png

Board front (disregard the RAM... I know: I was trying something and once these simms are in, I hate risking the plastic clips to remove them before I have to!)
tempImageRLaddP.png

Board rear
tempImageedqh78.png

Ende. Thanks for your attention!
 

Nixontheknight

Well-known member
Thank you! I don't know how to check whether or not it works in the SE/30, but it definitely all works in other machines
what you should do is put the sticks in the SE/30 two at a time (two of the same size) and see which ones produce the startup chime, and which don't, then omit the ones that don't produce the startup chime
 

jameswood

Member
Good plan! Although I think it needs to be four at a time on an se/30, which I’ve tried, and none produce a boot chime.

However! I decided to remove all the video multiplexing chips and, surely surprising to no-one, discovered they were in a lot worse shape than I’d thought. Dry solder, a couple of legs that tested ok for continuity but weren’t actually intact… etc. yikes. luckily I got them all off without lifting any traces. The vias were also full of hidden goo. Got it all cleaned up, hopefully. New parts time!

Thanks for your help so far; updates as they come to hand!

5A46368B-E0C6-4BA7-8ACA-90E1E4BFC4AF.jpeg
F992DFBB-DB72-49AE-A68B-D40EEC6232B9.jpeg
D295278C-9EDA-47CE-BA95-C8A83F31EF8B.jpeg
 

jameswood

Member
Oh, I also removed and socketed UI6 to try to track down the clock weirdness. The wave is now much sharper so perhaps it was partly due to dry solder joints on that chip. It seems the PAL works, which is nice 👍🏻
 

jameswood

Member
I've removed, cleaned, reinstalled and tested all of the video multiplexer chips, and the problems remain. Perhaps one of them is bad, BUT: I was checking the address and data lines on the ROM itself with my scope last night and I shorted something out. Suddenly I had a perfect Sad Mac screen. Rebooting with the reset button showed a clear Sad Mac screen again. I power cycled the machine and it went back to showing the same vertical lines as before. So at least I know it's capable of clear video!

I've realised I didn't show the stripes before (sorry), so here's a (bad) photo. I'll get a better one when I can. It appears to be attempting to show an alternating pattern of black and white dots, but for some reason it messes up the pattern every 1/3 of a line or so. I think that's how it looks, anyway.

1664865483713.jpeg

I think I might have a bad joint somewhere. All data and address lines have (had??) continuity when tested, but it really seems like it could be some kind of address-line issue. Could the sad Mac screen appearing be a clue as to where I should look? @techknight sorry to bother you but I saw your recent SE/30 Reloaded video so in my mind there's nothing you can't fix 🤣 In another thread, you said:
If anything, and I mean anything at all is holding up the bus, you would get nothing. no chimes, no nothing.
Do you think that could be what's happening here? If so, do you have any suggestions for what and where I should check next? I'm not really sure what I should be looking for. Address lines stuck high/low, etc? Or should some lines STAY high/low? during boot?

I still have no boot chime at all, no crash sound until I hit the interrupt button, and the same stripy screen with or without ROM installed. CPU walks entire address bus if no ROM is installed.

My next plan is to re-check data and address lines, and control lines to major chips.

edit: I also have a beautiful purple ROM which arrived fresh from France today (thanks @Siliconinsider !), to try out after I reattach the capacitor the courier removed from it for me 🤣
 

thellmer

Member
Check the top side of the negative lead of C2 - the big Axial - carefully with a big magnifying glass to make sure it isn't shorting the trace that runs literally a hair's width from it on the top side. I have been redoing an Se/30 myself and at one point was getting the same symptoms as yours and turns out when I put in the new cap the top-side solder blob was shorted to the trace next to it thus holding the reset on the GLUE chip low - and I mean only a micron gap separates them. Took me forever to track that one down and visibly I still couldn't see it until I checked with an ohmeter to verify the short. I also got siasma today when one of the PSU pins on the analog board had an almost invisible crack around it too. The PSU is an awkward connection in that it comes from the PSU plug then goes to the analog board, then the various logic board power lines run along the bottom and then reconnect to the plug that goes back into the logic board. SO even if the PSU is testing good outside the case, it is reliant on all those pins and sockets and both plugs to reconnect all the power and grounds back to the logic board from the PSU where they originate. The Siasma pattern can mean a zillion things - from an address/ROM/RAM issue to simply not booting since it has to boot to clear the VRAM and if it doesn't boot correctly the VRAM doesn't get cleared and that is the resulting pattern you see. Since you aren't getting the boot chime I would disregard the pattern for now and figure out why it isn't trying to even boot.
 

jameswood

Member
it has to boot to clear the VRAM and if it doesn't boot correctly the VRAM doesn't get cleared and that is the resulting pattern you see
OH!! That’s fantastic info, thank you so much. I’ll check out all the other things you mentioned as well, but this really makes so much sense. Perhaps when I accidentally shorted two ROM pins, I allowed the machine to move past whatever was blocking the boot process (but obviously it couldn’t complete the boot, sad-Mac-ing immediately after).

I was losing momentum and thinking of taking a break from the SE/30 for a while, but this new understanding has me motivated to keep going. Thanks!

Edit: and here is a better photo of the screen. Redundant at this stage, but I said I’d add one!
3F2C3213-D001-41C9-88D8-F98CB689A36C.jpeg
 

thellmer

Member
Yup, that is the exact pattern mine did both times as well as others I have worked on in the past. What you are seeing is a pattern of default junk in the VRAM that is being displayed when no other data is being shifted into them. Sometimes the pattern might be slightly different but usually its that same pattern you see there meaning the VRAM isn't being cleared from its default state for whatever reason. The successful ROM boot chime is fairly immediate when powered on. The chime of death melody usually occurs 10-15 seconds later when something else is wrong. But both would indicate the CPU is functioning and talking to the ROM. If you are not hearing either, your CPU isn't booting the ROM code which then does the further checks before booting or attempting to boot the OS. Sad mac usually occurs after the ROM boot while the system is checking out other things when it finds something wrong. Because you are never even booting the CPU/ROM you need to determine that root cause first. Reset held low...missing one or more of the crucial power voltages due to cracked solder or plug issues..etc.
 

mikes-macs

Well-known member
Don't get your hope up too high on this. I have two that do the same thing. They both eventually boot after a while of sitting at that same screen. I assumed it's all it can show while doing their slow memory test that they do with 64 MBs of RAM installed. But with less RAM installed it still shows this but for not as long. Doesn't seem normal. Unable to diagnos.
 

jameswood

Member
Voltages at the logic board look good, and C2 isn't shorted to the too-close trace.

I watched the address lines at startup. A5, A8, A15 and A17-19 appear to start out normally, then about 250ms after the reset, they all go high and stay there. After that it's all just blah. Now I think the Overlay trace might have something going on - it seems like that could fit the behaviour and timing? Not sure but at least it's something I can check!

Thanks Mike, I have failed to boot with only one MB, and higher amounts as well. Waiting for a very long time while I test things!

Thanks team, glad to have you all on the case!
 
Top