• Hello, Guest! Welcome back, and be sure to check out this post for more info about the recent service interruption and migration.

Netatalk..."The disk is locked"

mactjaap

Well-known member
I'm working with an old Netatalk version. Netatalk 2.0.2
Normal install. Everything looks fine I mount my Home Directory as always, try to write to it but get the message "The disk is locked"
I'm not getting it....how to "unlock" this disk?
 

mactjaap

Well-known member
A picture tells more..... As you can see a lock on my home directory.
 

Attachments

  • WhatsApp Image 2021-09-26 at 00.42.19.jpeg
    WhatsApp Image 2021-09-26 at 00.42.19.jpeg
    73.9 KB · Views: 14

demik

Well-known member
Two things:
- Either the share is now readonly on netatalk (can you share your atalkd.conf ?)
- Internal Netatalk errror.

That can happen if the database is corrupted/need repair/was opened by two process at once.

You will have to dig through netatalk logs.
 

mactjaap

Well-known member
atalkd.conf? Why can a atalkd.conf be of any importance? Why could it be locking my disk. I was in disbelieve .... ( yes I admit it...)
So .... I tried. My former setup was with a LocalTalk PC card. The zone is strange but an advice of the kernel module LTPC.

https://www.kernel.org/doc/html/latest/networking/device_drivers/appletalk/ltpc.html

dummy0 -seed -phase 2 -net 65280-65534 -addr 65281.41
lt0 -seed -phase 1 -net 1033 -addr 1033.27 -zone "1033"

Changed it to eth0 only
And tried again. Disk was not locked anymore....

BUT. There is also a change in system.
On my Macintosh ED I have System 6.0.8 with finder 6.1.8
On my network Basilisk II I have System 7.6

So I have to check with a newer System on a LocalTalk only Mac and LocalTalk PC card if it also works.
 

mactjaap

Well-known member
SOLVED! Ok. It is the system change, not the atalkd.conf.

Now running on a Macintosh SE System 7.5.3.
The disk is not locked anymore and I can upload to it! Happy with the result!

Not sure why I get this problem in the combination Debian Sarge (Debian 3.1) and System 6.0.8.
In Debian Woody (3.0) and System 6.0.8 I do not have this locked disk syndrome.
 
Top