• Hello, Guest! Welcome back, and be sure to check out this post for more info about the recent service interruption and migration.

Mac Plus and System 7.0.1: Address Error when Rebuilding Desktop

Iesca

Well-known member
Hello all,

I decided to try upgrading the system on my Mac Plus's external hard drive from 6.0.8 to 7.0.1. I used the Net Install of 7.0.1 and installed it to the drive over AppleShare from another Mac. It modified my original System unfortunately (I had renamed the System Folder in an attempt to avoid this), but regardless, when it finished, I restarted, and following the boot sequence the system began rebuilding the desktop for my external SCSI drive.

As the process approached its end, the dreaded bomb appeared: Address Error. Restarting with Extensions Disabled results in the same thing. However, I can cancel rebuilding the desktop, and everything hums along normally.

The Mac Plus has been upgraded to 4MB of RAM, and the external drive is a Seagate ST157N (identified by La Cie's Silverlining 5.31 as a Cirrus 45, though it resides in a GCC UltraDrive 40S enclosure). Silverlining has already mapped out the bad sectors on the drive, and I have run various memory tests using Snooper and MacTest.

I have not yet scoped out which version of the ROM is installed on the logic board, though I know that the main differences are with regards to external SCSI devices.

Should I just start over and try a clean install of 7.0.1? Or is this something I can remedy more simply? Again, disabling extensions does not affect anything.
 

Iesca

Well-known member
Tried re-installing 7.0.1 fresh with no prior System Folder, same Address Error about 80% of the way through rebuilding the desktop. Deleted old System 7 Desktop Files for good measure, and still no dice.

Very frustrating.
 

Crutch

Well-known member
I have not experienced this before. Here are a collection of ideas:

  1. This is probably a software error, but you’ve tried the most obvious things absent Macsbug. Here are some other ideas:
    1. Start deleting applications from your hard drive one by one and see if it stops happening — the fact that it always happens at a certain point in the rebuild makes me think Finder is stumbling on a badly corrupt file some how that is confusing it
    2. Install Macsbug and post a screenshot of what it shows on the crash and I or someone can try to diagnose (assuming you aren’t a Macsbug expert)
    3. Re-initialize your hard drive and start from scratch
  2. Just in case it’s a hardware issue:
    1. Try a different hard drive
    2. Try this on a different Mac, if you have one
    3. Try swapping out your RAM?
 
Top