• Hello, Guest! Welcome back, and be sure to check out this post for more info about the recent service interruption and migration.

Lisa system hang when booting any diagnostic image or disk

elemenoh

Well-known member
Got new ROMs which got me back to 'normal' where the machine will boot but only recognize 512K RAM with both boards installed.

Cleaning the CPU and socket with contact cleaner didn't help.

If it's the MMU it should be pretty easy to fix, though most likely those chips are soldered on the board. They should just be normal SRAMs which should be easy to find, and ofc the two adders.


@sunderCan you tell from the photo above which chips these would be? I'm unfamiliar and it wasn't clear to me from the schematic.

 

sunder

Well-known member
There's a bunch of them

See the schematic, it's the 74ls283 adders in schematic page: https://lisaem.sunder.net/cgi-bin/bookview2.cgi?zoom=0?page=3?book=6?

The adder chips are labeled U8B, and U9B, U10B

The SRAM registers for the MMU are: U8A, U9A, U10A,

Also the d-flops at U11D.

Basically most of the lower half of that schematic sheet has to do with the MMU. (The rest of that schematic sheet is mostly the video circuitry.)

If you look on the physical board, there's numbers on top of the board and letters on the left side, these map to locations on the board, so if you remove the "U" from the chip, you'll locate it at that position.

So for example U13A is the CPU location though it also occupies U13B and U13C.

 

elemenoh

Well-known member
Welp it turns out this was my own doing. I misread the hand drawn semi-schematic for the motherboard and had bodged pin 39 from the Mem1 slot to pin 39 on the Mem2 slot. Those are used to detect if both cards are installed. One should be connected to +5v and the other to Ground. After undoing that bodge, the second card was recognized okay.

I was then able to boot Lisa 2 System Diagnostic. The 'short' tests passed okay.

Pepsi Burn-in boots and runs but seems to hang on a floppy test. I was doing this with FloppyEmu so maybe some weirdness there.

Lisa Test 3.0 displays 'Disk Read Error' on boot. Will need to see if that's an image problem or something else.

I'll try doing all of these via real floppies at some point.

Anyway, it's working now!

13AxjuT.jpg


rGrtaTE.jpg


 

sunder

Well-known member
Yeay! Glad you fixed it!

Not sure if it helps or no, but I've had issues with the FloppyEmu and a 2/10. Perhaps it's firmware, but it worked well with 2/5's - I think mine was a version "B"

It basically worked to start booting but not after the OS loaded. But I think from the photos, yours is a 2/5.

Maybe try from the real floppy, and see if you still get errors as well, if you don't see if there's a firmware change for the FloppyEmu that might help.

 
Top