• Updated 2023-07-12: Hello, Guest! Welcome back, and be sure to check out this follow-up post about our outage a week or so ago.

Chasing down Lisa Error 52 (COP, I/O Board, etc)


Active member
I have a Lisa 2 that worked for many years, but has recently started giving an Error 52 -- and also immediately starting up when powered, instead of waiting for the power button. (Interestingly that light remains unlit despite the machine turning on.)

Here's what I've tried so far:

1) Replace COP chip with (allegedly) known-good chip.
2) Replace I/O Board with a different (allegedly) known-good board.
3) Swap another COP chip to both the original and replacement board, for a total of three COP chips tried.
4) Swap in an (allegedly) known-good CPU board
5) Test continuity between the internal keyboard connector and the 1/4" keyboard plug.
6) Made sure all contacts are clean and undamaged

All of these result in the exact same error, 52, and the same instant-on behavior.

Spelunking around for Error 52 shows these interesting discussions:
At this point my theories are:
  • Problem in the actual motherboard backplane that is blocking communication.
  • Problem in the female jack where the keyboard plugs in, or in that larger module.
  • Failing 1.8 power supply is no longer supplying correct voltage (see last link below)
I think at this point my next move is to recap the power supply, just to eliminate that from the equation, but would appreciate any other ideas...


Well-known member
Has your Lisa suffered any corrosion damage from batteries over the years, even minor?
I've had similar problems (not sure of the exact error code) in the past, and it all boiled down to bad traces on the motherboard backplane. I jumped many bad traces (on the underside) and finally got things working again.

Another thing you might want to check are the female connectors inside the case that the card cage plugs into. I've worked on a Lisa that actually had hidden corrosion damage *inside* that connector - severe enough that some pins were loose and later fell out entirely! Even slight corrosion might cause the pins to not spring properly into place. Just be careful messing with it too much - the pins are fragile and poking at them can cause them to break.

The 1.8A PSU is generally pretty reliable in my experience. If you do decide to recap it, I'd urge you to read my thread on PSU recapping, especially this post about choosing capacitors with the proper ripple current rating: https://68kmla.org/bb/index.php?threads/lisa-ac-interference-coupling.35554/post-384411

Good luck!


Active member
An update -- fully recapped the 1.8A PSU, mostly to get rid of the risk from the RIFA's. I've measured voltages on the Widget power connector and can see a nearly-perfect 12 and 5 volts. (Except for pin 3, but 5v doesn't seem to be necessary there).

I've created a page on TechTangents caps.wiki site just to document what I found... someone else on that site has started updating it with Mouser part numbers for replacements.

I've measured continuity through the "motherboard" at the bottom, and can confirm the signal traces from where I can reach the fingers to the back of the board. (Of course, there could be corrosion deeper inside the connector, but this board seems pretty clean.) Just to sure, I cleaned the "motherboard" ultrasonically, changed the caps on the I/O board, and inspected/cleaned all the socketed chips on the I/O board.

Still faced with Error 52 however. I'm beginning to think I should look for a spare "motherboard" on eBay, as that's literally the only component that isn't either known-good or that I don't have two of...

I suppose the other move would be to measure voltages at the COPS chip, etc. Kind of a pain to do that without a harness however...

Thanks for the tips on the motherboard traces and the internal case connectors, will take a look at that!


Active member
Realized the I/O board is facing the right way to do easy testing with the back cover removed and interlock defeated :)

I've tested each of the I/O boards I have, and both seems to be showing the correct voltages on the COP chip:
  • Pin 1: Ground
  • Pin 9: 4.86 volts
  • Pin 14: 4.86 volts

I think this means voltages are OK, and it's time to start testing signals somewhere (IO Board, CPU Board, both?)