• Hello, Guest! Welcome back, and be sure to check out this post for more info about the recent service interruption and migration.

Is there any way to use a BLU Widget disk image with an emulator?

drybones99

Active member
When I tried using the .dc42 profile image that I had working with LisaEm 1.2.6 with the new beta version, I got the ipc error again. Furthermore, when I attempted to create a new profile image by installing LOS 3.1 by booting from the first install floppy image, I get "The Tag checksum failed for this disk. It may be corrupted." This is followed by the same ipc error as before and an endless loop of the disk drive sound. The floppy images are in .image format, but they were working just fine in LisaEm 1.2.6, although I get the Tag checksum error there as well, but afterwards, it boots properly instead of giving me the ipc error. I suspect that the disk image may not be the problem here, seeing as I have been unable to get the virtual Lisa 2 to turn on in any manner with the beta LisaEm. If you need a BLU Widget image, I have already uploaded one at the start of this thread, but I'll attach it again to this post. Ignore the long string of numbers in the extension, for this is an artifact of uploading it on this website. The original file has no extension. I have also attached the LOS 3.1 Disk 1 that boots fine in LisaEm 1.2.6, but fails in the new beta version.

View attachment __-_BUILT-IN_PARALLEL_PORT_(10_MB_Widget_Hard_Disk).15240174b867249d873369e340911b47

View attachment LOS 3.1 1.image

 
Last edited by a moderator:

sunder

Well-known member
Ah ok, thank you for that LOS image. I've downloaded both and will check them.
btw, compressing the BLU image with xz reduces it down to 3.5MB:

Code:
-rw-r--r--   1 ray  ray   9.9M Mar  8 21:21 '3_-_BUILT-IN_PARALLEL_PORT_(10_MB_Widget_Hard_Disk).dc42'
-rw-r--r--   1 ray  ray   3.5M Mar  9 19:02 '__-_BUILT-IN_PARALLEL_PORT_(10_MB_Widget_Hard_Disk).blu.xz'
-rw-r--r--   1 ray  ray   410K Mar  9 19:03 'LOS 3.1 1-boots-on-126-but-not-127.image'
-rw-r--r--   1 ray  ray   9.9M Mar  9 19:07 '__-_BUILT-IN_PARALLEL_PORT_(10_MB_Widget_Hard_Disk).blu'


I'll start looking at this today.
 

sunder

Well-known member
Good news, I found some bugs in the code, it's now producing an image where the tags are correct, however, bad news, attempting to boot from it throws a 10726 error.

I found a couple of bugs in the converter program, and now, looking with lisafsh-tool, I see that the blocks that have the boot loader on the profile match the converted widget drive. I then tried to repair the Widget image using the LOS install disk #1 and it failed to do so with error 200/663, but not sure what that means.

View attachment __-_BUILT-IN_PARALLEL_PORT_(10_MB_Widget_Hard_Disk)_blu.dc42.xz

 
Last edited by a moderator:

sunder

Well-known member
Also tried to boot off a good profile image and attach the converted image on a dual port parallel slot (you can do that by changing the preferences, telling LOS there's a 2 port card in one of the slots, and that, say, the upper port is a profile) but the disk isn't recognized.

So likely there's some more stuff needed to get this working.

 

sunder

Well-known member
Hi, some better news, I tweaked the tool a bit more and now both tags and data is a lot better, I'm able to run the "dir" command in Lisafsh tool and it's also able to recognize the MDDF, likely this is now working, though I don't have time today to test this in LisaEm due to work obligations.

I'll test this later and if all is good and I manage to fix other bugs I'll push the code to github, and cut a binary release as well.

Hope this helps. :lisa:

View attachment __-_BUILT-IN_PARALLEL_PORT_(10_MB_Widget_Hard_Disk)_blu.dc42.xz

 

sunder

Well-known member
If anyone's interested I released the beta code that includes the BLU changes. I'll need more BLU images to compare to. While lisafsh is now able to get a directory, it's not right somehow. So the metadata for the directories is right, but when I try to extract the files they don't match known good extracted files from a profile image from LisaEm. It's possible this has to do with interleaving or the offset to the start of the file system.

https://github.com/rayarachelian/lisaem.git git repo

https://lisaem.sunder.net/downloads/lisaem-1.2.7-20200314-msw.zip windows binaries

https://lisaem.sunder.net/downloads/lisaem-1.2.7-20200314.tar.xz source archive

 

sunder

Well-known member
Yeah, this thread is about converting a Widget hard disk image taken with BLU to a dc42 image useable in LisaEm. There's some code to do this in the tools, but it doesn't fully work yet.

The error message means it's a disk image it doesn't recognize, I think because it's too short. BLU has the ability to save space by chopping off unused sectors at the end of an image, but libdc42 which is used in LisaEm expects a full sized 400k disk image. You can try thedc42-resize-to-400l tool to fix it. That said, the last time I tried booting BLU, it locked up in LisaEm, so it's probably not very useful.

You could try it with the H boot ROM and see if it works, or perhaps in 1.2.6 with the H ROM after you fix the size.

 
Top