• Hello, Guest! Welcome back, and be sure to check out this post for more info about the recent service interruption and migration.

IIGS Apple 3.5 Drive won't eject...

SlateBlue

Well-known member
The drive won't eject when the button is pressed, nor will it eject when dragging a disk to the trash. When I try the drag to trash method, the GS/OS appears to unmount the disk, but the disk drive will still show disk activity (light cycles on for a few seconds, then off, then back on), and the computer seems to freeze up until the disk is manually ejected. I've tried this disk drive on two different IIGS computers with the same result. It has been maybe a year since I last used this disk drive, and it was known working the last time I used it. It reads and writes fine, just has the weird issue with the auto eject mechanism not responding. Any ideas what could be causing the problem?

 

Elfen

Well-known member
Lets deal with the floppy drive first. Its time to open her up and relube her parts. Mechanically they are the same as a Mac Drive with some minor differences to the Ejection system. Just take your time in doing it. That should fix things for you.

 
Top