• Hello, Guest! Welcome back, and be sure to check out this post for more info about the recent service interruption and migration.

G4 Quicksilver wont turn on

NickNick

Well-known member
Recently I won a quicksilver G4 Power Macintosh for a good price stated as parts. Took a chance and it does not work. Was badly taken care of seemed to have been left out in a barn as there was mouse stuff inside of it. Literally took the whole thing apart and cleaned everything. Here's the issue, the motherboard didn't seem to see any memory at all, no matter what stick I threw into it and I tried about 10. All stating that were bad and gave either a single beep tone or sometimes gave three beep tones with a flashing power light. Washed the motherboard and processor with a tooth brush and rubbing alcohol and now it does nothing. Just produces a light at first that fades away. Machine is a 933mhz quicksilver with a super drive and 80gig HDD. Never had a Macintosh machine that did this. Anyone else ever have a similar issue? Any advice is appreciated.
 

CircuitBored

Well-known member
I've seen quite a few boards that behave similarly to yours. Quicksilver boards are fairly fragile - you can easily kill one by setting it down on the table too hard. There's barely enough solder on the pins that connect the memory, AGP and PCI sockets to the logic board. These solder connections are prone to cracking and causing trouble. I've fixed three different QS boards by resoldering the RAM/PCI sockets.

If your G4 was kept in a barn then it is likely that it saw a wide range of temperatures, which makes the cracking of solder connections even more likely.

It is also highly probable that your power supply is failing or has already failed. This is the second (and most common) widespread issue with QSs. If you have a spare ATX supply you can modify it for use with G4, with a few caveats.

If the board was especially dirty then it's possible that there is grime underneath the chips on the logic board. This can only be properly remedied by removing all the chips, cleaning them and the board, then refitting them. An ultrasonic clean will do a lot but it won't get everything.

I recommend that you first test the board with a new power supply and then reflow the solder connections (while adding more solder) if that has no effect. Beyond this point you need a new logic board. I have many spares so can help you out if needed, although I am based in the UK so postage may be prohibitively expensive.
 

NickNick

Well-known member
Thank you so much for your assistance! This is my first quicksilver in my collection, this style Macintosh case is my favorite starting with the G3 towers. I actually put the logicboard through the dishwasher yesterday as I thought what you just said that there was still gunk left somewhere. Still same response, except the fans turn on and the red LED on the logic board now lights up.

Didn't check the solder joints like you suggested but I will as that makes sense seeing it does not seem to see any memory. Also the processor chip doesn't even get hot. Heatsink is off and I can put my finger on the chip and gives no heat. I read what you just said about the power supply being bad and taking out logicboards or processors, more specifically the cache chips go no the G4 processors. There was so much dust inside too as the fans were gunked up. The processor fan had become dry. re lubed it and it works now. Feel that perhaps the processor is shot.

Should I have to buy a new logic board I will just look for a new machine as the case is not the greatest. Somehow the clear handles show signs of yellowing. As for the sockets tha GPU card also had a bad fan, still spins but its wobbly and super noisy. Think heat killed this machine. Thank you for all your suggestions. This model G4 seems to be the most problematic of the series.
 

herd

Active member
Can you test the CPU and RAM boards in a different machine? It sounds like something changed when cleaning, so maybe another clean with warm soapy water, then rinse with warm distilled water would help. You can gently blow from the sides of the BGA chips to try and clean out stuff under them. Is there a lot of corrosion?
 

NickNick

Well-known member
It sounds like something changed when cleaning
Agree. Actually thought about running it through the wash again but for longer, not just quick rinse. Plus I need to check for the solder joints as stated above by another member.

I didn't see a lot of corrosion but there was what looked like mouse pee on the board (my cats loved the machine lol). Something had dried on there but didn't appear to be cap goo. There does appear to be some tarnished areas or blackened areas of sorts in various spots on the logicboard. Mostly in the area where the dried substance was.

Perhaps another clean is in order. I still feel it might be the processor that is bad. I feel it should at least be getting warm when I feel it.
 
Top