• Updated 2023-07-12: Hello, Guest! Welcome back, and be sure to check out this follow-up post about our outage a week or so ago.

SE/30 Sound and Boot Freeze Issues


Well-known member
Pulling this into a separate thread for future search purposes.

I recently got a Macintosh SE/30 and have been working to get it back in working condition. This Mac did not have any battery bomb issues. The board was relatively clean. It had already been recapped before it came to me (tantalums for the SMDs and new axials). But the previous owner said the unit was not booting and was showing artifacts on the screen with no chime.

Initial Observations

There was a bodge wire from RP2 pin 12 to UE12 pin 18 that the person who recapped it had put in. Schematics show this connection is correct but I did not see any reason for this to be there. The trace on the motherboard between those two pins is intact and shows solid continuity with little resistance. So I removed it. Note that these two chips are part of the serial interface circuit and has nothing to do with the sound.

Second observation was markings on top of the UE10 chip. Clearly the person who recapped it was debugging a sound related issue as they have marked pin numbers on top of UE10.

Machine Configuration

At this point I should point out the machine configuration:
  • Macintosh SE/30 motherboard revision 820-0260-A
  • 4MB of total memory using four 1MB simms populating 4 of the 8 slots
  • Analog board and PSU recapped by me, both work fine when used with another machine and generates proper voltages
  • FDHD floppy drive
  • ZuluSCSI mini attached to the external SCSI connector (also tested a ZuluSCSI RP2040 connected to the internal SCSI connector)
  • No PRAM battery installed currently
  • ADB mouse and keyboard connected
Prep Work

I have washed the motherboard in IPA. I have triple checked the solder joints on the 14 pin connector coming in from the analog board. All of the connections look good and strong, and the voltages look correct on the motherboard side of that connector.

Problem #1: Stuck on Gray Screen with No Chime - SOLVED

I could not reproduce the display artifacts but the machine would not chime and stayed stuck on the gray screen. This resolved itself after I pulled the ROM, cleaned it (and the socket) and reseated it.

Problem #2: Crashes on Welcome to Macintosh Screen - SOLVED

I was getting random crashes on the screen with the Welcome to Macintosh message. I pulled all the RAM modules and tested them in another working computer. Turned out one of them was bad. I replaced all four of the RAM modules with known working 1MB modules (for a total of 4MB of memory) and I was no longer seeing the crashes.

Problem #3: Low Volume Staticky Chime Followed by No Sound - OPEN ISSUE

When powered on, you hear a faint, slightly distorted, staticky boot chime which quickly fades in volume to no sound. Booting into System 6.0.8 using either a floppy or external SCSI device, I can go into the Sound control panel and playing with the volume slider, there's no sound at all. The only sound that plays is again the low volume boot chime but no sound after that.

I have tried using a pair of headphones via the headphone jack. Plugging the headset in, the sound is properly routed from the speaker to the headphone jack but I still get the same faint, distorted, staticky boot chime followed by no sound after that. I have tested the headphones and the speaker with a different SE/30 motherboard and they work fine. The issue is somewhere on the motherboard. If I move the problematic motherboard to another machine (speaker, analog board, PSU), same sound issue. So the problem moves with the motherboard.

Strange Observation: normally when you play with the Sound Control Panel, you see the menu bar flicker (black/white) if you turn the volume down to zero. But at any other setting, the beep noise will play at the selected volume level. This is true whether you have a speaker plugged in or not. I tested this with a couple other Macs (albeit not another SE/30). BUT, on my SE/30, it doesn't matter whether you select no volume or any of the volume levels, the menu bar flickers as if you selected the no volume option. So clearly the System is detecting something going on with the sound hardware.

The sound circuit is here outlined in red:


I have pulled the C2 capacitor (which was new) and tested it. Both resistance and capacitance were good. The Y3 Crystal looks ok as well. I have also pulled the new tantalum capacitors that are part of the sound circuit (C3, C4, C5, C6) and tested them. They are also good and have the correct values (47uF on C3/C4/C5, and 1uF on C6).

I checked Q1 and Q2, both seemed ok. I pulled UA9 checked underneath and it was also good. The usual problem with pin 7 (12V) and pin 14 (-12V) being broken were not a problem on this machine. Connectivity to all the ICs in this circuit on all pins checked out, I went through beeping each one using an SE/30 schematic I found online. Visually I see no broken traces on the top side or the bottom side of the board. I have also continuity tested all the SMD resistors and capacitors on the bottom of the board (that are part of the sound circuit), and those seemed ok. Resistance values checked out on the resistors.

I have also checked the voltages coming into the sound circuit, namely +5V, +12V, and -12V. Those all look good at the pins on the ICs that expect them.

Next step: I'm in the process of pulling the three remaining chips I haven't touched yet, the two Sony branded sound chips (UB10 and UB11), as well as UE10. If everything looks good underneath as well as with each pin, then I'm going to stick some scope probes on the sound generation path and see if I can follow back from the speaker to where the sound signal disappears. Hopefully the issue isn't inside one of these ICs as then it's hopeless without a donor board.

Problem #4: Freeze on Boot on System 7+

Booting with System 6.0.8 whether via floppy or via external SCSI works fine. It's surprisingly fast (time from gray screen to desktop is like 3-5 seconds?).

But booting with System 7 or higher causes a freeze post the "Welcome to Macintosh" screen. When these freezes happen, the mouse cursor still can be moved, but the machine makes no further progress on boot even after 15 minutes. Under System 7.1.1, this freeze occurs right before it gets to the Finder on the gray screen after extensions load. Under System 7.5.5, this freeze occurs right after the "smiley mac" screen appears (after the Welcome to Macintosh screen) before any extension icons have appeared on the screen. In both cases, disabling extensions does not help. This occurs on Floppy or on SCSI. Doesn't make a difference.

It appears the newer OS might be exposing/triggering something wrong with the hardware whereas System 6.0.8 does not.

Haven't made much progress on this one because I've been focused on the sound issue which seems to be smaller in scope, hoping that a fix there might also resolve this issue and be related.

Pictures of the Motherboard

Please ignore the "weirdness" on the bottom of the board near where the Sony sound chips should be. The picture was taken while I was in the middle of removing the Sony sound chips. I had to pause as my desoldering gun got clogged.



If anyone has any suggestions, would appreciate it.

FYI that as I mentioned, I'm in the processing removing the remaining sound circuit ICs to clean them / check underneath. I have also since decapped all the new capacitors, checked each individually, and placed them back on the board.


Well-known member
Well, removed both sound chips. UB11 wasn't in that great a shape as pin 16 broke off with just a nudge and there was a partially damaged trace under it. But the trace wasn't completely broken and continuity was still good. Added some bodge wires and beeped out everything, cleaned everything, put the chips back on the board, and tried again. Same problem, no change. The continuity was all good prior to removing the chips so I didn't expect success. Hopefully this doesn't mean the chip itself is damaged internally.

Barring any internal IC damage, the only chip left that I haven't pulled in the sound circuit is UE10.

Before I remove it, I'm going to try to figure out how to use this 16 channel digital scope I got recently and then trace the sound signal as far as I can.


Well-known member
It appears the newer OS might be exposing/triggering something wrong with the hardware whereas System 6.0.8 does not.
I have a vague recollection of someone on this board having a problem like that which was related to the SCC and serial ports - that earlier System versions didn’t test the SCC, but later versions did.


Well-known member
I have a vague recollection of someone on this board having a problem like that which was related to the SCC and serial ports - that earlier System versions didn’t test the SCC, but later versions did.

Oh hmm. Thanks for this. There was that bodge wire in the serial interface circuit that the original recapper put in. Perhaps they were also trying to fix something there. I will need to look at that area further. Thanks!


Well-known member
@mdeverhart your memory is awesome! Thank you.

With that info I was able to dig up some theads my search didn’t turn up a few days back that contain the info you mentioned.

These look promising. Thanks!

Garrett B

Well-known member
I have a vague recollection of someone on this board having a problem like that which was related to the SCC and serial ports - that earlier System versions didn’t test the SCC, but later versions did.
I had a similar issue, and a replacement SCC was the fix. I determined all traces were making their intended connections, so chip replacement was the next logical thing to do in my mind.


Well-known member
Well hopefully it’s helpful and not a wild goose chase! 😀

Nope, your tip helped me narrow down my focus.

My SE/30 is fixed!

I had toned out all the ICs in the sound circuit but my focus had been to ensure each chip was properly connected to the board and could reach one other IC. Toning out all the connections for each pin for each IC was on my todo list but this really helped narrow down my search.

Based on those threads, I revisited the SCC (UG12) and the ASC (UE10). The SCC is part of the serial interface and I had only checked its connections with the ASC. Although I had tested each pin on the ASC, I had used the SCC as the "one other IC" when testing the data lines. I decided to go back and recheck those data lines and tone out to every IC those data lines are connected to.

All the data lines had continuity between the ASC and SCC... but when I went further and tested ASC/SCC to other components (ROM, SIMM sockets, VIA1, VIA2, SCSI, SWIM) I found D4 was broken somewhere.

I found the trace that runs from ASC for D4. It has a via which ties to SCC. That part checked out. It then continues to the SWIM. Uh oh... it passes by a row of capacitors (there were SMD electrolytic caps here before).

Right where those caps are located, there's another via along the way. I checked continuity between ASC and this via... nothing. Hmm. Then the SCC to this via... nothing. And then the SWIM to this via... beep. Moved the board under my digital microscope to take a look at this via... couldn't see it with my naked eye but there's clearly a break the thickness of a hair. Fixed this break which resulted in a good tone for D4 across all the ICs.

Went through the remaining data lines and other connections on the ASC and SCC, everything else looked good.

Then fired up the SE/30 to test. Good chime! And System 7.1 is booting now!! Yes, both my problems are solved! :)

I've finished installing System 7.1 and applications on the SE/30 and everything's working well now.


Well-known member
Good timing on this post!
It gave me the motivation to fix the sound on an SE/30 I picked up recently. My symptoms were no sound through speaker or headphone jack, but also the machine would partially hang when trying to play certain sounds in the control panel. I forget which sounds, but I believe it was the top ones. The machine wouldn't completely hang, as the mouse would continue to move. However, clicking wouldn't work. No changing windows, changing volume, etc. Would also not respond to keyboard presses. I decided I should look at the schematics and test as much as I could for breaks. I had literally checked all the connections I found except one. All connections to UG12 looked good, connections to UB11 and UB12 also looked good, connection to UK11 was fine. Then I got to pin 11. It should connect to pin 35 of the glue chip. I was not getting a tone. Tested from UE10 to a nearby via and there was a break. I scraped the solder mask away in that very short trip from the pad to the via and sure enough, right beside the pad there was a small break! I ran a tiny bodge wire, plugged it back into the analog board, and sure enough, I get a nice, strong bong!


Well-known member
While trying to get all my floppy drives to consistently read/write the same floppies, I found a problem with my SE/30. Sounds like something is still busted somewhere.

The machine reads just fine any 400K, 800K, and 1.4MB floppy. I checked the tag/data checksums from Disk Copy 4.2 and they all match. But as soon as I go to write, the system hangs (locks up). I tried the same exercise with an external 800K floppy drive, and the same lockup occurs. So it's not the drive. Once I got a crash error message (address error). So I suspect there's another broken or suspect trace somewhere.

I have toned out the DB19 connector to RP10, and then both RP10 and J8 to the UJ11 Swim Chip. I had previously toned out most of the SWIM chip to other chips but must be something I skipped.

Without the floppy, everything else seems to be ok when playing with the machine. I've put it through an extended set of MacTest Pro memory tests without issue. So something on the floppy write path is not working right. The obvious write/sense/read/enable pins all check out. Hmm.


Well-known member
It feels like if there was one cracked via (corroded via from capacitor leakage perhaps), then there’s probably another, this time from the SWIM?

I really appreciate your thorough report of the sound and boot problems and their cause, I feel I may be facing something similar one day.


Well-known member
No problem.

I've toned out all of the connections coming off the SWIM chip as well as UH7 which is tied to the floppy connectors. Also toned out the vias surrounding all the caps including death row :) (C8, C9, C10).

Will have to be patient and go carefully through most of the lines. It could obviously be the SWIM chip itself and/or UH7 although all the pins look pristine on both chips (ie. doesn't look like any cap gunk got anywhere near them). The hunt continues.


Well-known member
I've got a lead. It's UH7 pin 4. It toned out with near zero resistance. But if I apply pressure to that pin, it seems to format disks just fine.

This thread with a similar issue helped a lot:


Well-known member
Forgot that I left this thread hanging. This issue was solved and the root cause I documented into another thread dedicated to SE/30 floppy issues.