• Hello, Guest! Welcome back, and be sure to check out this post for more info about the recent service interruption and migration.

G4 cube slot loader fix

lobust

Active member
The slot loading dvd drive on my recently acquired cube was extremely sluggish to eject and would not inject fully without assisting the mechanism. I completely stripped it and cleaned and lubed the moving parts to no avail, and tried the trick to shrink the belt in boiling water that seems to be recommended on various forum posts here and there, I glued the rollers onto the shaft because they were quite loose and slipped easily on the shaft.

None of this made any difference.

What I eventually discovered was that the primary gear (a combined worm gear and small pinion) that is pressed onto the motor shaft was not tight enough on the motor shaft and was slipping. Presumably the aging of the plastic had caused it to expand slightly and lose it's grip.

I cleaned the gear and the motor shaft with isopropanol and applied a tiny amount of liquid super glue into the hole in the gear (I was wary about getting super glue into the front bearing of the motor, and this seemed safer than putting it on the shaft) and pushed it on into position as quickly as possible so the glue didn't cure before it was fully in place. I tried locktite first, but it would not cure for some reason, I guess incompatible with the plastic.

After I put it back together it works perfectly.

Perhaps this might help someone else diagnose the same issue in the future.
 

shadedream

Well-known member
Hmmm I'll have to look at this on mine. I've taken apart, shrunk the belt, cleaned the rollers the belt was on, cleaned the disk rollers thoroughly and even attempted to glue them to the bar they rotate on to make sure they weren't slipping, and mine still struggles to eject... would be really nice if this was the solution to get it working properly again.
 
Top