• Hello, Guest! Welcome back, and be sure to check out this post for more info about the recent service interruption and migration.

Clamshell left hinge screw

sfiera

Well-known member
I have two iBook clamshells I’ve been working on. I stripped them down this far, but in both cases I got stuck at the screw holding the left hinge, the one dead center in this photo:

ibook-left-hinge.jpg

It turns freely, but won’t come out. There’s enough of a gap for the grounding cable to rotate, though. I tried forcing the screw upwards, but didn’t make any progress. The screw on the right hinge comes out without any trouble.

A stuck screw is no surprise, but I wasn’t expecting to get stuck on the same screw in both iBooks. Is there something I’m missing? Is there something about this specific screw? Any advice on how to proceed?

 

bibilit

Well-known member
Probably the thread insert is loose and preventing the screw to be removed. 

I will try to use a small lever under the screw, while unscrewing at the same time. 

 

sfiera

Well-known member
I tried, but I didn’t make any progress. There’s not really room to get much leverage there. I also tried inserting a coin under the hinge, but that didn’t help either. There might be room to slip a thin wrench underneath to keep the insert from turning, if I knew what size was appropriate. (assuming the insert is hex-shaped)

I guess the extreme option is to cut the head off the screw or drill it out. I don’t have the tools for that, though.

 
Top