• Hello, Guest! Welcome back, and be sure to check out this post for more info about the recent service interruption and migration.

1MB L2 Cache Modules Gone Bad?

Nathan_A

Well-known member
So... I've got four 1MB L2 cache modules here for PCI Power Macintoshes & their comparable clones. Two of them work, two of them don't.

There's nothing visibly wrong with the ones that don't work. When installed they just prevent machines from booting. Power comes on, but there's no startup chime, no video, etc. The machines that the two failed modules came from boot just fine with no cache installed or with either of the two still working cache modules.

I'd love to try and diagnose and repair the two that seem like they're inoperable now, but I don't really have any good idea how to do that. I've also thought about donating one of them the cause of trying to recreate them since they're becoming increasingly unobtainium. Or even to the cause of making larger L2 cache modules (2MB or 4MB) if that's possible.

Anybody have any ideas?
 

trag

Well-known member
Are the speed ratings of the chips on the working modules the same as on the unworking modules?

Back in the day one was often advised to try removing the L2 cache module. Apparently a lot of the things caused stability problems, even when they were new.

Were you testing with Apple CPU cards installed or third party CPU cards?

The second question is relevant, because there are three "CLKID" pins in the CPU socket which are grounded or not. These signal what bus timings to use to Hammerhead on the PCI PowerMacs.

Third party upgrade makers didn't know about or know how to use the CLKID pins as late as the early G3 CPU upgrades. That's why no one could ever seem to get the bus speeds to overclock much beyond 45MHz on those early upgrades.

XLR8 knew what they were doing early. They had this PPC604e/225 upgrade card with adjustable speeds called the PowerBoost Pro (IIRC) and it had a little PIC on the board that took your clock speed switch settings and translated them into CLKID pin settings (as well as adjusting the clock speed).

That thing will drive the CPU bus up to about 62.5 MHz successfully. It seems like XLR8 didn't use that technology on their cheaper cards though. I wonder if the PowerBoost Pro came out late, after some of the early G3 upgrades were already released. There was some overlap.

Anyway, if you're using a third-party CPU card it could be signaling the wrong motherboard bus timing setting and that could exacerbate and limitations in the cache cards performance.
 

Nathan_A

Well-known member
I'll check the speeds. The two (1 working, 1 not) that I was fiddling with last night were seemingly identical to each other. Which makes sense considering they came out of the same make/model of machine. But, I'll take a closer look. The machine I was testing them in had a CPU upgrade in it, but I can swap it out and see if that makes a difference. The upgrade sets the bus to 50 MHz and isn't adjustable on this card (Sonnet).
 

Nathan_A

Well-known member
Based on the specs, all 4 modules should be able to trivially handle a 50 MHz bus. I tried them all with a stock 250/50 604e card. No difference. The same 2 work and the same 2 don't. I tried a 225/45 card I forgot I had laying around. No difference.

I've considered trying to do a simple reflow on one of the currently inoperable ones since I've got nothing much to lose, barring any better ideas for diagnosis & treatment anyone else might have?
 
Top