Jump to content

SCSI2SD wont boot on MAC SE, shows up under SCSIProbe as tape drive


Recommended Posts

I have been trying to get my Mac SE FDHD to boot using SCSI2SD.   I have been tinkering with it on and off for a few months with no success.  I finally got a copy of SCSIProbe to see what was going on.  Booted with System 6.0.8 and SCSIProbe 4.3.  SCSIProbe showed the problem, the Mac thinks they are tape drives.

 

SCSIProbe_results.thumb.jpeg.b9a81d2499953c526682ac0012bc6aa2.jpeg

 

 

I have tried both a v6 and a v5.2 hardware and both are updated to latest firmware.  I have tried using the builtin termination and an external termination.  I have tried playing around with the vendor and product id to see no change.  The config file for the screenshot above is attached.  I was trying different settings to see if would make a difference on any one of the four partitions.  The actual partition layout of the SD is attached too.  The SD contains a system 7.5.3 configuration with four drives total.

 

I dont understand why it shows up as a tape drive and why the vendor, product get garbled.  But, it definitely explains why the MAC wont boot from it.

 

Does anyone have any ideas?  Anything else to try?

tested_cfg.xml SD partitions

Link to post
Share on other sites

Tried a nice simple 2GB partition with 6.0.8 and reconfigured SCSI2SD.  Followed http://www.savagetaylor.com/2018/01/05/setting-up-your-vintage-classic-68k-macintosh-using-a-scsi2sd-adapter/.

Wouldnt boot either.  So a quick check of SCSIProbe gives me a single tape drive again.  I then unplugged the power and removed the SCSI cable to the SCSI2SD and rescanned for devices just to verify the "tape drive" went away, and it did.  In addition SCSIProbe warned me that the bus was terminated with the SCSI2SD removed. 

So, it seems the SCSI2SD is kinda of working.  I just dont know if its the SCSI2SD acting weird, a bad config, misidentification by SCSIProbe, or a strangely flakey SCSI on this MAC SE.

Link to post
Share on other sites

More info.  Plugged in my external SCSI CDROM and SCSIProbe identified it correctly, as a ROM.  So, looks like the problem is with SCSI2SD. 

Cant believe its a config issue as the 2GB SD I last tested was pretty simple.  Guess I will have to reach out to the developer, although I cant find a support contact.

 

Any thoughts?

Link to post
Share on other sites
  • 68kMLA Supporter
Posted (edited)

'U' is one bit off from 'T', specifically the '1' bit.  And the tape peripheral type is also 1 bit off from the 'hard disc' peripheral type, specifically also the '1' bit. 

 

The / in the version field ought to be a . (ASCII 47 vs. 46), and so there bit 1 is firing in error; and I'll bet the !s are meant to be spaces (ASCII 33 vs. 32) so there again the bit is being set in error.

 

Looks like you have a bit that's intermittently turning on on its own.  Why, I don't know.  Try a new SCSI cable to start with?

Edited by cheesestraws
Link to post
Share on other sites

As you have tested two versions of SCSI2SD (V5.2 and V6) that are not sharing the same bus driver I would also suspect the cable as mentioned by cheesestraws (those flat cable tend to get bad contacts it they are pulled from the nap).

You could also check this cable by hooking the CD Rom driver with the internal connector. 

Link to post
Share on other sites
On 5/5/2021 at 2:51 AM, dochilli said:

Did you read this?

Perhaps you can show us the configuration of the scsi2sd?

Do you use the newest firmware for the scsi2sd?

 

First, thank you for the replies.  Here are some additional details and questions answered.

 

Thanks dochilli for the reference to the article, I hadnt seen that one.  The configuration XML is tested_cfg.xml in original post.  I have attached the xml from the 2GB images I was testing with too.  Both xml are the values read back from the SCSI2SD.  Yes, I did have the latest firmware and I reflashed it from PC instead of my MAC to see if it made a difference.  No luck.

 

Thanks cheesestraws.  I will try your suggestion.  When I saw that the spaces for the CDROM also showed up as "!" I figured it must be SCSIProbes way of showing them.  I too was thinking maybe I should change the values by one and see what happens.  As far as the cable I have tried two different internal cables and a separate external cable.

 

Breathing, I will try the cdrom internally.  That would be a good check if there was a problem with the SCSI interface on the internal side.

 

 

I did get a hold of the developer but he hasnt replied to my additional details. 

 

I want to try three more things this weekend: all of the suggestions you gave, more through testing with the V6 SCSI2SD (only quick testing done before), testing with my other Mac SE (not FDHD).

 

Thanks again for the help and support

scsi2sd_2GB_plus.xml

Link to post
Share on other sites
  • 68kMLA Supporter
16 minutes ago, SharksWithLasers said:

When I saw that the spaces for the CDROM also showed up as "!" I figured it must be SCSIProbes way of showing them

 

A CD-ROM's device type is 5, which already has the 1 bit set, so the 1 bit toggling itself on sometimes wouldn't prevent a CD-ROM drive from being seen as a CD-ROM drive.  If that is showing !s instead of spaces, then it's likely that that is misbehaving in the same way.

Link to post
Share on other sites
  • 68kMLA Supporter
16 minutes ago, Crutch said:

Just for clarity we are counting bits from 1 here not 0 right? Bit 0 has value 1 and I think that’s the one we’re talking about? :) 

 

Gahhhhh.  Yes.  You're right, my brain is apparently terminally confused.  Bit 0.  Value 1.  Sorry. :-)

Link to post
Share on other sites
  • 2 weeks later...

Sorry, I havent checked back in.  Work kept me busy.

 

I still plan to test the cdrom internally and I ordered a SCSI ZIP drive to test with too.

 

In the meantime I tried something new.  I installed a SCSI card in my Windows XP machine and it recognized the driver correctly both configured as a CDROM and as a hard drive.

So, it looks like I will need to inspect the SE motherboard carefully and maybe replace the SCSI chip.  The ZIP drive will help me to figure out if the just the internal or the external connections are faulty.  I will also get my other Mac SE up and running and see if the SCSI2SDs are working fine on it.

 

Thanks again for the help. 

Link to post
Share on other sites
  • 3 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...