Jump to content

Need some help setting up macipgw-VM. Modern computer will recieve appletalk packets from the powerbook via the ethernet port, but the VM won't recognise the mac


Recommended Posts

Good morning everyone.

The past few days I've been attempting to set up file sharing via AppleTalk between a modern computer and my old Powerbook 520c, as I recently got an AAUI-ethernet transciever. My first idea was to simply connect it to the internet using Netscape, but I forgot system 7.5 doesn't have any TCP/IP configuration by default, and as I don't have a floppy drive for other computers I could not transfer MacIP to it.

My next idea was to set up file sharing from my os 9.2.2 running iMac, but when connecting the two devices directly via an ethernet cable the transciever would not link. I'm pretty sure I did something wrong on this attempt, as I didn't read much into it, but it was more convenient to attempt to connect to a more modern computer.

This is when I stumbled upon macipgw-VM, which seemed like the perfect program for what I was trying to do. I downloaded virtualbox and the OVA file to my Windows 10 computer and turned on wireshark to make sure I was in fact receiving appletalk packets via the ethernet port. I connected the powerbook and the laptop directly via an ethernet cable and turned on the VM.

This is when the problems started to appear. At first, virtualbox would throw an error that stated it "could not find the Realtek PCIE Fe Family controller". To troubleshoot this, I changed the settings of the VM so it attempted a bridged connection from my ethernet adapter instead. After this, the vm would get stuck while booting at "A start job is running for raise network interfaces" and once it booted it would not recognize the mac or even allow me to nbplkup. 


After this, just as a test I attempted to bridge a connection from my WiFi adapter. It booted just fine and I could do nbplkup, where it showed the macipgw device and file sharing server, but obviously it didn't recognize the mac. After this I attempted to use both virtualbox 6.2 and 5.2, tried bridging two network adapters, with both wifi and ethernet, and tried it on a ubuntu running laptop I had, but no solution would work.


Since I've seen this program discussed on this forum, and I'm pretty sure people here have a better understanding about how it works than me, I am asking you for help, as I wouldn't be surprised if I missed a crucial step or did a small thing wrong while setting it up.

Link to post
Share on other sites
  • 68kMLA Supporter
Posted (edited)

I made the MacIPgw VM so I guess I should know what to do. :-)

 

I don’t know what is going wrong directly. You also tried a few things I would be careful with.

- The VM should run on a computer connected to your home network. So directly on a switch. Same as your Powerbook 520c with AAUI-ethernet transciever. Hook it also to your home switch. 
- Don’t try anything with WiFi or a direct network cable between two computers. 
 

I will boot the VM in my own environment and see if I can help you. 

I switched to the Raspberry version so I don’t use it anymore. It is a little bit old now, but will work I think. If hou have a Raspberry Pi.....

Edited by mactjaap
Link to post
Share on other sites
  • 68kMLA Supporter

Yes. You need to install MacTCP. ( https://en.wikipedia.org/wiki/MacTCP)

But to test if you 'see' the MacIPRpi only AppleTalk will do. Just open the Chooser and see if the MacIPpi is sharing its disk.

Then download and install MacTCP if you are running system 7 .0 to  7.5.1. Above it is Open Transport.

Let me know if it works!

https://macintoshgarden.org/apps/mactcp-206

 

 

 

 

 

 

 

 

Link to post
Share on other sites
  • 68kMLA Supporter

I don’t understand why you think it is not possible. You can use file sharing. You don’t need MacTCP for file sharing......

AppleTalk and Chooser.  That is enough. 
 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...