Jump to content

MacIP in Professional MachTen


Recommended Posts

I'm trying to get a network up using macipgw and an AsantePrint, and it actually fully works on the Mac side of things, but it doesn't seem to work through Professional MachTen. I have the networking pane configured properly (at0 IP 172.16.2.2, gateway 172.16.2.1, DNS 8.8.8.8, search domain macip.net), and it seems to bring the at0 interface up at boot, but I can't actually ping out or reach anything. Setting the IP to 0.0.0.0 (in order to have it dynamically find the zone and get an IP) also works and sets the IP to 172.16.2.2 but I still can't actually use the network. Anyone have ideas?

Link to post
Share on other sites
  • 68kMLA Supporter

Nice to hear your trying my stuff.

I build MacIP VM and Rpi images to make it possible to use IP and LocalTalk. But you can use it in a network. Not sure what solution you are using. VM or Rpi?

Don’t know MachTen. But that is my problem. I will have a look. 

Link to post
Share on other sites

Thanks for making those images! MacIPgw-VM is working perfectly in this instance, it's just something to do with how MachTen needs to be configured.

 

As an aside, it seems that the VM has quite a few things that depend on the name of the interface being `enp0s3`. I was trying to run the VM in something besides VirtualBox, which resulted in a different interface name. I tried to find everything that depended on the interface name and got everything working except for DNS on the Mac side. So, as an alternate solution, I created a udev rule in /etc/udev/rules.d called 60-net.conf with the contents

ACTION=="add", SUBSYSTEM=="net", DRIVERS=="?*", ATTR{address}=="interface MAC address here", NAME="enp0s3"

, which worked around the issue perfectly. This may help others in the future if you want to mention it on your site.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...