Jump to content

Disk II drive not spinning up


Recommended Posts

TL;DR

 

My Apple II Plus goes straight to the basic prompt instead of spinning up the Disk II drive in wait of a floppy. The drive is just quiet and does nothing. I got it working for a short period of time, but then it died again. It has power though. Where should I start my troubleshooting?

 

 

Long version

 

I just picked up my first Apple II (Plus) the other day and now I'm going thru everything, step by step. The first problem I had to tackle were some keyboard issues. But after re-soldering and changing a few switches all keys worked.

 

My next problem was the Disk II drive. It didn't start at all when I tried it the first time. I took it apart, inspected all components, cleaned it a bit and re-attached all connectors. After which it came to life. I could load a few programs from floppy and all seemed good. Then the keyboard started to behave weird again, typing wrong characters and after some time no characters at all... I decided to put the computer away for the day.

 

The following day I managed to fix the keyboard problem by re-seating and cleaning the chip at position A3. After a few reboots everything was normal again. Time to try some more floppies. And now the Disk II was dead again...

 

So what happens when I turn on the computer is it goes straight to the basic prompt. It does not wait for the drive. The drive does not spin and the head doesn't re-calibrate. I've measured the voltages on the drive connector and they seem ok. I can see the drive LED flash slghtly when the computer is turned on and when turned off.

 

Where should I start troubleshooting? Can it be the controller card? I've tried it in both slot 3 and 6. If I try the "PR#6" command the cursor disappear and then nothing more happens.

 

I should also add that I downloaded a diagnostic disk and converted it to audio (using the c2t tool) and after loading for 10-15 seconds it goes to some "INSTA-DISK" screen, the disk drive spins up for a few seconds (while making some noise, not the normal head calibration noise), then gives a "DISK ERROR". So it shows the computer has some control over the drive.

Edited by blindowl
Link to post
Share on other sites
4 hours ago, bibilit said:

Hard to say without another drive side by side. 

Probably an issue with the drive (board)

is the drive spinning freely by hand ? Belt still there ?

 

Yeah, belt is there and it spins if I move it by hand. My first thought when it started working (briefly) was that it came to life after I moved the belt/motor (after being still for 30 years...). I've tried that again but no luck. And the load-from-audio method I described actually causes the disk spin, so the motor/belt seems fine.

Link to post
Share on other sites

I think it's fixed now. One of the transistors on the interface card looked kinda strange. Upon closer inspection, I could see that the component had been replaced at some point. And the PCB had been slightly damaged during the replacement. I removed the transistor, cleaned the card and put it back again. And now the device starts up again. Hopefully it will last longer than overnight this time ...

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...