Jump to content

6100 - Recap and internal speaker issue


Recommended Posts

  • 68kMLA Supporter

Hey everyone,

 

So, I just finished an overhaul of my AudioVision 14", and then turned to my 6100 DOS to get it back in shape. Absolutely no issues prior to recap, just preventative. Caps removed easy: no lifted pads. Replaced them all with same spec 47 µf, 16V organic polymer surface mount caps. No issues so far. Now, when I use the machine, after a while (presumably when it heats up), I start getting all this crazy loud crackling through the internal speaker. I have the thing hooked to the AudioVision and it does the crazy dance through the cable converter via the PC Card cable, etc, and there is a speaker mini plug plugged in the back, so the internal speaker should automatically just cut out. The sound through the AudioVision is crystal clear - it works just fine. It is just the internal speaker with this crazy crackling. It comes and goes, and is worse the longer the machine is on. So to sum up, get good, normal computer sound via the AudioVision while simultaneously getting crackling through the internal speaker.

 

I suspected some bad soldering on my part, so I desoldered, cleaned, fluxed, and desoldered them all. To be fair, one was somewhat loose. So, I double-checked and desoldered all 13 of them. Started the machine w/o the AudioVision hooked up - got a good startup sound through the internal speaker. Thought I was good, but after 5-10 minutes, the crackling came back again. Not sure what is up with this. Only the caps were touched, nothing else. Could I have accidentally hit something else? Maybe, but what? What else would cause this out of nowhere? Otherwise the machine is 100% functional, and the DOS card works perfectly as well.

 

Any guidance would be super helpful!

Edited by LaPorta
Link to post
Share on other sites

Ugh, I hate problems like this. You have to check every component from the speaker back, unless someone knows of a common failure point on these. I see you used organic caps, were they shade grown and free trade too? I kid! I kid!

Link to post
Share on other sites
  • 68kMLA Supporter

Thanks, Matt. I have a bit of an update.

 

So, The four caps that appear to be in the sound area (the sound input from the CD drive plugs in nearby, and it is right behind the sound output jack), I desoldered them, cleaned the pads, resoldered, cleaned the terminals on the caps...basically made them the spiffiest, cleanest cap job I ever could. Played some Marathon for maybe 30 minutes or so, everything seemed great. Then...crackling from the internal speaker! So, I experimented a little. I shut off the AudioVision speakers, and just kept dinging the alert sound. So, during the crackling, sometimes you can hear the alert fade in and then back out. Sometimes when the crackling stops, there is no sound, and other times when it stops the sound then is just clear. Is it possible one of the caps is just bad, a manufacturing issue that was not picked up because it doesn't appear until the thing is sufficiently warmed up? But...which one if so? Plus, are the four caps in that area the only ones that deal with sound?

 

I wish schematics for this thing existed.

 

Any other suggestions would be helpful.

Link to post
Share on other sites
  • 68kMLA Supporter

Well, one of the caps toward the front of the MB did appear to have some "grit" in the solder of one pad. I must have inadvertently introduced it while soldering. The problem now seems to be fixed. Check your work thoroughly, I guess!

 

Now I also added a 32 MB SIMM (brand new!) to the PC Card. Got Windows 3.1 and Wolf 3D running...although with no sound?

 

Along with a power supply recap, I am glad this thing is freshly overhauled!

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...