Jump to content

Macintosh classic analog board fluctuating voltages

Recommended Posts

hey, this is my first post to the forum.

A couple of days ago I bought a lot of old computers in which came 4 Macintosh classics, not a single one turned on.


I chose to start working in one of the 220v models as it is the voltage that my country has.

After researching a bit on reddit, this forum and such, i came to the conclussion that the Analog board needed to be recapped.

 after recapping the a/b now the computer turned on, but the screen wobbled a lot and showed a checkerboard pattern, after researching a bit more, I washed the logic board, then tried again, same thing.

i took out the logic boards from all 4 macs, washed them, tried them, same thing.

then i came across a post on this forum about measuring the voltages at the floppy port.

i got 11.2v and 4.2v in the floppy connector, with that known, I researched a bit more and then replaced optoisolator, dp3, dp4 and IRFBC40.

now the computer is showing the exact same problems that the user 6502 has made a post about, after two minutes of being turned on, the computer suddenly boots, the screen stops shaking, and it boots from the hard drive.

im stumped as what it could be as the reported solution to that problem is replacing the optoisolator, dp3 and 4.


sorry for the bad formating and English. English is not my native language. 

Link to post
Share on other sites


searching this forum a bit more, i saw a post about blasting heat to the A/B to make it start quicker so i grabbed my smd resoldering station and with the mac turned on started blasting ic's with 150º air, sure enough, the mac started almost instantly this time.

I narrowed it down to the TDA4605 IC.

I will be replacing it tomorrow.

will keep updated.

Link to post
Share on other sites

Hmm, the rifa caps apear to be perfect although I haven't tested them yet.

As I said in the first post i already replaced the optoisolator, the mosfet, and both 1n4148 diodes.

today I will be replacing the TDA ic and see if that solves the problem, I think it will, If not, I will get to testing those rifa caps as you said.

Thanks for the reply!

will keep updated.

Link to post
Share on other sites

All B/W in Classic Macs, including the Classic Series all suffer from such issues.


Seems to me that the voltages are a bit off, but I believe it is something pulling them down, in the high voltage section of the board. Things to do are:


...Excuse me as I am doing this blind without a schematic so I can't say the actual parts numbers...


1) check and resolder cracked solder joints. DO NOT REFLOW THE SOLDER BY HEATING THEM! Desolder the old solder, clean up the area with Alcohol and Acetone, and use fresh new flux and solder on the board.


2) (Should be 1 and 1 Should be 2) Check for burnt connectors (J1 on most B/W 9in Macs, it connects the board to the crt's yoke), Clean them up and resolder if slightly charred (light brown). Use a file or emory cloth to clean up charred pins on the connector. Get a new connector if any pin/plastic it is dark brown or black. Again, DO NOT REFLOW THE OLD SOLDER! Use new Flux and Solder.


3) T1 (High Voltage transformer), and the parts around may need to be replaced. On other Macs it is the T1, Large Cap near by, Transistor on the Heat sink and a nearby Diode connected to the Heatsink usually all need to be replaced. A tiny coil (L1 on older BW Macs) sometimes usually needs to be replaced but I find desoldering and resoldering it usually fixes this one part.


This should fix 90% (if not all) of the problems you are having. Get Larry Pina's "Macintosh Upgrade and Repair Secrets for the Mac Classic."  Also get the "Dead Mac Scrolls" as well. It has the parts numbers you would need if you need to replace them.


Looks like the logic board(s) need recapping too. So start slow and take your time. It is easy to break pads if you rush things. clean the cap goo with alcohol and acetone (q-tip with acetone for really rough spots to get the good out). Rinse with distilled water and alcohol. Tap water has salts and minerals that can ruin a board if you use it.


Good luck.

Link to post
Share on other sites

Hey Elfen, thanks for your reply!

I already have reflowed the usual suspects such as the yoke connector and high voltage parts of the board with flux core solder. I also went arround every solder joint with a magnifying glass for visual inspection of hairline cracks.

The logic boards do need recapping, I already have the  tantalum caps for that, I just want to finish the nightmare that is the analog board.

for testing purposes they do work so I won't worry about them (yet).

Today I replaced the tda4605 with a tda4605-3 which I know is compatible.

the first start went great, computer chimed and everything, but i noticed that the hard drive did not spin up, so i checked voltages. 12.04 and 4,7.

then I restarted the mac and im back to the same old situation, if I heat the tda ic or wait 2 minutes, it will start right up.

I was worried about something frying the ic, so i checked the datasheet for the tda chip and got that pin 6 on the ic should not surpass 20v ac while running.

I meassured the voltage and pin 6 is receiving 79 volts ac.

I honestly have no idea as what can cause this, and im pretty sure my new ic is dead.

Link to post
Share on other sites

Ok. so I downloaded the bomarc schematics for my board (the late model, without the zener diode dp1) and obviously the first thing that struck me was that at the end of rp1 (22k 3w) there should be 12v ac.

I measured and im getting 120v ac both at the start and the end of the resistor AND now at pin 6 I am getting 120v almost double of what I was measuring before!!!.

I tested the resistor and it came out perfect. I desoldered cp4 and dp4 since those where the only things connected to pin 6 outside of the 22k resistor, I still got 120v ac. I even desoldered the tda Ic again and measured just to be sure, it was still 120v.

In the same post that talked about heating the ic to get the computer to work the temporary solution that the user got was using the computer without a ground lead in the plug, I resoldered everything back in and tested that.

now, the computer works great, always boots and the screen doesnt shake at all.

but that kind of "solution" is not a solution and to be honest I don't want to get electrocuted to death.

(also without ground the voltage on pin 6 is 145v).

If anyone has any other schematics with more detailed voltage readings I would be really grateful for that.

Even if this nightmare of a proyect takes me 2 years to figure out, I will NOT be giving up on it under any circumstance, I might have to desolder every component on the board and test them individualy, but I don't care, i will get it fixed.



Link to post
Share on other sites

Hi Iyo,


I'm in your same situation, I know it does not help much at the moment but at least we can share some experience.

I have partially resurrected a Mac Classic which was dead-silent, analog board code 820-0525-C.

I replaced most of the capacitors, the TDA4605 (regulator), CNY17G (opto isolator), 79L12 (regulator), IRFBC40 (mosfet), 2 schottky diodes 


Now it starts up till the system 7 shows up, but shortly after it BEEPS and reboots showing an horizontal while stripe with a weird pattern.

The 12V drops down to 10 ...


This behaviour has to do with overheating, maybe some resistor (which one is had to tell because the resistance is probably ok when cold), the transformed maybe:(.

I can try to replace the remaining capacitors and the zener diodes.


In my case, since it re starts before showing a weird pattern in the CRT, it might be something in the main power supply circuit, but what?


Anyone can suggest what else to replace, the board is almost new :)









Link to post
Share on other sites

Hi!, first of all thanks for your reply!

I think we are having different problems here, because your board boots first time but after a couple of minutes the voltages drop off.

my board does exactly the opposite thing, the thing starts with the checkerboard pattern but after a couple of minutes it boots and works just fine.

But I believe we still can help each other out.

First, some questions that I want to ask you.

Do you have the computer plugged to 220v? is it connected to ground?

What voltage do you measure at ressistor RP1? It is the big 22k 3 watt ressistor that connects one of the pins of the bridge rectifier DP9 (the voltage is ac).

I would greatly apreciate those readings, as they dont show up in the schematic that I have. 

I uploaded the schematics for the classic in case you need them. (I think you will, these boards are a nightmare to work on)

you can also ask me for any reading you want, of course.

with that said, replace both 1N4148 diodes (DP3 and DP4) I read that they are a extremely common problem in these boards.


Best of luck with your board, will wait for your reply.


Link to post
Share on other sites

Well, I have found the culprit of my suffering (spoiler alert: its my fault)

To make it quick, it is the octocoupler. 

I thought the one i bought was compatible, but it seems it wasn't.

I got started with another one of the other macs to get a break from this one.

recapped it, put a new tda in it, new diodes and cp4 and 5.

I turned it on, and to my surprise, same exact symptoms, but this time i got a idea, instead of heating from the front of the ic, I heated where the solder joints are, and sure enough, I can spend 30 minutes heating the tda and absolutely nothing will happen, but after 5 seconds of heating the octocoupler the computer starts immediately.

so, if you are suffering the exact symptoms as me, double check the octocoupler, you can heat it, or just buy a new one, the computer will work again.


So it seems the "nightmare" I was suffering turned out to be my own stupidity and lack of knowledge about these old macs.

At least I serve as an example to double check your own guesses, I spent 5 days scratching my head, I changed the ic 3 times, same with diodes and caps to no avail.

I got frustrated at first, but now im quite happy as I have 2 working macs.







Link to post
Share on other sites

Hi Lyo,


I am glad you fixed your problem, it does not matter the reason, you simply made it, so I assume you do not need the reading now.

About my classi: while I was bench testing the PSU with the multimeter, I notices the voltage from 11,4 jumped steady to 12,2.

So I gave it try and .. it worked, it is not hours that it is no, floppy, HD, SCSI2SD ... it does not restart anymore.


Unfortunately I did nothing, so the problem might appear again in the future.

About the DP3 and DP4 I checked them, they were just fine.


Enjoy your Mac




Link to post
Share on other sites

Well, It seems the problem has not ended yet.

I replaced the octocoupler with a 4n37. And the computers worked great for a while, I could switch them on and off all the times that I wanted to and all that.

then, the next day I went to turn one of them on and the same symptoms returned, wobbly screen image, low voltages unless I wait or heat up the octocoupler.

Now, I know that the octocoupler is the issue here, I replaced it again and got the exact same results (it worked flawlessly for a while, then it didn't anymore)

Now, Here comes the question. Is the octocoupler failing because it isn't compatible or is it failing due to some other flaw in the board? How can I measure if it is something wrong with my board?

I can't seem to get a correct list as what can be used as a modern replacement for the CNY17G-3, so the 4n37 was kind of a wild guess from me. 

as octocouplers degrade with age I don't want to buy new old stock or something like that, But again, every single octocoupler that seems to be compatible with the cny17g-3 seems to have been descontinued years ago.

Link to post
Share on other sites

Thanks for the replies!

I did not solder a socket, now that you mention it, i should have.

there shouldn't be any thermal expansion in the joints, to get it to work I only need to heat it to about 70 degrees (celsius).

but maybe the octos are failing in a way that makes them thermally intermittent on the inside, i have no idea why, but they might.


As for why I don't use the cny17g-3, I sincerely don't know how i got the Tda ic, it was kind of a miracle, but trust me, I tried every electronics store in the city, and not a single one sold the cny17g-3, one sold a cny17-3, which was the first one I bought and tried, and it did not work.

I cannot buy them from an online source like mouser as I don't live in the US or Europe so it would cost me a fortune in shipping.

Link to post
Share on other sites
  • 4 weeks later...

well, it seems that this will be the last update for this thread.

I bought another cny17-3 and this time, instead of soldering it directly I soldered a socket first. It seems I was killing the octocouplers with the heat from the soldering iron.

I have been testing the machines for close to 2 weeks now, and everything seems fine. 

I started to restore the plastic in the macs with 10% hydrogen peroxide and uv light, that is also going great.

I have an entire 512K macintosh that came with the lot that I haven't even cracked open yet, so I probably will be returning to the forums in some time.

As always I am extremely thankful for the support that is given in this forum, and the patience of other users to share information. I will try to do my part helping now that I know a bit about this machines.




Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...