Jump to content

Apple II+ pure white screen?

Recommended Posts

So have an Apple II+ I'm trying to get working.

The issue I'm running into is the screen is PURE WHITE.  But why?  Its like the CPU is idle doing nothing.


#1 I built a new PSU using a PICO & 1705 voltage regulator to get -5v. (All voltages test correct)


#2 I replaced the 3904 transistors but not the A13 one yet. (No change)


#3 I only have a single row of memory chips in.


#4 There is no beep.  PWR LED doesn't work but 5v power is going to LED correctly.


Anyone ever seen this before and know what a might be wrong?




Edited by zezba9000
Link to post
Share on other sites
  • 2 weeks later...

Ok so maybe people can help me identify the voltages on these caps, if they differ at all.  Are they all 50v?


I now replaced all the electrolytic caps & transistors on the board and one of the ceramic ones.

Also have a single row of NEW memory. Using old memory also doesn't change anything. So its probably not ram.


I now get this on the screen.



Replaced power light with LED.




Here is a picture of all the ceramic cap types. Are they all 50v?  If so why do they differ?




So I also re-seated all chips on the board as well.  Unless someone has a better idea I was going to replace all ceramic caps but need to be 100% sure I'm replacing them with the right ones.


Link to post
Share on other sites
8 hours ago, bibilit said:

Don’t think your issue is related with capacitors. 


Garbage screen is either Ram or Rom related. 

Well pretty sure its not RAM as both original ram and new ram produce the same result.

What ROM chips should be replaced or investigated first?  Sucks they're so expensive.  Are there new 3rd party ROMs for Apple II+ ?

Link to post
Share on other sites
20 hours ago, bibilit said:

Without another unit to swap, hard to say. 


Yes 3rd new units are available, not very expensive. 



So read you only need the F8 rom to use ASM.

I removed every rom but the F8 ram and the same issue happens. Remove the F8 rom as its block garbage.  So it might be the "341-0020-00" / F8 ROM.

But I can't find a 3rd or first party one anywhere.


EDIT: ok looks like I found one here: https://jesperalsed.com/vintageapple/product/341-0020-00-2/

Edited by zezba9000
Link to post
Share on other sites

So bought a working board of the same model.

I went through and replace all chips one at a time till I found the bad one.

It wasn't a bad ROM FYI.


Is this a memory controller chip?  Picture shows good chip from other board but thats where the bad one was.

Funny thing is its the LAST chip I tried replacing... wow I have bad luck LOL.



It now works!!!  So I will buy a replacement chip and have two working boards.



Also do people put heatsinks on some of these chips that get a little hotter?

Link to post
Share on other sites
21 hours ago, zezba9000 said:

Funny thing is its the LAST chip I tried replacing... wow I have bad luck LOL.

That is why, whenever I find a bad chip, I always replace 2 more, just so the one that fixed it wasn't the last one I tried.


Sorry..  Couldn't help it.. ;-)


Great find!!!!

Love reading these threads!

Link to post
Share on other sites
  • 2 weeks later...

So I'm having a problem still after adding a disk-drive interface card. It stops reading drive and spits garbage data similar to @bibilit issue he shared here.

FYI: Frogger I loaded above was done via tape input.  Many times loading from tapes will have the same/similar issue.


What I do:

* Power on computer with drive and Mario Bros disk mounted with FloppyEmu

* Computer beeps

* Computer beeps AGAIN but spits out junk similar to @bibilit issue he shared.

* Drive stops being read and game never loads


What I've tested:

* Drive works perfect in known fully working Apple II+ motherboard and Apple IIe computer.

* I tested ever single chip with known good ones from Apple II+ motherboard. RAM etc is all good.

* The 74LS283 was not the issue as I hoped like bibilit had.

* If I turn on the computer with no disk mounted THEN mount a disk it SOMETIMES will load BUT text is messed up in some apps


I'm currently deep cleaning the motherboard to see if anything changed.

I'll take a picture of what it displays after its cleaned but if anyone has any ideas what could cause this when all chips are confirmed working.

Edited by zezba9000
Link to post
Share on other sites
19 hours ago, bibilit said:

If you can, try a copy of MECC inspector or similar, to test ram an Rom. 


A single bad ram chip can do that, I know that you are confident ram is ok, but I have seen ram becoming bad pretty quickly. 

You're right I had 3 bad ram chips. Guess I tested wrong last time.

Now its 100% stable and working! Ran it for an hour with no issues.


I also added some heat-sinks on chips that got hot. Hopefully it keeps them from overheating and lasting longer.




Also modified my FloppyEmu cable so I can easily attach "DISK ][" drive cables


Link to post
Share on other sites
On 9/3/2020 at 9:24 AM, techknight said:

What was the chip type/number of the chip you replaced out of curiosity? (I am taking a tally mentally from all the different repair experiences, and so far Ive found the LS138 to be less than reliable)

Besides the bad ram the bad logic chip was: SN74LS153 to the right of the last upper row of ram as you can see in the picture.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...