Jump to content

Resurrecting a few 128k/512k boards

Recommended Posts

I've finally got around to sorting through a box of broken logic boards that I inherited. Four or five of them are 128k and 512k boards, so I figured that it would definitely be worthwhile to try and get them going again. I have a 128k that was chip-for-chip upgraded to 512ke, and I want to backdate it to 128k with 400k drive for historical curiosity. The other boards will be available to others once I am done! This is what I built my test rig for: being able to quickly diagnose boards like this:




The majority of the boards are throwing what appear to be RAM-related errors, which, to my research, appears to be quite common with these machines, especially those with original, Apple-screened RAM. All visible errors are one-liners, starting with 04 and one with 03. So, to start, does anyone have a good, reliable source of the 64 and 256 kbit RAM chips these thing take at a reasonable cost?



Link to post
Share on other sites

Crap. So I order these things, spend three hours desoldering the one bad chip, and solder in the new one. Nothing.


I look up schematics. Turns out these things are NOT pin compatible with the original RAM! What in the heck gives. How frustrating. Does anyone have any insight into a source of pin-compatible stuff for these? I mean, I can make a breakout board and wire it correctly, but come on.


Here is the pinout from the spec sheet on the order site:




And from the Mac 512k schematics:



Link to post
Share on other sites

Ok so I sorted all this out on paper:




Basically, the ground and 5V pins are reverse...why, I have no idea. So, I went ahead and raised the 8 and 16 pins up, inserted wires into their corresponding holes, and rearranged them. I used a new RAM chip in case I fried the other.EAB05247-CBF2-4830-AC7F-3665EF8ECDC5.jpeg.8972b7479586148174f9762c9052c90e.jpeg


This arrangement produces the same result:  nothing on startup. No chime, no video, nothing. It may be that these chips just don’t work at all...what do I know about it? I wish I knew of a known-good source. Otherwise I’m kind of stuck here. Open to all suggestions.

Link to post
Share on other sites

That’s crazy that the pin-out is different on them. I figured that was the same on all 64k RAM chips.


Hopefully someone can tell you why it isn’t working, or where there’s a good source for the proper RAM chips. I don’t know, unfortunately.

Link to post
Share on other sites
  • 68kMLA Supporter

IIRC, Uniserver claimed to have laid in a supply of those chips several years ago.   You might search the forums and see if he mentioned where he sourced them from.  

Link to post
Share on other sites

Did you change the RAM chip after you powered it on improperly and then rewired? If not, that chip is dead. You cant reverse polarity on a chip and hope it doesnt die it will die. usually instantly. 


As far as the exact RAM, I dont remember off the top of my head. I havent needed to replace RAM in these machines before as most of the stuff I ever worked on was SE and newer. 

Edited by techknight
Link to post
Share on other sites

Yes, I used a different chip in the assumption that I fried the other one. By

my hand drawing at least, does the logic look correct? Also, the pin that the chip lists as N.C., I just kept the pin out of the hole

and soldered it up to keep the +5V continuity path. Was that a mistake?

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...