Jump to content

iMac G3 refuses to power on - used to work fine

Recommended Posts

Hello everyone! 


I recently got an iMac G3 cheaply from a thrift store missing the hard drive and ram, but it powered on and gave the beep signal for no ram, so I bought it. I got a stick of ram from a friend, installed a hard drive, and it even powered on to the blinking question mark. However, after returning to the computer after burning an install disc for the OS, it no longer would turn on. I will attach a video of what it does. 




In case this does not load, the speakers click a few times, and the CRT makes noise that sounds like static that persists for several seconds after I let go of the button. I do not get power LED, bong, or HDD spinup.


Things I have tried:

-resetting PMU (with the motherboard button)

-leaving iMac unplugged for 2 days and trying power on

-leaving iMac plugged in for 2 days and trying power on

-disconnecting hdd and CD drive to reduce psu load


None of this has fixed it. I have tried googling but have gotten everything from people saying it is simply a bad p-ram battery to capacitors to PAV failure. I really want to get this machine working (my first apple computer, although I am far more experienced with PCs) and these problems are out of my depth so I need some help to diagnose the issue. 


Computer info:

-blueberry 1999 slot loading

-350mhz, no FireWire

-ram: pc133 (compatible to PC 100) 256mb

-hdd: 120gb Western digital 7200rpm


Due to coronavirus, I don't have most of my tools (normally I have access to an oscilloscope) and haven't gotten access to a new pram battery to change as the shop that sells them is closed. What can I do to get this computer running? Thank you in advance for your help! I tried to cover all info but will give more if needed.



Link to post
Share on other sites
  • 3 weeks later...

It would be worth testing your PRAM battery, and if it's out of voltage spec, replacing it. Even if it doesn't fix the problem, it will be a necessity to have whenever you get it fully functional.
I've got the same model as you, that's also dead. The power LED lights up, but nothing else comes alive or makes noise when the power button is pushed. I've tried all the troubleshooting steps and have attributed the problem to the PAV board, which I learned is the common failure point on all of these.
I thought I had a NOS replacement PAV board purchased on ebay, but after 3 weeks, the seller never shipped, and ebay had to refund my money. I'm on the hunt for a working one, but I am more curious about repairing the current failed board.. which is where I can't find any information. I'm following this post in case anyone has any information on the repair of these models. B) 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...