Jump to content

Wifi Extension Development Thread


Recommended Posts

  • Replies 213
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Posted Images

  • 4 months later...
  • 9 months later...

@ants Firstly thank you for all your work, but I am struggling, I hope you can help me get this working:

system:

---------------------

Powerbook 190

Using System 8.1 with 40mb ram

pcmcia 3com 589 ethernet

Opentransport 1.3

---------------------

Process I followed:

GL-AR300M16 / Updated to latest OpenWRT 19.07 (sets the default ip to 192.168.1.1)

Connected it to my wifi to see if the bridge is working (yes it does)

Installed Json RPC, which just involves this correct?

opkg install luci-mod-rpc
/etc/init.d/uhttpd restart

Installed ethtool

Swapped eth1/eth0 devices

added:

ethtool -s eth0 autoneg off speed 10 duplex half

to my startup paremeters (infront of exit 0) Is this correct? Because in your readme you state 'eth1' but I think this is supposed to be eth0...

---------------------

- Checked that my Mac can browse the internet, yes it can

- Configured the tool with the 192.168.1.1 host and root/password

- click refresh networks

- nothing happens

---------------------

The mac is connected to the WAN port, I think this is right since we swapped eth1/0? It must be talking okay since I can browse the internet, but the wifi extension doesn't seem to work.

Is the router meant to be in the first/default dhcp mode (with the hardware switch to the left) This is what I am using it on. You don't mention this switch in the documentation.

 

Any thoughts appreciated, thank you.

 

 

Edited by stormy
Link to post
Share on other sites

NEW DAY, NEW TESTING:

 

Okay decided to start again, I re-flashed with the latest GL-AR300M16 firmware from the manufacturers website, this still includes WRT 18.06 so it should be fine. I figured it might be the pure OpenWRT that might be causing an issue. After this, I was facing the same difficulty so I decided to omit the Ethtool stage and not swap the ports - voila! The Mac was talking to the Router.

 

I have the menu with all the Wifi signals, it connects okay! BUT, none of my programs connect to the internet because of 'no DNS server'. So for some reason it doesn't seem to be getting DNS server info, I tried inputting my own manually in the TCPIP Mac settings to no avail. 

 

This is where I am at, will update with any news.

 

EDIT: Just FYI there is no mention what the physical mode button should be set to in your guide. Should it be in router mode? I assume it should.

EDIT-2: I tried setting the DNS server manually to the Cloudflare 1.1.1.1 in tcp/ip settings of the Mac, programs look and try to connect, but still come up with DNS not available.

Edited by stormy
Link to post
Share on other sites

Hey @stormy sorry for the delay, unfortunately life has gotten in the way of all my hobbies! It's great to hear you got the wifi menu working with OpenWRT, please post a screenshot!

 

I don't think the DNS issues will be too sinister, I'll fire up my Mac today and check my settings. But can you at least hit websites by IP address? e.g. 17.253.144.10 (apple.com - but you'll just get an error page)

Link to post
Share on other sites
17 hours ago, ants said:

Hey @stormy sorry for the delay, unfortunately life has gotten in the way of all my hobbies! It's great to hear you got the wifi menu working with OpenWRT, please post a screenshot!

 

I don't think the DNS issues will be too sinister, I'll fire up my Mac today and check my settings. But can you at least hit websites by IP address? e.g. 17.253.144.10 (apple.com - but you'll just get an error page)

Hi @ants

 

I got it working, this is how:

1. did a full reset of the router, holding reset for 10 seconds.

2. Once connected, plugged into my main pc with ethernet and went to 192.168.8.1

3. Set my password etc, then entered the main screen

--- this is where I did something different ---

4. At the bottom where it says 'Repeater' I clicked 'Scan networks'

5. I clicked the drop-down list and selected my local wifi, connected

6. Tested connectivity on my pc, works, no problems

7.  ssh into the mini router to install JsonRpc

--- unplug from main pc, plug into mac ---

8. First tested the internet, was working just the same as it was on my main pc

9. I noticed the wifi extension hadn't properly connected yet, as this was just running off previous settings, so I clicked 'settings' and 'ok'.

10. Wifi extension displayed my local wifi as not connected, I clicked connect and typed my password

11. It connected, and the internet continued to work

- note - the _only_ time I needed to enter the advanced Luci interface was to go to 'Software' and click 'Update lists' so that the ssh could install Json.

 

So it seems the magical difference was number 4 - actually connect it to your wifi under the repeater section first. Previously I was not doing this and instead was plugging it into my network with the WAN port. Oh and it seems my 3com 589 pcmcia card in my Powerbook190 works fine without having to mess around with ethtool and port swapping.

 

Hope this helps anyone else...

Edited by stormy
Link to post
Share on other sites

Well done! It looks great and thank you for the detailed steps. Maybe you should try out the MacPlayer Spotify client? (https://github.com/antscode/MacPlayer) :tongue: You're probably the only other person in the world apart for me who's got the MacWifi extension working with OpenWRT :grin:

 

You just need to follow the additional steps to install stunnel on the OpenWRT router...

Link to post
Share on other sites
4 minutes ago, ants said:

You're probably the only other person in the world apart for me who's got the MacWifi extension working with OpenWRT :grin:

I had it working with a G3 iMac and OpenWRT device - it’s an awesome extension!

 

I seem to recall some issue getting stunnel set up on my OpenWRT device, so I never got Spotify working... yet. When I get the time, hopefully it’ll happen.

Link to post
Share on other sites
  • 2 weeks later...

@ants I'm wondering if your extension could be ported to OS X? I have a similar setup on my G4 cube which uses an internal wifi travel router, but being able to select network etc would be bliss.

 

ps - there is a small bug in the extension (I think?) when trying to shutdown the Mac it will say 'Cannot shut down due to open apps' the first time, then when I press shutdown a second time it works. I am pretty sure it's the extension causing this behavior.

Edited by stormy
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...